mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Arnaldo Carvalho de Melo <acme@ghostprotocols.net>
To: David Ahern <dsahern@gmail.com>
Cc: Namhyung Kim <namhyung.kim@lge.com>,
	Peter Zijlstra <a.p.zijlstra@chello.nl>,
	Paul Mackerras <paulus@samba.org>, Ingo Molnar <mingo@redhat.com>,
	Namhyung Kim <namhyung@gmail.com>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 3/3] perf target: Add need_mmap field
Date: Wed, 16 May 2012 12:50:01 -0300	[thread overview]
Message-ID: <20120516155000.GF7864@infradead.org> (raw)
In-Reply-To: <4FB3C895.1050508@gmail.com>

Em Wed, May 16, 2012 at 09:32:37AM -0600, David Ahern escreveu:
> On 5/16/12 9:28 AM, Arnaldo Carvalho de Melo wrote:
> >Em Wed, May 16, 2012 at 06:45:49PM +0900, Namhyung Kim escreveu:
> >>If perf doesn't mmap on event (like perf stat), it
> >>should not create per-task-per-cpu events. So just
> >>use a dummy cpu map to create a per-task event for
> >>this case.
> >
> >Humm, perhaps target.no_mmap is better? I.e. just perf-stat would set
> >it.
> >
> 
> That gets back to the potential double negation Ingo frowns upon (!no_mmap).

Ok, but this really doesn't feel like a good name :-\ Short of ideas
now tho.

- Arnaldo

  reply	other threads:[~2012-05-16 15:50 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-05-16  9:45 [PATCH 1/3] perf target: Rename functions to avoid double negation Namhyung Kim
2012-05-16  9:45 ` [PATCH 2/3] Revert 'perf evlist: Fix creation of cpu map' Namhyung Kim
2012-05-16 15:26   ` Arnaldo Carvalho de Melo
2012-05-17  8:57     ` Namhyung Kim
2012-05-17  9:03       ` Namhyung Kim
2012-05-21  7:38   ` [tip:perf/core] " tip-bot for Namhyung Kim
2012-05-16  9:45 ` [PATCH 3/3] perf target: Add need_mmap field Namhyung Kim
2012-05-16 15:28   ` Arnaldo Carvalho de Melo
2012-05-16 15:32     ` David Ahern
2012-05-16 15:50       ` Arnaldo Carvalho de Melo [this message]
2012-05-21  7:39   ` [tip:perf/core] perf target: Add uses_mmap field tip-bot for Namhyung Kim
2012-05-21  7:37 ` [tip:perf/core] perf target: Rename functions to avoid double negation tip-bot for Namhyung Kim

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20120516155000.GF7864@infradead.org \
    --to=acme@ghostprotocols.net \
    --cc=a.p.zijlstra@chello.nl \
    --cc=dsahern@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=namhyung.kim@lge.com \
    --cc=namhyung@gmail.com \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome