From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1762102Ab2FHKzT (ORCPT ); Fri, 8 Jun 2012 06:55:19 -0400 Received: from mail-pb0-f46.google.com ([209.85.160.46]:54449 "EHLO mail-pb0-f46.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1760459Ab2FHKzR (ORCPT ); Fri, 8 Jun 2012 06:55:17 -0400 Date: Fri, 8 Jun 2012 19:55:07 +0900 From: Minchan Kim To: David Rientjes Cc: Ben Hutchings , linux-kernel@vger.kernel.org, stable@vger.kernel.org, torvalds@linux-foundation.org, akpm@linux-foundation.org, alan@lxorguk.ukuu.org.uk, Minchan Kim Subject: Re: [ 31/82] mm/vmalloc.c: change void* into explict vm_struct* Message-ID: <20120608105506.GB2185@barrios> References: <20120608041845.013957176@decadent.org.uk> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Jun 08, 2012 at 03:41:57AM -0700, David Rientjes wrote: > On Fri, 8 Jun 2012, Ben Hutchings wrote: > > > 3.2-stable review patch. If anyone has any objections, please let me know. > > > > ------------------ > > > > From: Minchan Kim > > > > commit db1aecafef58b5dda39c4228debe2c845e4a27ab upstream. > > > > vmap_area->private is void* but we don't use the field for various purpose > > but use only for vm_struct. So change it to a vm_struct* with naming to > > improve for readability and type checking. > > > > Signed-off-by: Minchan Kim > > Acked-by: David Rientjes > > Signed-off-by: Andrew Morton > > Signed-off-by: Linus Torvalds > > Signed-off-by: Ben Hutchings > > I'm not sure this is stable material and it wasn't annotated as such when > it was commited, why should someone need to upgrade their 3.2 for a patch > like this? I agree. It's not a stable material. Thanks.