From: Taku Izumi <izumi.taku@jp.fujitsu.com>
To: Jiang Liu <jiang.liu@huawei.com>
Cc: Bjorn Helgaas <bhelgaas@google.com>,
Yinghai Lu <yinghai@kernel.org>,
Kenji Kaneshige <kaneshige.kenji@jp.fujitsu.com>,
Jiang Liu <liuj97@gmail.com>, Don Dutile <ddutile@redhat.com>,
Greg KH <gregkh@linuxfoundation.org>,
Yijing Wang <wangyijing@huawei.com>,
Keping Chen <chenkeping@huawei.com>,
linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [RFC PATCH v1 1/6] PCI: change PCI device management logic to better follow device model
Date: Thu, 14 Jun 2012 18:18:44 +0900 [thread overview]
Message-ID: <20120614181844.760bc0c7.izumi.taku@jp.fujitsu.com> (raw)
In-Reply-To: <1338787022-400-1-git-send-email-jiang.liu@huawei.com>
Hi Jiang,
Looks good for me.
Best regards,
Taku Izumi
On Mon, 04 Jun 2012 13:16:57 +0800
Jiang Liu <jiang.liu@huawei.com> wrote:
> From: Jiang Liu <liuj97@gmail.com>
>
> According to device model documentation, the way to add/remove device
> object should be symmetric.
>
> /**
> * device_del - delete device from system.
> * @dev: device.
> *
> * This is the first part of the device unregistration
> * sequence. This removes the device from the lists we control
> * from here, has it removed from the other driver model
> * subsystems it was added to in device_add(), and removes it
> * from the kobject hierarchy.
> *
> * NOTE: this should be called manually _iff_ device_add() was
> * also called manually.
> */
>
> The rule here is to either use
> 1) device_register()/device_unregister()
> or
> 2) device_initialize()/device_add()/device_del()/put_device().
>
> So change PCI core to follow the rule and get rid of the redundant
> pci_dev_get()/pci_dev_put() pair.
>
> Signed-off-by: Jiang Liu <liuj97@gmail.com>
> ---
> drivers/pci/probe.c | 1 -
> drivers/pci/remove.c | 4 ++--
> 2 files changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
> index 0840409..dacca26 100644
> --- a/drivers/pci/probe.c
> +++ b/drivers/pci/probe.c
> @@ -1294,7 +1294,6 @@ void pci_device_add(struct pci_dev *dev, struct pci_bus *bus)
> {
> device_initialize(&dev->dev);
> dev->dev.release = pci_release_dev;
> - pci_dev_get(dev);
>
> dev->dev.dma_mask = &dev->dma_mask;
> dev->dev.dma_parms = &dev->dma_parms;
> diff --git a/drivers/pci/remove.c b/drivers/pci/remove.c
> index 04a4861..6c07bc5 100644
> --- a/drivers/pci/remove.c
> +++ b/drivers/pci/remove.c
> @@ -22,7 +22,7 @@ static void pci_stop_dev(struct pci_dev *dev)
> if (dev->is_added) {
> pci_proc_detach_device(dev);
> pci_remove_sysfs_dev_files(dev);
> - device_unregister(&dev->dev);
> + device_del(&dev->dev);
> dev->is_added = 0;
> }
>
> @@ -40,7 +40,7 @@ static void pci_destroy_dev(struct pci_dev *dev)
> up_write(&pci_bus_sem);
>
> pci_free_resources(dev);
> - pci_dev_put(dev);
> + put_device(&dev->dev);
> }
>
> /**
> --
> 1.7.1
>
>
>
next prev parent reply other threads:[~2012-06-14 9:18 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-06-04 5:16 Jiang Liu
2012-06-04 5:16 ` [RFC PATCH v1 2/6] PCI: split PCI bus device registration into two stages Jiang Liu
2012-06-04 5:16 ` [RFC PATCH v1 3/6] PCI, ACPI: correctly update binding info when PCI hotplug event happens Jiang Liu
2012-06-04 5:17 ` [RFC PATCH v1 4/6] PCI, ACPI: update PCI slot information " Jiang Liu
2012-06-04 5:17 ` [RFC PATCH v1 5/6] PCI, ACPI: update ACPI hotplug " Jiang Liu
2012-06-04 5:17 ` [RFC PATCH v1 6/6] PCI: update AER configuration " Jiang Liu
2012-06-14 9:18 ` Taku Izumi [this message]
2012-08-15 20:21 ` [RFC PATCH v1 1/6] PCI: change PCI device management logic to better follow device model Bjorn Helgaas
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20120614181844.760bc0c7.izumi.taku@jp.fujitsu.com \
--to=izumi.taku@jp.fujitsu.com \
--cc=bhelgaas@google.com \
--cc=chenkeping@huawei.com \
--cc=ddutile@redhat.com \
--cc=gregkh@linuxfoundation.org \
--cc=jiang.liu@huawei.com \
--cc=kaneshige.kenji@jp.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=liuj97@gmail.com \
--cc=wangyijing@huawei.com \
--cc=yinghai@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®