On Thu, Jul 19, 2012 at 09:04:44AM +0000, Kim, Milo wrote: > + * @irq_type: Interrupt register type. masked or enabled > */ > struct regmap_irq_chip { > const char *name; > @@ -304,6 +311,8 @@ struct regmap_irq_chip { > > const struct regmap_irq *irqs; > int num_irqs; > + > + enum regirq_type irq_type; This naming is very unclear - it's not about the interrupt itself, it's about the mask for the interrupt. This would more normally be covered by marking the masks as being inverted rather than something like this.