From: Borislav Petkov <bp@amd64.org>
To: Ming Lei <ming.lei@canonical.com>
Cc: Linus Torvalds <torvalds@linux-foundation.org>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
"Rafael J. Wysocki" <rjw@sisk.pl>,
linux-kernel@vger.kernel.org
Subject: Re: [RFC PATCH 06/13] driver core: firmware loader: always let firmware_buf own the pages buffer
Date: Wed, 25 Jul 2012 18:02:21 +0200 [thread overview]
Message-ID: <20120725160221.GJ11152@aftab.osrc.amd.com> (raw)
In-Reply-To: <1343149213-10160-7-git-send-email-ming.lei@canonical.com>
On Wed, Jul 25, 2012 at 01:00:06AM +0800, Ming Lei wrote:
> @@ -750,6 +835,7 @@ request_firmware_nowait(
while you're here, can you fix the arg alignment of this
request_firmware_nowait - it looks awful right now:
int
request_firmware_nowait(
struct module *module, bool uevent,
const char *name, struct device *device, gfp_t gfp, void *context,
void (*cont)(const struct firmware *fw, void *context))
{
and it could like, say, this:
int request_firmware_nowait(struct module *module, bool uevent, const char *name,
struct device *device, gfp_t gfp, void *context,
void (*cont)(const struct firmware *fw, void *context))
{
or something even more readable.
> static int __init firmware_class_init(void)
> {
> + fw_cache_init();
> return class_register(&firmware_class);
> }
>
> diff --git a/include/linux/firmware.h b/include/linux/firmware.h
> index 1e7c011..e85b771 100644
> --- a/include/linux/firmware.h
> +++ b/include/linux/firmware.h
> @@ -12,6 +12,9 @@ struct firmware {
> size_t size;
> const u8 *data;
> struct page **pages;
> +
> + /* firmware loader private fields */
> + void *priv;
> };
>
> struct module;
Thanks.
--
Regards/Gruss,
Boris.
Advanced Micro Devices GmbH
Einsteinring 24, 85609 Dornach
GM: Alberto Bozzo
Reg: Dornach, Landkreis Muenchen
HRB Nr. 43632 WEEE Registernr: 129 19551
next prev parent reply other threads:[~2012-07-25 16:02 UTC|newest]
Thread overview: 62+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-07-24 17:00 [RFC PATCH 00/13] firmware loader: introduce cache/uncache firmware Ming Lei
2012-07-24 17:00 ` [RFC PATCH 01/13] driver core: firmware loader: simplify pages ownership transfer Ming Lei
2012-07-24 18:10 ` Borislav Petkov
2012-07-25 2:49 ` Ming Lei
2012-07-24 17:00 ` [RFC PATCH 02/13] driver core: firmware loader: fix races during loading firmware Ming Lei
2012-07-24 17:00 ` [RFC PATCH 03/13] driver core: firmware loader: remove unnecessary wmb() Ming Lei
2012-07-24 17:00 ` [RFC PATCH 04/13] driver core: firmware loader: fix creation failure of fw loader device Ming Lei
2012-07-24 17:00 ` [RFC PATCH 05/13] driver core: firmware loader: introduce firmware_buf Ming Lei
2012-07-25 13:59 ` Borislav Petkov
2012-07-26 2:51 ` Ming Lei
2012-07-26 10:08 ` Borislav Petkov
2012-07-24 17:00 ` [RFC PATCH 06/13] driver core: firmware loader: always let firmware_buf own the pages buffer Ming Lei
2012-07-25 7:55 ` Stephen Boyd
2012-07-25 14:37 ` Borislav Petkov
2012-08-03 8:34 ` Ming Lei
2012-07-25 16:02 ` Borislav Petkov [this message]
2012-07-25 16:13 ` Borislav Petkov
2012-07-24 17:00 ` [RFC PATCH 07/13] driver core: firmware loader: introduce cache_firmware and uncache_firmware Ming Lei
2012-07-25 7:54 ` Stephen Boyd
2012-07-26 2:34 ` Ming Lei
2012-07-25 15:52 ` Borislav Petkov
2012-07-26 2:40 ` Ming Lei
2012-07-24 17:00 ` [RFC PATCH 08/13] driver core: firmware loader: fix device lifetime Ming Lei
2012-07-25 16:04 ` Borislav Petkov
2012-07-26 2:59 ` Ming Lei
2012-07-26 12:20 ` Borislav Petkov
2012-07-26 15:44 ` Ming Lei
2012-07-26 17:46 ` Borislav Petkov
2012-07-27 1:30 ` Ming Lei
2012-07-27 10:32 ` Borislav Petkov
2012-07-28 14:04 ` Ming Lei
2012-07-24 17:00 ` [RFC PATCH 09/13] driver core: firmware loader: store firmware name into devres list Ming Lei
2012-07-25 16:15 ` Borislav Petkov
2012-07-26 15:15 ` Ming Lei
2012-07-24 17:00 ` [RFC PATCH 10/13] driver core: devres: introduce devres_for_each_res Ming Lei
2012-07-25 16:25 ` Borislav Petkov
2012-07-26 16:51 ` Ming Lei
2012-07-24 17:00 ` [RFC PATCH 11/13] driver core: firmware: introduce devices_cache/uncache_firmwares Ming Lei
2012-07-25 16:52 ` Borislav Petkov
2012-07-26 15:36 ` Ming Lei
2012-07-24 17:00 ` [RFC PATCH 12/13] driver core: firmware loader: use small timeout for cache device firmware Ming Lei
2012-07-26 12:36 ` Borislav Petkov
2012-07-26 15:48 ` Ming Lei
2012-07-26 17:54 ` Borislav Petkov
2012-07-27 1:54 ` Ming Lei
2012-07-27 10:35 ` Borislav Petkov
2012-07-28 13:58 ` Ming Lei
2012-07-24 17:00 ` [RFC PATCH 13/13] driver core: firmware loader: cache devices firmware during suspend/resume cycle Ming Lei
2012-07-26 12:43 ` Borislav Petkov
2012-07-26 15:49 ` Ming Lei
2012-07-24 17:08 ` [RFC PATCH 00/13] firmware loader: introduce cache/uncache firmware Ming Lei
2012-07-24 17:16 ` Linus Torvalds
2012-07-24 17:47 ` Ming Lei
2012-07-24 17:53 ` Linus Torvalds
2012-07-24 17:54 ` Linus Torvalds
2012-07-25 12:35 ` Ming Lei
2012-07-25 12:43 ` Oliver Neukum
2012-07-25 12:50 ` Ming Lei
2012-07-25 12:59 ` Ming Lei
2012-07-25 17:23 ` Linus Torvalds
2012-07-25 19:02 ` Rafael J. Wysocki
2012-07-26 2:29 ` Ming Lei
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20120725160221.GJ11152@aftab.osrc.amd.com \
--to=bp@amd64.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=ming.lei@canonical.com \
--cc=rjw@sisk.pl \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®