mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Michal Hocko <mhocko@suse.cz>
To: Viresh Kumar <viresh.kumar@linaro.org>
Cc: rjw@sisk.pl, tglx@linutronix.de, cpufreq@vger.kernel.org,
	linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org,
	linaro-dev@lists.linaro.org, patches@linaro.org,
	Robin.Randhawa@arm.com
Subject: Re: [PATCH] cpufreq: timer: Move tick-sched specific code outside of cpufreq governors
Date: Mon, 15 Oct 2012 10:51:37 +0200	[thread overview]
Message-ID: <20121015085137.GD29069@dhcp22.suse.cz> (raw)
In-Reply-To: <CAKohponUigqKOkj3i2=LDgVG0bi4dXsbrJCDpzv6M3k1E_Y6Ew@mail.gmail.com>

On Mon 15-10-12 14:11:53, Viresh Kumar wrote:
> On 15 October 2012 14:05, Michal Hocko <mhocko@suse.cz> wrote:
[...]
> > I would suggest moving the common functionality into drivers/cpufreq/
> > (e.g. cpufreq_common.c).
> 
> Initially i did that only, but then thought these routines must be present in
> more generic files if possible, available across frameworks.
> 
> Can we try renaming these to show there exact functionality and then put
> them in generic files like, tick-sched.c?

But we already do have generic generic functionality for nohz case
get_cpu_{idle,iowait}_time_us and kcpustat_cpu for !nohz. The only one
that cares for both is /proc/stat code and it has its own helpers
get_{idle,iowait}_time and as you can see it's demands are different
from what governors want.

-- 
Michal Hocko
SUSE Labs

      reply	other threads:[~2012-10-15  8:51 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-10-15  8:11 Viresh Kumar
2012-10-15  8:35 ` Michal Hocko
2012-10-15  8:41   ` Viresh Kumar
2012-10-15  8:51     ` Michal Hocko [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20121015085137.GD29069@dhcp22.suse.cz \
    --to=mhocko@suse.cz \
    --cc=Robin.Randhawa@arm.com \
    --cc=cpufreq@vger.kernel.org \
    --cc=linaro-dev@lists.linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=patches@linaro.org \
    --cc=rjw@sisk.pl \
    --cc=tglx@linutronix.de \
    --cc=viresh.kumar@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®