From: Josh Cartwright <josh.cartwright@ni.com>
To: Michal Simek <michal.simek@xilinx.com>
Cc: Arnd Bergmann <arnd@arndb.de>,
"monstr@monstr.eu" <monstr@monstr.eu>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"arm@kernel.org" <arm@kernel.org>,
Thomas Gleixner <tglx@linutronix.de>
Subject: Re: [PATCH] ARM: zynq: move ttc timer code to drivers/clocksource
Date: Wed, 31 Oct 2012 06:35:13 -0600 [thread overview]
Message-ID: <20121031123513.GJ5190@beefymiracle.amer.corp.natinst.com> (raw)
In-Reply-To: <2b8e9679-dade-4448-8c16-362de455ead0@AM1EHSMHS002.ehs.local>
[-- Attachment #1: Type: text/plain, Size: 1938 bytes --]
On Wed, Oct 31, 2012 at 08:48:38AM +0000, Michal Simek wrote:
> From: Arnd Bergmann [mailto:arnd@arndb.de]
> > On Tuesday 30 October 2012, Michal Simek wrote:
> > > On 10/29/2012 07:56 PM, Josh Cartwright wrote:
[..]
> >
> > > > delete mode 100644 arch/arm/mach-zynq/common.h
> > > > delete mode 100644 arch/arm/mach-zynq/timer.c
> > > > create mode 100644 drivers/clocksource/xilinx_ttc.c
> > > > create mode 100644 include/linux/xilinx_ttc.h
> > >
> > > Really?
> > > If yes. shouldn't be there any better naming convention especially
> > > for headers. linux/clocksource/xilinx_ttc.h.
> >
> > Moving it is certainly the right direction, but I think we need a
> > better way to handle those forward declarations. "struct sys_timer"
> > is actually an ARM specific structure, so we might just want to add
> > all the forward declarations for the timers into
> > arch/arm/include/asm/mach/time.h. It's not ideal to do it like that,
> > but I think it's much better than having a new globally visible
> > header for each timer that is used on ARM.
> >
> > Eventually, we might want to do something similar to what we are
> > discussing for the top-level IRQ controllers at the moment, where we
> > just autodetect them from DT if possible, so we don't need to have
> > any pointer to the timer from arch code at all.
>
> Ok. It means that it is not big deal to keep timer as is in mach and
> when we have any generic solution we can follow it. This patch just
> move the code out of mach-zynq. It should be done across architecture
> because for example timer I use for microblaze can be used by zynq
> too, also by Xilinx ppc.
That all makes sense. Since posting, I've had to rework this a bit for
getting COMMON_CLK support working with the TTC. I'll pull this patch
(in proper form, and with some slight modifications) into my pending
COMMON_CLK support patchset.
Thanks,
Josh
[-- Attachment #2: Type: application/pgp-signature, Size: 836 bytes --]
prev parent reply other threads:[~2012-10-31 12:35 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-10-29 18:56 Josh Cartwright
2012-10-30 11:36 ` Michal Simek
2012-10-30 22:36 ` Arnd Bergmann
2012-10-31 8:48 ` Michal Simek
2012-10-31 12:35 ` Josh Cartwright [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20121031123513.GJ5190@beefymiracle.amer.corp.natinst.com \
--to=josh.cartwright@ni.com \
--cc=arm@kernel.org \
--cc=arnd@arndb.de \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=michal.simek@xilinx.com \
--cc=monstr@monstr.eu \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®