From: Tejun Heo <tj@kernel.org>
To: Vivek Goyal <vgoyal@redhat.com>
Cc: linux-kernel@vger.kernel.org, axboe@kernel.dk, jmoyer@redhat.com
Subject: Re: [PATCH 2/6] cfq-iosched: More renaming to better represent wl_class and wl_type
Date: Thu, 6 Dec 2012 11:17:06 -0800 [thread overview]
Message-ID: <20121206191706.GA3676@htj.dyndns.org> (raw)
In-Reply-To: <1349297821-30078-3-git-send-email-vgoyal@redhat.com>
On Wed, Oct 03, 2012 at 04:56:57PM -0400, Vivek Goyal wrote:
> Some more renaming. Again making the code uniform w.r.t use of
> wl_class/class to represent IO class (RT, BE, IDLE) and using
> wl_type/type to represent subclass (SYNC, SYNC-IDLE, ASYNC).
>
> At places this patch shortens the string "workload" to "wl".
> Renamed "saved_workload" to "saved_wl_type". Renamed
> "saved_serving_class" to "saved_wl_class".
>
> For uniformity with "saved_wl_*" variables, renamed "serving_class"
> to "serving_wl_class" and renamed "serving_type" to "serving_wl_type".
>
> Again, just trying to improve upon code uniformity and improve
> readability. No functional change.
>
> v2:
> - Restored the usage of keyword "service" based on Jeff Moyer's feedback.
>
> Signed-off-by: Vivek Goyal <vgoyal@redhat.com>
Acked-by: Tejun Heo <tj@kernel.org>
Thanks.
--
tejun
next prev parent reply other threads:[~2012-12-06 19:24 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-10-03 20:56 [PATCH 0/6] cfq-iosched: Some minor cleanups Vivek Goyal
2012-10-03 20:56 ` [PATCH 1/6] cfq-iosched: Properly name all references to IO class Vivek Goyal
2012-10-03 20:56 ` [PATCH 2/6] cfq-iosched: More renaming to better represent wl_class and wl_type Vivek Goyal
2012-12-06 19:17 ` Tejun Heo [this message]
2012-10-03 20:56 ` [PATCH 3/6] cfq-iosched: Rename "service_tree" to "st" at some places Vivek Goyal
2012-12-06 19:18 ` Tejun Heo
2012-10-03 20:56 ` [PATCH 4/6] cfq-iosched: Rename few functions related to selecting workload Vivek Goyal
2012-12-06 19:19 ` Tejun Heo
2012-10-03 20:57 ` [PATCH 5/6] cfq-iosched: Get rid of unnecessary local variable Vivek Goyal
2012-12-06 19:20 ` Tejun Heo
2012-10-03 20:57 ` [PATCH 6/6] cfq-iosched: Print sync-noidle information in blktrace messages Vivek Goyal
2012-12-06 19:21 ` Tejun Heo
2012-12-06 19:23 ` [PATCH 0/6] cfq-iosched: Some minor cleanups Tejun Heo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20121206191706.GA3676@htj.dyndns.org \
--to=tj@kernel.org \
--cc=axboe@kernel.dk \
--cc=jmoyer@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=vgoyal@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome