From: Borislav Petkov <bp@alien8.de>
To: Yinghai Lu <yinghai@kernel.org>
Cc: "H. Peter Anvin" <hpa@zytor.com>,
Thomas Gleixner <tglx@linutronix.de>, Ingo Molnar <mingo@elte.hu>,
"Eric W. Biederman" <ebiederm@xmission.com>,
Andrew Morton <akpm@linux-foundation.org>,
Jan Kiszka <jan.kiszka@web.de>,
Jason Wessel <jason.wessel@windriver.com>,
linux-kernel@vger.kernel.org, Rob Landley <rob@landley.net>,
Matt Fleming <matt.fleming@intel.com>,
Gokul Caushik <caushik1@gmail.com>,
Josh Triplett <josh@joshtriplett.org>,
Joe Millenbach <jmillenbach@gmail.com>
Subject: Re: [PATCH v7u1 22/31] x86, boot: add fields to support load bzImage and ramdisk above 4G
Date: Tue, 15 Jan 2013 20:49:18 +0100 [thread overview]
Message-ID: <20130115194918.GD8101@liondog.tnic> (raw)
In-Reply-To: <CAE9FiQUz6t_hK11X9ra5pj2DwJsNCu=cZJ7TYGR1ry-rvwSmjg@mail.gmail.com>
On Tue, Jan 15, 2013 at 10:43:38AM -0800, Yinghai Lu wrote:
> I only change lines according to the response that i could understand
> and i think that is right.
And those you don't understand and/or don't think are right, you simply
ignore? How about asking if you don't understand them? How about saying
that you don't agree with them so that we can talk it out as it is the
case on lkml normally?
> are you looking wrong place?
>
> http://git.kernel.org/?p=linux/kernel/git/yinghai/linux-yinghai.git;a=commitdiff;h=fd6da054a055aea9cf265a005563073ada6e1af0
>
> x86, 64bit, realmode: Use init_level4_pgt to set trapmoline_pgd directly
> author Yinghai Lu <yinghai@kernel.org>
> Tue, 15 Jan 2013 05:11:07 +0000 (21:11 -0800)
> committer Yinghai Lu <yinghai@kernel.org>
> Tue, 15 Jan 2013 05:11:07 +0000 (21:11 -0800)
> with #PF handler way to set early page table, level3_ident will go away with
> 64bit native path.
>
> So just use entries in init_level4_pgt to set them in tramopline_pgd
^^^^^^^^^^^^^^
No, I'm looking at the right place, you're not seeing it:
Let me show you once again:
tramopline_pgd
trapmoline_pgd
See the letter swap?
> > * [PATCH 08/31] x86, 64bit: early #PF handler set page table
> > - almost no changes, SOB chain still wrong
>
> HPA and I have explained that to you.
No, hpa commented only on the handful commits without SOB. But if he's
fine with having only your SOB, then ok.
> http://lkml.org/lkml/2013/1/12/115
>
> >
> > * [PATCH 12/31] x86: add get_ramdisk_image/size()
> > - no change
>
> I respond: will insert other lines between them.
Again: I'm not talking about spacing the functions (but that would be
good too). Here's what I would like to see (btw, I'm explaining this for
the third time):
static u64 __init get_ramdisk_image(void)
{
return (u64)boot_params.hdr.ramdisk_image;
}
static u64 __init get_ramdisk_size(void)
{
return (u64)boot_params.hdr.ramdisk_size;
}
No need for the useless variable declaration and improved readability -
a win-win situation.
> > * [PATCH 13/31] x86, boot: add get_cmd_line_ptr()
> > - no change
>
> same above
And I say too "same as above".
> > * [PATCH 14/31] x86, boot: move checking of cmd_line_ptr out of common path
> > - no change
>
> same above
No, this is not same as above - I'd simply like to have the comment
explaining why we do the >= 0x100000 check in the code.
> > * [PATCH 20/31] x86, kexec: replace ident_mapping_init and init_level4_page
> > - no change
>
> https://patchwork.kernel.org/patch/1930741/
>
> I pointed you about the grammar. ...
And I said:
"And yet, this is not the point - the point is that this code is
complicated enough as it is so why not make the easy things trivial so
that people looking at it months or even years from now can still try to
understand it.
So what it is defined by the standard?! Just add that line anyway! Then
there's no need to go check what was meant. This way it is *there*,
*explicit* and everyone *knows* what is meant - even people who don't
sleep with C99std under their pillow."
IOW, add the initialization *anyways*!
> > * [PATCH 21/31] x86, kexec: only set ident mapping for ram.
> > - almost
>
> almost what?
That it is almost fixed:
"This patch exposes THE pfn_mapped array..."
"This patch relies on new THE kernel_ident_mapping_init..."
The "THE" in capital letters are missing.
This is what I mean: you take my comments but not really - you still
change them on the way and make the text funny.
> > * [PATCH 22/31] x86, boot: add fields to support load bzImage and ramdisk above 4G
> > - except sentinel, almost no change
>
> ?
Well, I'm not going to repeat myself ad infinitum and ad absurdum - go
look at the mail thread and read my comments I had and then look at your
commit message again.
> > * [PATCH 23/31] x86, boot: update comments about entries for 64bit image
> > - almost no change
>
> I explained that i copied that from 32bit, and if you want to change
> with 32bit need to do that later.
You're adding new text and we want it to be as clean as possible.
According to your logic, if you copy/paste code from the kernel and it
has a bug, the newly pasted portion would have that same bug too and you
won't fix it and let someone else fix it? Even though I told you how to
fix it?
So why don't you simply integrate my suggestions verbatim into the text
instead of opposing so much? I'm not forcing you to do anything bad -
I'm simply commenting on your work so that it can get better. Why the
hell are you still opposing to that?
> >> +The memory for struct boot_params should be allocated under or above
> >> +4G and initialized to all zero.
> >
> > I suggested:
> >
> > "Memory for struct boot_params may be allocated anywhere (even above
> > 4G). This memory must be zeroed out."
> >
> > You changed it to:
> >
> > "The memory for struct boot_params could be allocated anywhere (even
> > above 4G) and initialized to all zero."
> >
> > which still reads funny and has a couple of issues.
>
> did not see anything wrong.
That's why I'M POINTING IT TO YOU! TO FUCKING SEE IT! So if you still
don't see anything wrong, simply take my suggestions as they are,
without changing them on the fly and stop debating.
Btw, if you'd taken the time to simply add those requested changes
instead of stubbornly and uselessy debating, we would've been done by
now.
Thanks.. but no thanks.
--
Regards/Gruss,
Boris.
Sent from a fat crate under my desk. Formatting is fine.
--
next prev parent reply other threads:[~2013-01-15 19:49 UTC|newest]
Thread overview: 199+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-01-04 0:48 [PATCH v7u1 00/31] x86, boot, 64bit: Add support for loading ramdisk and bzImage " Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 01/31] x86, mm: Fix page table early allocation offset checking Yinghai Lu
2013-01-04 7:17 ` Borislav Petkov
2013-01-04 21:50 ` Yinghai Lu
2013-01-05 13:05 ` Borislav Petkov
2013-01-15 12:27 ` Stefano Stabellini
2013-01-04 0:48 ` [PATCH v7u1 02/31] x86, 64bit, mm: make pgd next calculation consistent with pud/pmd Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 03/31] x86, realmode: set real_mode permissions early Yinghai Lu
2013-01-04 20:15 ` Borislav Petkov
2013-01-04 20:58 ` Yinghai Lu
2013-01-04 21:04 ` Borislav Petkov
2013-01-04 22:13 ` Yinghai Lu
2013-01-05 13:25 ` Borislav Petkov
2013-01-07 12:40 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 04/31] x86, 64bit, mm: add generic kernel/ident mapping helper Yinghai Lu
2013-01-04 21:19 ` Borislav Petkov
2013-01-04 22:19 ` Yinghai Lu
2013-01-05 13:21 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 05/31] x86, 64bit: copy zero-page early Yinghai Lu
2013-01-07 15:53 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 06/31] x86, 64bit, realmode: use init_level4_pgt to set trapmoline_pgt directly Yinghai Lu
2013-01-04 17:18 ` Sakkinen, Jarkko
2013-01-04 22:01 ` Yinghai Lu
2013-01-05 9:59 ` Sakkinen, Jarkko
2013-01-07 15:54 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 07/31] x86, realmode: Separate real_mode reserve and setup Yinghai Lu
2013-01-04 17:18 ` Sakkinen, Jarkko
2013-01-07 15:54 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 08/31] x86, 64bit: early #PF handler set page table Yinghai Lu
2013-01-07 15:55 ` Borislav Petkov
2013-01-10 1:56 ` Yinghai Lu
2013-01-10 12:19 ` Borislav Petkov
2013-01-10 17:05 ` Yinghai Lu
2013-01-10 20:27 ` Borislav Petkov
2013-01-12 22:04 ` H. Peter Anvin
2013-01-04 0:48 ` [PATCH v7u1 09/31] x86, 64bit: #PF handler set page to cover 2M only Yinghai Lu
2013-01-09 22:57 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 10/31] x86, 64bit: Don't set max_pfn_mapped wrong value early on native path Yinghai Lu
2013-01-11 12:13 ` Borislav Petkov
2013-01-11 16:42 ` Yinghai Lu
2013-01-11 16:52 ` Borislav Petkov
2013-01-15 13:48 ` Stefano Stabellini
2013-01-15 15:22 ` Konrad Rzeszutek Wilk
2013-01-15 15:59 ` Stefano Stabellini
2013-01-15 16:37 ` Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 11/31] x86: Merge early_reserve_initrd for 32bit and 64bit Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 12/31] x86: add get_ramdisk_image/size() Yinghai Lu
2013-01-07 15:56 ` Borislav Petkov
2013-01-10 1:53 ` Yinghai Lu
2013-01-10 12:13 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 13/31] x86, boot: add get_cmd_line_ptr() Yinghai Lu
2013-01-07 15:56 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 14/31] x86, boot: move checking of cmd_line_ptr out of common path Yinghai Lu
2013-01-07 16:00 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 15/31] x86, boot: pass cmd_line_ptr with unsigned long instead Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 16/31] x86, boot: move verify_cpu.S and no_longmode down Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 17/31] x86, boot: Move lldt/ltr out of 64bit code section Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 18/31] x86, kexec: remove 1024G limitation for kexec buffer on 64bit Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 19/31] x86, kexec: set ident mapping for kernel that is above max_pfn Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 20/31] x86, kexec: replace ident_mapping_init and init_level4_page Yinghai Lu
2013-01-04 21:01 ` Borislav Petkov
2013-01-04 22:04 ` Yinghai Lu
2013-01-05 13:24 ` Borislav Petkov
2013-01-10 1:26 ` Yinghai Lu
2013-01-10 11:59 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 21/31] x86, kexec: only set ident mapping for ram Yinghai Lu
2013-01-13 12:56 ` Borislav Petkov
2013-01-14 5:46 ` Yinghai Lu
2013-01-14 9:53 ` Borislav Petkov
2013-01-14 18:17 ` Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 22/31] x86, boot: add fields to support load bzImage and ramdisk above 4G Yinghai Lu
2013-01-13 21:41 ` Borislav Petkov
2013-01-14 5:37 ` Yinghai Lu
2013-01-14 9:43 ` Borislav Petkov
2013-01-14 23:06 ` Yinghai Lu
2013-01-14 17:49 ` H. Peter Anvin
2013-01-14 18:57 ` Yinghai Lu
2013-01-14 18:59 ` H. Peter Anvin
2013-01-14 19:19 ` Yinghai Lu
2013-01-14 19:50 ` Yinghai Lu
2013-01-14 19:56 ` H. Peter Anvin
2013-01-14 20:05 ` Yinghai Lu
2013-01-15 6:17 ` Yinghai Lu
2013-01-15 15:50 ` Borislav Petkov
2013-01-15 16:03 ` Yinghai Lu
2013-01-15 16:48 ` Borislav Petkov
2013-01-15 18:43 ` Yinghai Lu
2013-01-15 19:49 ` Borislav Petkov [this message]
2013-01-15 20:16 ` Yinghai Lu
2013-01-15 20:28 ` Borislav Petkov
2013-01-14 20:05 ` Borislav Petkov
2013-01-14 20:14 ` Yinghai Lu
2013-01-14 20:26 ` Borislav Petkov
2013-01-14 22:38 ` Yinghai Lu
2013-01-14 23:11 ` Borislav Petkov
2013-01-15 1:04 ` Yinghai Lu
2013-01-14 23:10 ` H. Peter Anvin
2013-01-14 23:21 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 23/31] x86, boot: update comments about entries for 64bit image Yinghai Lu
2013-01-14 11:20 ` Borislav Petkov
2013-01-14 18:35 ` Yinghai Lu
2013-01-14 18:37 ` Yinghai Lu
2013-01-14 18:46 ` Borislav Petkov
2013-01-14 20:01 ` Yinghai Lu
2013-01-14 18:43 ` Borislav Petkov
2013-01-04 0:48 ` [PATCH v7u1 24/31] x86, boot: Not need to check setup_header version for setup_data Yinghai Lu
2013-01-14 11:26 ` Borislav Petkov
2013-01-14 17:37 ` H. Peter Anvin
2013-01-14 18:04 ` Borislav Petkov
2013-01-14 18:42 ` H. Peter Anvin
2013-01-04 0:48 ` [PATCH v7u1 25/31] memblock: add memblock_mem_size() Yinghai Lu
2013-01-14 20:42 ` H. Peter Anvin
2013-01-14 22:28 ` Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 26/31] x86: Don't enable swiotlb if there is not enough ram for it Yinghai Lu
2013-01-04 16:05 ` Konrad Rzeszutek Wilk
2013-01-04 19:57 ` Yinghai Lu
2013-01-04 17:50 ` Shuah Khan
2013-01-04 20:34 ` Yinghai Lu
2013-01-04 21:02 ` Shuah Khan
2013-01-04 22:10 ` Yinghai Lu
2013-01-04 22:26 ` Shuah Khan
2013-01-04 22:34 ` Yinghai Lu
2013-01-04 22:47 ` Eric W. Biederman
2013-01-04 22:56 ` Shuah Khan
2013-01-04 23:00 ` Yinghai Lu
2013-01-04 23:21 ` Shuah Khan
2013-01-04 23:55 ` Yinghai Lu
2013-01-05 2:02 ` Shuah Khan
2013-01-05 4:10 ` Yinghai Lu
2013-01-05 22:04 ` Shuah Khan
2013-01-04 22:58 ` Yinghai Lu
2013-01-07 15:26 ` Konrad Rzeszutek Wilk
2013-01-07 17:02 ` Shuah Khan
2013-01-07 19:29 ` Konrad Rzeszutek Wilk
2013-01-08 2:22 ` Eric W. Biederman
2013-01-08 2:48 ` Konrad Rzeszutek Wilk
2013-01-08 3:03 ` Eric W. Biederman
2013-01-08 3:01 ` Yinghai Lu
2013-01-08 3:13 ` Eric W. Biederman
2013-01-08 3:50 ` Yinghai Lu
2013-01-08 23:40 ` Yinghai Lu
2013-01-09 0:04 ` Eric W. Biederman
2013-01-09 0:43 ` Konrad Rzeszutek Wilk
2013-01-09 0:56 ` Yinghai Lu
2013-01-09 0:58 ` Eric W. Biederman
2013-01-09 1:07 ` Yinghai Lu
2013-01-09 1:12 ` Yinghai Lu
2013-01-09 2:31 ` Eric W. Biederman
2013-01-09 13:24 ` Konrad Rzeszutek Wilk
2013-01-09 17:27 ` Yinghai Lu
2013-01-09 18:01 ` Shuah Khan
2013-01-09 19:13 ` Yinghai Lu
2013-01-09 21:00 ` Eric W. Biederman
2013-01-09 21:15 ` Yinghai Lu
2013-01-10 23:07 ` Yinghai Lu
2013-01-10 23:15 ` Eric W. Biederman
2013-01-10 23:55 ` Yinghai Lu
2013-01-11 16:35 ` Konrad Rzeszutek Wilk
2013-01-11 16:52 ` Yinghai Lu
2013-01-11 17:49 ` Yinghai Lu
2013-01-15 6:19 ` Yinghai Lu
2013-01-18 15:55 ` Konrad Rzeszutek Wilk
2013-01-24 15:39 ` Konrad Rzeszutek Wilk
2013-01-24 16:51 ` Shuah Khan
2013-01-24 19:22 ` Shuah Khan
2013-01-24 21:50 ` Yinghai Lu
2013-01-29 2:27 ` Shuah Khan
2013-01-29 3:44 ` Yinghai Lu
2013-01-31 19:28 ` Shuah Khan
2013-01-31 19:35 ` H. Peter Anvin
2013-01-09 13:12 ` Konrad Rzeszutek Wilk
2013-01-07 20:32 ` Yinghai Lu
2013-01-07 21:30 ` Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 27/31] x86, kdump: remove crashkernel range find limit for 64bit Yinghai Lu
2013-01-14 15:43 ` Borislav Petkov
2013-01-14 18:18 ` Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 28/31] x86: add Crash kernel low reservation Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 29/31] x86: Merge early kernel reserve for 32bit and 64bit Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 30/31] x86, 64bit, mm: Mark data/bss/brk to nx Yinghai Lu
2013-01-04 0:48 ` [PATCH v7u1 31/31] x86, 64bit, mm: hibernate use generic mapping_init Yinghai Lu
2013-01-04 11:43 ` Rafael J. Wysocki
2013-01-04 21:59 ` Yinghai Lu
2013-01-04 22:07 ` Rafael J. Wysocki
2013-01-04 7:09 ` [PATCH v7u1 00/31] x86, boot, 64bit: Add support for loading ramdisk and bzImage above 4G Borislav Petkov
2013-01-04 21:44 ` Yinghai Lu
2013-01-14 20:45 ` H. Peter Anvin
2013-01-14 22:44 ` Yinghai Lu
2013-01-14 23:16 ` H. Peter Anvin
2013-01-14 23:39 ` David Woodhouse
2013-01-14 23:50 ` H. Peter Anvin
2013-01-15 0:12 ` David Woodhouse
2013-01-15 12:19 ` Stefano Stabellini
2013-01-15 16:43 ` Yinghai Lu
2013-01-15 19:28 ` Yinghai Lu
2013-01-16 11:32 ` Stefano Stabellini
2013-01-16 17:31 ` Yinghai Lu
2013-01-16 17:38 ` H. Peter Anvin
2013-01-16 18:20 ` Yinghai Lu
2013-01-17 2:35 ` Yinghai Lu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130115194918.GD8101@liondog.tnic \
--to=bp@alien8.de \
--cc=akpm@linux-foundation.org \
--cc=caushik1@gmail.com \
--cc=ebiederm@xmission.com \
--cc=hpa@zytor.com \
--cc=jan.kiszka@web.de \
--cc=jason.wessel@windriver.com \
--cc=jmillenbach@gmail.com \
--cc=josh@joshtriplett.org \
--cc=linux-kernel@vger.kernel.org \
--cc=matt.fleming@intel.com \
--cc=mingo@elte.hu \
--cc=rob@landley.net \
--cc=tglx@linutronix.de \
--cc=yinghai@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®