From: Chen Baozi <baozich@gmail.com>
To: Alexandre Courbot <gnurou@gmail.com>
Cc: Grant Likely <grant.likely@secretlab.ca>,
Linus Walleij <linus.walleij@linaro.org>,
Arnd Bergmann <arnd@arndb.de>,
Romain Naour <romain.naour@openwide.fr>,
linux-arch@vger.kernel.org,
Alexandre Courbot <acourbot@nvidia.com>,
linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 0/3] gpio: remove GENERIC_GPIO completely
Date: Sun, 7 Apr 2013 11:23:04 +0800 [thread overview]
Message-ID: <20130407032304.GA11500@cbz-workstation> (raw)
In-Reply-To: <1364562678-8945-1-git-send-email-acourbot@nvidia.com>
On Fri, Mar 29, 2013 at 06:11:15AM -0700, Alexandre Courbot wrote:
> Another issue, I could not update the Chinese documentation in a satisfying
> manner due to my absence of Chinese skills. Hope that will be forgiven.
>
Hi Alexandre,
I have changed the Chinese documentation according to your update as
follows. Hopefully it would be helpful, :)
---
Documentation/zh_CN/gpio.txt | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/Documentation/zh_CN/gpio.txt b/Documentation/zh_CN/gpio.txt
index 4fa7b4e..d5b8f01 100644
--- a/Documentation/zh_CN/gpio.txt
+++ b/Documentation/zh_CN/gpio.txt
@@ -84,10 +84,10 @@ GPIO 公约
控制器的抽象函数来实现它。(有一些可选的代码能支持这种策略的实现,本文档
后面会介绍,但作为 GPIO 接口的客户端驱动程序必须与它的实现无关。)
-也就是说,如果在他们的平台上支持这个公约,驱动应尽可能的使用它。平台
-必须在 Kconfig 中声明对 GENERIC_GPIO的支持 (布尔型 true),并提供
-一个 <asm/gpio.h> 文件。那些调用标准 GPIO 函数的驱动应该在 Kconfig
-入口中声明依赖GENERIC_GPIO。当驱动包含文件:
+也就是说,如果在他们的平台上支持这个公约,驱动应尽可能的使用它。同时,平台
+必须在 Kconfig 中选择 ARCH_REQUIRE_GPIOLIB 或者 ARCH_WANT_OPTIONAL_GPIOLIB
+选项。那些调用标准 GPIO 函数的驱动应该在 Kconfig
入口中声明依赖GENERIC_GPIO。
+当驱动包含文件:
#include <linux/gpio.h>
next prev parent reply other threads:[~2013-04-07 3:25 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-03-29 13:11 Alexandre Courbot
2013-03-29 13:11 ` [PATCH 1/3] Convert selectors of GENERIC_GPIO to GPIOLIB Alexandre Courbot
2013-03-29 13:11 ` [PATCH 2/3] Remove GENERIC_GPIO config option Alexandre Courbot
2013-03-29 13:11 ` [PATCH 3/3] Rename CONFIG_GPIOLIB to CONFIG_GPIO Alexandre Courbot
2013-03-29 15:24 ` [PATCH 0/3] gpio: remove GENERIC_GPIO completely Alex Courbot
2013-04-03 13:28 ` Linus Walleij
2013-04-07 3:23 ` Chen Baozi [this message]
2013-04-07 21:25 ` Alexandre Courbot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130407032304.GA11500@cbz-workstation \
--to=baozich@gmail.com \
--cc=acourbot@nvidia.com \
--cc=arnd@arndb.de \
--cc=gnurou@gmail.com \
--cc=grant.likely@secretlab.ca \
--cc=linus.walleij@linaro.org \
--cc=linux-arch@vger.kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=romain.naour@openwide.fr \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®