mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Arnd Bergmann <arnd@arndb.de>
To: H Hartley Sweeten <hartleys@visionengravers.com>
Cc: Linux Kernel <linux-kernel@vger.kernel.org>,
	"gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org>,
	Ryan Mallon <rmallon@gmail.com>,
	"mcrapet@gmail.com" <mcrapet@gmail.com>
Subject: Re: [PATCH 02/14] misc/ep93xx_pwm: use {read,write}* instead of __raw_* versions for io
Date: Mon, 27 May 2013 19:07:14 +0200	[thread overview]
Message-ID: <201305271907.14742.arnd@arndb.de> (raw)
In-Reply-To: <ADE657CA350FB648AAC2C43247A983F0021DA666D43C@AUSP01VMBX24.collaborationhost.net>

On Monday 27 May 2013, H Hartley Sweeten wrote:
> On Monday, May 27, 2013 8:18 AM, Arnd Bergmann wrote:
> > On Saturday 25 May 2013, H Hartley Sweeten wrote:
> >> @@ -42,13 +42,13 @@ struct ep93xx_pwm {
> >>  static inline void ep93xx_pwm_writel(struct ep93xx_pwm *pwm,
> >>                 unsigned int val, unsigned int off)
> >>  {
> >> -       __raw_writel(val, pwm->mmio_base + off);
> >> +       writel(val, pwm->mmio_base + off);
> >>  }
> >
> > Just an idea: since you are adding the writel in a lot of places in subsequent
> > patches, you could rename 'mmio_base' to the shorter 'base' first, which would
> > make the resulting code actually smaller.
> 
> Hmm.. It would make the source file a bit smaller but the compiled size would
> be the same.

Right.

> But, I'll probably rename the variable when I convert this driver to the PWM
> framework.

Ok.

	Arnd


      reply	other threads:[~2013-05-27 17:07 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-05-24 23:21 H Hartley Sweeten
2013-05-27 15:18 ` Arnd Bergmann
2013-05-27 16:17   ` H Hartley Sweeten
2013-05-27 17:07     ` Arnd Bergmann [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=201305271907.14742.arnd@arndb.de \
    --to=arnd@arndb.de \
    --cc=gregkh@linuxfoundation.org \
    --cc=hartleys@visionengravers.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mcrapet@gmail.com \
    --cc=rmallon@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome