From: Felipe Balbi <balbi@ti.com>
To: Kishon Vijay Abraham I <kishon@ti.com>
Cc: <grant.likely@linaro.org>, <tony@atomide.com>, <balbi@ti.com>,
<arnd@arndb.de>, <swarren@nvidia.com>,
<sylvester.nawrocki@gmail.com>, <linux-kernel@vger.kernel.org>,
<linux-omap@vger.kernel.org>,
<linux-arm-kernel@lists.infradead.org>,
<linux-usb@vger.kernel.org>, <gregkh@linuxfoundation.org>,
<akpm@linux-foundation.org>, <rob.herring@calxeda.com>,
<rob@landley.net>, <b-cousson@ti.com>, <linux@arm.linux.org.uk>,
<benoit.cousson@linaro.org>, <mchehab@redhat.com>,
<cesarb@cesarb.net>, <davem@davemloft.net>, <rnayak@ti.com>,
<shawn.guo@linaro.org>, <santosh.shilimkar@ti.com>,
<devicetree-discuss@lists.ozlabs.org>,
<linux-doc@vger.kernel.org>, <nsekhar@ti.com>
Subject: Re: [PATCH v7 1/9] drivers: phy: add generic PHY framework
Date: Tue, 18 Jun 2013 12:38:29 +0300 [thread overview]
Message-ID: <20130618093829.GP5461@arwen.pp.htv.fi> (raw)
In-Reply-To: <1371113039-5784-2-git-send-email-kishon@ti.com>
[-- Attachment #1: Type: text/plain, Size: 2803 bytes --]
Hi,
On Thu, Jun 13, 2013 at 02:13:51PM +0530, Kishon Vijay Abraham I wrote:
> +struct phy_provider *of_phy_provider_register(struct device *dev,
> + struct module *owner, struct phy * (*of_xlate)(struct device *dev,
> + struct of_phandle_args *args))
I would rename this to __of_phy_provider_register() and in a header
have:
#define of_phy_provider_register(dev, xlate) \
__of_phy_provider_register((dev), THIS_MODULE, (xlate))
then your users don't need to remember always passing THIS_MODULE
argument.
> +struct phy_provider *devm_of_phy_provider_register(struct device *dev,
> + struct module *owner, struct phy * (*of_xlate)(struct device *dev,
> + struct of_phandle_args *args))
likewise.
> +/**
> + * phy_release() - release the phy
> + * @dev: the dev member within phy
> + *
> + * When the last reference to the device is removed, it is called
> + * from the embedded kobject as release method.
> + */
> +static void phy_release(struct device *dev)
> +{
> + struct phy *phy;
> +
> + phy = container_of(dev, struct phy, dev);
I would have a:
#define to_phy(dev) (container_of((dev), struct phy dev))
somewhere in a header, just for the sake of brevity :-p
> + dev_dbg(dev, "releasing '%s'\n", dev_name(dev));
make it dev_vdbg() instead.
> diff --git a/include/linux/phy/phy.h b/include/linux/phy/phy.h
> new file mode 100644
> index 0000000..df0c98a
> --- /dev/null
> +++ b/include/linux/phy/phy.h
[ ... ]
> +static inline int phy_init(struct phy *phy)
> +{
> + int ret = -ENOTSUPP;
> +
> + if (!pm_runtime_enabled(&phy->dev))
> + goto no_pm_runtime;
> +
> + ret = pm_runtime_get_sync(&phy->dev);
> + if (ret < 0) {
> + dev_err(&phy->dev, "get sync failed: %d\n", ret);
> + return ret;
> + }
> +
> +no_pm_runtime:
you can avoid this goto if you code as below, note that I'm also solving
a possible unbalanced PM runtime call which would prevent actual
*runtime* suspend of the PHY:
ret = phy_pm_runtime_get_sync(phy);
if (ret < 0 && ret != -ENOTSUPP)
return ret;
if (phy->ops->init) {
ret = phy->ops->init(phy);
if (ret < 0) {
dev_err(&phy->dev, "failed to initialize --> %d\n", ret);
goto out;
}
}
out:
/*
* In order to avoid unbalanced PM runtime calls, let's make
* sure to disable what we might have enabled when entering this
* function.
*/
phy_pm_runtime_put(phy);
return ret;
> +}
> +
> +static inline int phy_exit(struct phy *phy)
> +{
> + int ret = -ENOTSUPP;
> +
> + if (phy->ops->exit)
> + ret = phy->ops->exit(phy);
> +
> + if (!pm_runtime_enabled(&phy->dev))
> + goto no_pm_runtime;
> +
> + ret = pm_runtime_put_sync(&phy->dev);
move your pm runtime wrappers before these calls and you can use them.
--
balbi
[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 836 bytes --]
next prev parent reply other threads:[~2013-06-18 9:40 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-06-13 8:43 [PATCH v7 0/9] Generic PHY Framework Kishon Vijay Abraham I
2013-06-13 8:43 ` [PATCH v7 1/9] drivers: phy: add generic PHY framework Kishon Vijay Abraham I
2013-06-18 9:38 ` Felipe Balbi [this message]
2013-06-18 21:22 ` Sylwester Nawrocki
2013-06-24 6:37 ` Kishon Vijay Abraham I
2013-06-19 15:49 ` Sylwester Nawrocki
2013-06-20 5:28 ` Kishon Vijay Abraham I
2013-06-13 8:43 ` [PATCH v7 2/9] usb: phy: omap-usb2: use the new " Kishon Vijay Abraham I
2013-06-18 9:40 ` Felipe Balbi
2013-06-18 9:49 ` Kishon Vijay Abraham I
2013-06-18 9:50 ` Felipe Balbi
2013-06-18 9:56 ` Kishon Vijay Abraham I
2013-06-18 10:00 ` Felipe Balbi
2013-06-13 8:43 ` [PATCH v7 3/9] usb: phy: twl4030: " Kishon Vijay Abraham I
2013-06-18 9:42 ` Felipe Balbi
2013-06-13 8:43 ` [PATCH v7 4/9] usb: phy: twl4030: twl4030 shouldn't be subsys_initcall Kishon Vijay Abraham I
2013-06-18 9:43 ` Felipe Balbi
2013-06-13 8:43 ` [PATCH v7 5/9] ARM: OMAP: USB: Add phy binding information Kishon Vijay Abraham I
2013-06-18 9:44 ` Felipe Balbi
2013-06-18 10:04 ` Kishon Vijay Abraham I
2013-06-18 10:27 ` Felipe Balbi
2013-06-18 11:13 ` Kishon Vijay Abraham I
2013-06-18 12:35 ` Felipe Balbi
2013-06-18 14:55 ` Kishon Vijay Abraham I
2013-06-18 14:57 ` Felipe Balbi
2013-06-13 8:43 ` [PATCH v7 6/9] ARM: dts: omap: update usb_otg_hs data Kishon Vijay Abraham I
2013-06-18 9:45 ` Felipe Balbi
2013-06-13 8:43 ` [PATCH v7 7/9] usb: musb: omap2430: use the new generic PHY framework Kishon Vijay Abraham I
2013-06-18 9:47 ` Felipe Balbi
2013-06-24 5:31 ` Kishon Vijay Abraham I
2013-06-24 6:37 ` Felipe Balbi
2013-06-13 8:43 ` [PATCH v7 8/9] usb: phy: omap-usb2: remove *set_suspend* callback from omap-usb2 Kishon Vijay Abraham I
2013-06-18 9:47 ` Felipe Balbi
2013-06-13 8:43 ` [PATCH v7 9/9] usb: phy: twl4030-usb: remove *set_suspend* and *phy_init* ops Kishon Vijay Abraham I
2013-06-18 9:47 ` Felipe Balbi
2013-06-17 10:16 ` [PATCH v7 0/9] Generic PHY Framework Sylwester Nawrocki
2013-06-18 9:49 ` Felipe Balbi
2013-06-24 19:27 ` Sylwester Nawrocki
2013-06-24 19:34 ` Felipe Balbi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130618093829.GP5461@arwen.pp.htv.fi \
--to=balbi@ti.com \
--cc=akpm@linux-foundation.org \
--cc=arnd@arndb.de \
--cc=b-cousson@ti.com \
--cc=benoit.cousson@linaro.org \
--cc=cesarb@cesarb.net \
--cc=davem@davemloft.net \
--cc=devicetree-discuss@lists.ozlabs.org \
--cc=grant.likely@linaro.org \
--cc=gregkh@linuxfoundation.org \
--cc=kishon@ti.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-omap@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=linux@arm.linux.org.uk \
--cc=mchehab@redhat.com \
--cc=nsekhar@ti.com \
--cc=rnayak@ti.com \
--cc=rob.herring@calxeda.com \
--cc=rob@landley.net \
--cc=santosh.shilimkar@ti.com \
--cc=shawn.guo@linaro.org \
--cc=swarren@nvidia.com \
--cc=sylvester.nawrocki@gmail.com \
--cc=tony@atomide.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome