mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Mika Westerberg <mika.westerberg@iki.fi>
To: Ryan Mallon <rmallon@gmail.com>
Cc: H Hartley Sweeten <hartleys@visionengravers.com>,
	Linux Kernel <linux-kernel@vger.kernel.org>,
	spi-devel-general@lists.sourceforge.net, broonie@kernel.org,
	grant.likely@linaro.org
Subject: Re: [PATCH 4/8] spi: spi-ep93xx: remove bits_per_word() helper
Date: Sun, 30 Jun 2013 19:17:48 +0300	[thread overview]
Message-ID: <20130630161748.GB786@mwesterb-mobl.lan> (raw)
In-Reply-To: <51CE1A8C.7070703@gmail.com>

On Sat, Jun 29, 2013 at 09:21:48AM +1000, Ryan Mallon wrote:
> On 29/06/13 04:44, H Hartley Sweeten wrote:
> 
> > This inline helper function is only used to determine the bus width
> > of the current transfer (8 or 16 bit). Add a bool flag to the private
> > structure and set it appropriately for each transfer.
> > 
> > Signed-off-by: H Hartley Sweeten <hsweeten@visionengravers.com>
> > Cc: Ryan Mallon <rmallon@gmail.com>
> > Cc: Mika Westerberg <mika.westerberg@iki.fi>
> > Cc: Mark Brown <broonie@kernel.org>
> > Cc: Grant Likely <grant.likely@linaro.org>
> > ---
> >  drivers/spi/spi-ep93xx.c | 16 +++++-----------
> >  1 file changed, 5 insertions(+), 11 deletions(-)
> > 
> > diff --git a/drivers/spi/spi-ep93xx.c b/drivers/spi/spi-ep93xx.c
> > index bcfd35a..4fab3bb 100644
> > --- a/drivers/spi/spi-ep93xx.c
> > +++ b/drivers/spi/spi-ep93xx.c
> > @@ -116,6 +116,7 @@ struct ep93xx_spi {
> >  	unsigned long			min_rate;
> >  	unsigned long			max_rate;
> >  	bool				running;
> > +	bool				word_xfer;
> 
> 
> I think this is a slightly confusing name. Maybe something like
> is_16bit_xfer would be better?
> 
> >  	struct workqueue_struct		*wq;
> >  	struct work_struct		msg_work;
> >  	struct completion		wait;
> > @@ -407,17 +408,9 @@ static void ep93xx_spi_chip_setup(const struct ep93xx_spi *espi,
> >  	writew(cr0, espi->regs_base + SSPCR0);
> >  }
> >  
> > -static inline int bits_per_word(const struct ep93xx_spi *espi)
> > -{
> > -	struct spi_message *msg = espi->current_msg;
> > -	struct spi_transfer *t = msg->state;
> > -
> > -	return t->bits_per_word;
> > -}
> > -
> >  static void ep93xx_do_write(struct ep93xx_spi *espi, struct spi_transfer *t)
> >  {
> > -	if (bits_per_word(espi) > 8) {
> > +	if (espi->word_xfer) {
> >  		u16 tx_val = 0;
> >  
> >  		if (t->tx_buf)
> > @@ -436,7 +429,7 @@ static void ep93xx_do_write(struct ep93xx_spi *espi, struct spi_transfer *t)
> >  
> >  static void ep93xx_do_read(struct ep93xx_spi *espi, struct spi_transfer *t)
> >  {
> > -	if (bits_per_word(espi) > 8) {
> > +	if (espi->word_xfer) {
> >  		u16 rx_val;
> >  
> >  		rx_val = readw(espi->regs_base + SSPDR);
> > @@ -522,7 +515,7 @@ ep93xx_spi_dma_prepare(struct ep93xx_spi *espi, enum dma_transfer_direction dir)
> >  	size_t len = t->len;
> >  	int i, ret, nents;
> >  
> > -	if (bits_per_word(espi) > 8)
> > +	if (espi->word_xfer)
> >  		buswidth = DMA_SLAVE_BUSWIDTH_2_BYTES;
> >  	else
> >  		buswidth = DMA_SLAVE_BUSWIDTH_1_BYTE;
> > @@ -699,6 +692,7 @@ static void ep93xx_spi_process_transfer(struct ep93xx_spi *espi,
> >  
> >  	ep93xx_spi_chip_setup(espi, chip);
> >  
> > +	espi->word_xfer = (t->bits_per_word > 8) ? true : false;
> 
> 
> 	espi->word_xfer = (t->bits_per_word > 8);

Or even
	espi->word_xfer = t->bits_per_word > 8;

> This patch is fine, but not sure it is entirely worth it. The
> information is already stored in t->bits_per_word and the cost
> of retrieving it is pretty minimal.

I agree.

      reply	other threads:[~2013-06-30 16:18 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-06-28 18:44 H Hartley Sweeten
2013-06-28 23:21 ` Ryan Mallon
2013-06-30 16:17   ` Mika Westerberg [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130630161748.GB786@mwesterb-mobl.lan \
    --to=mika.westerberg@iki.fi \
    --cc=broonie@kernel.org \
    --cc=grant.likely@linaro.org \
    --cc=hartleys@visionengravers.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rmallon@gmail.com \
    --cc=spi-devel-general@lists.sourceforge.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®