mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Mark Brown <broonie@kernel.org>
To: Ryan Mallon <rmallon@gmail.com>
Cc: H Hartley Sweeten <hartleys@visionengravers.com>,
	Linux Kernel <linux-kernel@vger.kernel.org>,
	spi-devel-general@lists.sourceforge.net, mika.westerberg@iki.fi,
	grant.likely@linaro.org
Subject: Re: [PATCH 1/8] spi: spi-ep93xx: use read,write instead of __raw_* variants
Date: Mon, 1 Jul 2013 11:57:50 +0100	[thread overview]
Message-ID: <20130701105750.GI27646@sirena.org.uk> (raw)
In-Reply-To: <51CE18FD.8010806@gmail.com>

[-- Attachment #1: Type: text/plain, Size: 657 bytes --]

On Sat, Jun 29, 2013 at 09:15:09AM +1000, Ryan Mallon wrote:
> On 29/06/13 04:42, H Hartley Sweeten wrote:

> > -static inline u8
> > -ep93xx_spi_read_u8(const struct ep93xx_spi *spi, u16 reg)
> > -{
> > -	return __raw_readb(spi->regs_base + reg);
> > -}

> Is there a particular reason to drop these functions? It's basically just
> bike-shedding, but they can make the code more readable at very little
> cost. Even dropping the inline (which is preferred nowdays) the compiler
> will still inline these, and it would also make this patch much smaller
> to keep them.

I tend to agree, it's much more normal to have the base + reg in a
function than not.

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 836 bytes --]

  reply	other threads:[~2013-07-01 10:58 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-06-28 18:42 H Hartley Sweeten
2013-06-28 23:15 ` Ryan Mallon
2013-07-01 10:57   ` Mark Brown [this message]
2013-07-01 18:17     ` H Hartley Sweeten

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130701105750.GI27646@sirena.org.uk \
    --to=broonie@kernel.org \
    --cc=grant.likely@linaro.org \
    --cc=hartleys@visionengravers.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mika.westerberg@iki.fi \
    --cc=rmallon@gmail.com \
    --cc=spi-devel-general@lists.sourceforge.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®