mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Matt Fleming <matt@console-pimps.org>
To: Roy Franz <roy.franz@linaro.org>
Cc: linux-kernel@vger.kernel.org, linux-efi@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, matt.fleming@intel.com,
	linux@arm.linux.org.uk, leif.lindholm@linaro.org,
	dave.martin@arm.com
Subject: Re: [PATCH 10/17] Renames in handle_cmdline_files() to complete generalization.
Date: Wed, 7 Aug 2013 14:09:44 +0100	[thread overview]
Message-ID: <20130807130944.GE2515@console-pimps.org> (raw)
In-Reply-To: <1375847113-24884-11-git-send-email-roy.franz@linaro.org>

On Tue, 06 Aug, at 08:45:06PM, Roy Franz wrote:
> Rename variables to be not initrd specific, as now the function
> loads arbitrary files.
> 
> Signed-off-by: Roy Franz <roy.franz@linaro.org>
> ---
>  drivers/firmware/efi/efi-stub-helper.c |   92 ++++++++++++++++----------------
>  1 file changed, 46 insertions(+), 46 deletions(-)

This looks nice, thanks.

-- 
Matt Fleming, Intel Open Source Technology Center

  reply	other threads:[~2013-08-07 13:09 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-08-07  3:44 [PATCH V2 00/17] EFI stub for ARM Roy Franz
2013-08-07  3:44 ` [PATCH 01/17] EFI stub documentation updates Roy Franz
2013-08-07  3:44 ` [PATCH 02/17] Move common EFI stub code from x86 arch code to common location Roy Franz
2013-08-07  3:44 ` [PATCH 03/17] Add system pointer argument to shared EFI stub related functions so they no longer use global system table pointer as they did when part of eboot.c Roy Franz
2013-08-07 13:08   ` Matt Fleming
2013-08-07 17:10     ` Roy Franz
2013-08-07 21:55       ` Matt Fleming
2013-08-07  3:45 ` [PATCH 04/17] Rename memory allocation/free functions Roy Franz
2013-08-07 13:09   ` Matt Fleming
2013-08-07 17:12     ` Roy Franz
2013-08-07  3:45 ` [PATCH 05/17] Add minimum address parameter to efi_low_alloc() Roy Franz
2013-08-07  3:45 ` [PATCH 06/17] rename __get_map() to efi_get_memory_map(), add parameter to optionally return mmap key. The mmap key is required to exit EFI boot services, and allows efi_get_memory_map() to be used for getting final memory map Roy Franz
2013-08-07  3:45 ` [PATCH 07/17] Enforce minimum alignment of 1 page on allocations. The efi_high_alloc() and efi_low_alloc() functions use the EFI_ALLOCATE_ADDRESS option to the EFI function allocate_pages(), which requires a minimum of page alignment, and rejects all other requests Roy Franz
2013-08-07  3:45 ` [PATCH 08/17] Allow efi_free() to be called with size of 0, and do nothing in that case Roy Franz
2013-08-07  3:45 ` [PATCH 09/17] Generalize handle_ramdisks() and rename to handle_cmdline_files() Roy Franz
2013-08-07  3:45 ` [PATCH 10/17] Renames in handle_cmdline_files() to complete generalization Roy Franz
2013-08-07 13:09   ` Matt Fleming [this message]
2013-08-07  3:45 ` [PATCH 11/17] Move EFI_READ_CHUNK_SIZE define to shared location Roy Franz
2013-08-07  3:45 ` [PATCH 12/17] Add proper definitions for some EFI function pointers Roy Franz
2013-08-07 13:09   ` Matt Fleming
2013-08-07 17:20     ` Roy Franz
2013-08-09 14:10   ` Mark Salter
2013-08-09 14:13     ` Roy Franz
2013-08-07  3:45 ` [PATCH 13/17] Fix types in EFI calls to match EFI function definitions Roy Franz
2013-08-07  3:45 ` [PATCH 14/17] resolve warnings found on ARM compile Roy Franz
2013-08-07  3:45 ` [PATCH 15/17] Add strstr to compressed string.c for ARM Roy Franz
2013-08-07  3:45 ` [PATCH 16/17] Add EFI stub " Roy Franz
2013-08-07 18:05   ` Dave Martin
2013-08-07 18:33     ` Leif Lindholm
2013-08-08 21:57     ` Roy Franz
2013-08-09  0:53       ` Roy Franz
2013-08-13 14:21       ` Dave P Martin
2013-08-07  3:45 ` [PATCH 17/17] Add config EFI_STUB for ARM to Kconfig Roy Franz
2013-08-07  7:44 ` [PATCH V2 00/17] EFI stub for ARM Matt Fleming

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130807130944.GE2515@console-pimps.org \
    --to=matt@console-pimps.org \
    --cc=dave.martin@arm.com \
    --cc=leif.lindholm@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-efi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@arm.linux.org.uk \
    --cc=matt.fleming@intel.com \
    --cc=roy.franz@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®