From: Mark Brown <broonie@kernel.org>
To: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
Cc: lgirdwood@gmail.com, linux-kernel@vger.kernel.org,
patches@opensource.wolfsonmicro.com
Subject: Re: [RFC PATCH] regulator: core: Add ability to create a lookup alias for supply
Date: Wed, 2 Oct 2013 20:50:29 +0100 [thread overview]
Message-ID: <20131002195029.GH27287@sirena.org.uk> (raw)
In-Reply-To: <1380716219-32039-1-git-send-email-ckeepax@opensource.wolfsonmicro.com>
[-- Attachment #1: Type: text/plain, Size: 1305 bytes --]
On Wed, Oct 02, 2013 at 01:16:59PM +0100, Charles Keepax wrote:
> Following our discussions around the Arizona regulator
> bindings here is an effort at putting a mechanism into the
> regulator core to alias registering of a supply from one
> device to another.
This seems basically fine, though I do have a few comments below.
Bulk versions of the API would also make sense - it's likely that more
than one supply will need to be mapped - and please also add managed
versions so people don't have to write cleanup code.
> I have a couple of patches that update the Arizona driver to
> use this that I will send in if you think this looks along
> the lines of what you were suggesting.
This seems like someting that should be in the MFD core, or at least
that there should be helpers in the core. Something like a set of
mappings in the mfd_cell so it's all data to the drivers.
> + struct device *dev;
> + const char *supply;
> + struct device *alias;
Please use a more meaningful name for dev. It might also be worth
allowing rewriting of the supply name since we'll probably find other
applications for things like modular board designs where name rewriting
is useful; since it's a function call with a parameter list it's harder
to add later than it would be with a struct.
[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 836 bytes --]
next prev parent reply other threads:[~2013-10-02 19:50 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-10-02 12:16 Charles Keepax
2013-10-02 19:50 ` Mark Brown [this message]
2013-10-03 16:11 ` Charles Keepax
2013-10-03 16:29 ` Mark Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20131002195029.GH27287@sirena.org.uk \
--to=broonie@kernel.org \
--cc=ckeepax@opensource.wolfsonmicro.com \
--cc=lgirdwood@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=patches@opensource.wolfsonmicro.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®