mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Hannes Frederic Sowa <hannes@stressinduktion.org>
To: "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Cc: Eric Dumazet <eric.dumazet@gmail.com>,
	Josh Triplett <josh@joshtriplett.org>,
	linux-kernel@vger.kernel.org, mingo@kernel.org,
	laijs@cn.fujitsu.com, dipankar@in.ibm.com,
	akpm@linux-foundation.org, mathieu.desnoyers@efficios.com,
	niv@us.ibm.com, tglx@linutronix.de, peterz@infradead.org,
	rostedt@goodmis.org, dhowells@redhat.com, edumazet@google.com,
	darren@dvhart.com, fweisbec@gmail.com, sbw@mit.edu,
	"David S. Miller" <davem@davemloft.net>,
	Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>,
	James Morris <jmorris@namei.org>,
	Hideaki YOSHIFUJI <yoshfuji@linux-ipv6.org>,
	Patrick McHardy <kaber@trash.net>,
	netdev@vger.kernel.org
Subject: Re: [PATCH v2 tip/core/rcu 07/13] ipv6/ip6_tunnel: Apply rcu_access_pointer() to avoid sparse false positive
Date: Sat, 12 Oct 2013 04:25:08 +0200	[thread overview]
Message-ID: <20131012022508.GA20321@order.stressinduktion.org> (raw)
In-Reply-To: <20131010190532.GQ5790@linux.vnet.ibm.com>

On Thu, Oct 10, 2013 at 12:05:32PM -0700, Paul E. McKenney wrote:
> On Thu, Oct 10, 2013 at 04:04:22AM +0200, Hannes Frederic Sowa wrote:
> > On Wed, Oct 09, 2013 at 05:28:33PM -0700, Paul E. McKenney wrote:
> > > On Wed, Oct 09, 2013 at 05:12:40PM -0700, Eric Dumazet wrote:
> > > > On Wed, 2013-10-09 at 16:40 -0700, Josh Triplett wrote:
> > > > 
> > > > > that.  Constructs like list_del_rcu are much clearer, and not
> > > > > open-coded.  Open-coding synchronization code is almost always a Bad
> > > > > Idea.
> > > > 
> > > > OK, so you think there is synchronization code.
> > > > 
> > > > I will shut up then, no need to waste time.
> > > 
> > > As you said earlier, we should at least get rid of the memory barrier
> > > as long as we are changing the code.
> > 
> > Interesting thread!
> > 
> > Sorry to chime in and asking a question:
> > 
> > Why do we need an ACCESS_ONCE here if rcu_assign_pointer can do without one?
> > In other words I wonder why rcu_assign_pointer is not a static inline function
> > to use the sequence point in argument evaluation (if I remember correctly this
> > also holds for inline functions) to not allow something like this:
> > 
> > E.g. we want to publish which lock to take first to prevent an ABBA problem
> > (extreme example):
> > 
> > rcu_assign_pointer(lockptr, min(lptr1, lptr2));
> > 
> > Couldn't a compiler spill the lockptr memory location as a temporary buffer
> > if the compiler is under register pressure? (yes, this seems unlikely if we
> > flushed out most registers to memory because of the barrier, but still... ;) )
> > 
> > This seems to be also the case if we publish a multi-dereferencing pointers
> > e.g. ptr->ptr->ptr.
> 
> IIRC, sequence points only confine volatile accesses.  For non-volatile
> accesses, the so-called "as-if rule" allows compiler writers to do some
> surprisingly global reordering.
> 
> The reason that rcu_assign_pointer() isn't an inline function is because
> it needs to be type-generic, in other words, it needs to be OK to use
> it on any type of pointers as long as the C types of the two pointers
> match (the sparse types can vary a bit).
> 
> One of the reasons for wanting a volatile cast in rcu_assign_pointer() is
> to prevent compiler mischief such as you described in your last two
> paragraphs.  That said, it would take a very brave compiler to pull
> a pointer-referenced memory location into a register and keep it there.
> Unfortunately, increasing compiler bravery seems to be a solid long-term
> trend.

I saw your patch regarding making rcu_assign_pointer volatile and wonder if we
can still make it a bit more safe to use if we force the evaluation of the
to-be-assigned pointer before the write barrier. This is what I have in mind:

diff --git a/include/linux/rcupdate.h b/include/linux/rcupdate.h
index f1f1bc3..79eccc3 100644
--- a/include/linux/rcupdate.h
+++ b/include/linux/rcupdate.h
@@ -550,8 +550,9 @@ static inline void rcu_preempt_sleep_check(void)
 	})
 #define __rcu_assign_pointer(p, v, space) \
 	do { \
+		typeof(v) ___v = (v); \
 		smp_wmb(); \
-		(p) = (typeof(*v) __force space *)(v); \
+		(p) = (typeof(*___v) __force space *)(___v); \
 	} while (0)
 
 
I don't think ___v must be volatile for this case because the memory barrier
will force the evaluation of v first.

This would guard against cases where rcu_assign_pointer is used like:

rcu_assign_pointer(ptr, compute_ptr_with_side_effects());

Greetings,

  Hannes


  reply	other threads:[~2013-10-12  2:25 UTC|newest]

Thread overview: 46+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-10-09 21:29 [PATCH v2 tip/core/rcu 0/13] Sparse-related updates for 3.13 Paul E. McKenney
2013-10-09 21:29 ` [PATCH v2 tip/core/rcu 01/13] rcu: Make rcu_assign_pointer's assignment volatile and type-safe Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 02/13] notifiers: Apply rcu_access_pointer() to avoid sparse false positive Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 03/13] bridge: " Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 04/13] wireless: " Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 05/13] decnet: " Paul E. McKenney
2013-10-09 22:28     ` Josh Triplett
2013-10-09 22:46       ` Paul E. McKenney
2013-10-09 22:57         ` Josh Triplett
2013-10-09 23:57           ` Paul E. McKenney
2013-10-09 22:58     ` Dhaval Giani
2013-10-09 23:54       ` Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 06/13] ipv4/ip_socketglue: " Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 07/13] ipv6/ip6_tunnel: " Paul E. McKenney
2013-10-09 21:42     ` Eric Dumazet
2013-10-09 21:57       ` Paul E. McKenney
2013-10-09 22:10         ` Eric Dumazet
2013-10-09 22:36           ` Paul E. McKenney
2013-10-09 22:51             ` Eric Dumazet
2013-10-09 22:56               ` Josh Triplett
2013-10-09 23:17                 ` Eric Dumazet
2013-10-09 23:40                   ` Josh Triplett
2013-10-10  0:12                     ` Eric Dumazet
2013-10-10  0:28                       ` Paul E. McKenney
2013-10-10  2:04                         ` Hannes Frederic Sowa
2013-10-10 19:05                           ` Paul E. McKenney
2013-10-12  2:25                             ` Hannes Frederic Sowa [this message]
2013-10-12  7:53                               ` Paul E. McKenney
2013-10-12 16:43                                 ` Hannes Frederic Sowa
2013-10-12 17:37                                   ` Hannes Frederic Sowa
2013-10-12 19:42                                     ` Mathieu Desnoyers
2013-10-13 11:14                                       ` Paul E. McKenney
2013-10-13 20:11                                         ` Hannes Frederic Sowa
2013-10-11  0:20                         ` Josh Triplett
2013-10-11 13:25                           ` Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 08/13] ipv6/ip6_gre: " Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 09/13] ipv6/sit: " Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 10/13] mac80211: " Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 11/13] bridge/br_mdb: " Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 12/13] bonding/bond_main: " Paul E. McKenney
2013-10-09 21:29   ` [PATCH v2 tip/core/rcu 13/13] bonding/bond_alb.c: " Paul E. McKenney
2013-10-09 22:26   ` [PATCH v2 tip/core/rcu 01/13] rcu: Make rcu_assign_pointer's assignment volatile and type-safe Josh Triplett
2013-10-09 22:18 ` [PATCH v2 tip/core/rcu 0/13] Sparse-related updates for 3.13 Josh Triplett
2013-10-09 22:46   ` Paul E. McKenney
2013-10-09 22:23 ` Josh Triplett
2013-10-09 22:30 ` Josh Triplett

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20131012022508.GA20321@order.stressinduktion.org \
    --to=hannes@stressinduktion.org \
    --cc=akpm@linux-foundation.org \
    --cc=darren@dvhart.com \
    --cc=davem@davemloft.net \
    --cc=dhowells@redhat.com \
    --cc=dipankar@in.ibm.com \
    --cc=edumazet@google.com \
    --cc=eric.dumazet@gmail.com \
    --cc=fweisbec@gmail.com \
    --cc=jmorris@namei.org \
    --cc=josh@joshtriplett.org \
    --cc=kaber@trash.net \
    --cc=kuznet@ms2.inr.ac.ru \
    --cc=laijs@cn.fujitsu.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mathieu.desnoyers@efficios.com \
    --cc=mingo@kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=niv@us.ibm.com \
    --cc=paulmck@linux.vnet.ibm.com \
    --cc=peterz@infradead.org \
    --cc=rostedt@goodmis.org \
    --cc=sbw@mit.edu \
    --cc=tglx@linutronix.de \
    --cc=yoshfuji@linux-ipv6.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®