From: Will Deacon <will.deacon@arm.com>
To: Jiang Liu <liuj97@gmail.com>
Cc: Steven Rostedt <rostedt@goodmis.org>,
Catalin Marinas <Catalin.Marinas@arm.com>,
Sandeepa Prabhu <sandeepa.prabhu@linaro.org>,
Jiang Liu <jiang.liu@huawei.com>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v4 3/7] arm64: move encode_insn_immediate() from module.c to insn.c
Date: Thu, 17 Oct 2013 13:11:35 +0100 [thread overview]
Message-ID: <20131017121135.GK18765@mudshark.cambridge.arm.com> (raw)
In-Reply-To: <1381990781-27814-4-git-send-email-liuj97@gmail.com>
On Thu, Oct 17, 2013 at 07:19:36AM +0100, Jiang Liu wrote:
> From: Jiang Liu <jiang.liu@huawei.com>
>
> Function encode_insn_immediate() will be used by other instruction
> manipulate related functions, so move it into insn.c and rename it
> as aarch64_insn_encode_immediate().
>
> Signed-off-by: Jiang Liu <jiang.liu@huawei.com>
> Cc: Jiang Liu <liuj97@gmail.com>
> ---
> arch/arm64/include/asm/insn.h | 14 ++++
> arch/arm64/kernel/insn.c | 58 ++++++++++++++++
> arch/arm64/kernel/module.c | 152 +++++++++++++-----------------------------
> 3 files changed, 117 insertions(+), 107 deletions(-)
>
> diff --git a/arch/arm64/include/asm/insn.h b/arch/arm64/include/asm/insn.h
> index fc439b9..d62b601 100644
> --- a/arch/arm64/include/asm/insn.h
> +++ b/arch/arm64/include/asm/insn.h
> @@ -42,6 +42,18 @@ enum aarch64_insn_encoding_class {
> * system instructions */
> };
>
> +enum aarch64_insn_imm_type {
> + AARCH64_INSN_IMM_MOVK,
> + AARCH64_INSN_IMM_ADR,
> + AARCH64_INSN_IMM_26,
> + AARCH64_INSN_IMM_19,
> + AARCH64_INSN_IMM_16,
> + AARCH64_INSN_IMM_14,
> + AARCH64_INSN_IMM_12,
> + AARCH64_INSN_IMM_9,
> + AARCH64_INSN_IMM_MAX
> +};
> +
> #define __AARCH64_INSN_FUNCS(abbr, mask, val) \
> static __always_inline bool aarch64_insn_is_##abbr(u32 code) \
> { return (code & (mask)) == (val); } \
> @@ -80,6 +92,8 @@ static __always_inline void aarch64_insn_write(void *addr, u32 insn)
> }
>
> enum aarch64_insn_encoding_class aarch64_get_insn_class(u32 insn);
> +u32 aarch64_insn_encode_immediate(enum aarch64_insn_imm_type type,
> + u32 insn, u64 imm);
> bool aarch64_insn_hotpatch_safe(u32 old_insn, u32 new_insn);
>
> int aarch64_insn_patch_text_nosync(void *addrs[], u32 insns[], int cnt);
> diff --git a/arch/arm64/kernel/insn.c b/arch/arm64/kernel/insn.c
> index 8dd5fbe..344d23ed 100644
> --- a/arch/arm64/kernel/insn.c
> +++ b/arch/arm64/kernel/insn.c
> @@ -147,3 +147,61 @@ int __kprobes aarch64_insn_patch_text(void *addrs[], u32 insns[], int cnt)
>
> return ret;
> }
> +
> +u32 aarch64_insn_encode_immediate(enum aarch64_insn_imm_type type,
> + u32 insn, u64 imm)
> +{
> + u32 immlo, immhi, lomask, himask, mask;
> + int shift;
> +
> + switch (type) {
> + case AARCH64_INSN_IMM_MOVK:
> + mask = BIT(16) - 1;
> + shift = 5;
> + break;
This is just AARCH64_INSN_IMM_16 now that we're not dealing with MOV
relocations. You can kill INSN_IMM_MOVK in the enum.
The rest of the patch looks fine.
Will
next prev parent reply other threads:[~2013-10-17 12:12 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-10-17 6:19 [PATCH v4 0/7] Optimize jump label implementation for ARM64 Jiang Liu
2013-10-17 6:19 ` [PATCH v4 1/7] arm64: introduce basic aarch64 instruction decoding helpers Jiang Liu
2013-10-17 10:47 ` Will Deacon
2013-10-17 15:14 ` Jiang Liu
2013-10-17 6:19 ` [PATCH v4 2/7] arm64: introduce interfaces to hotpatch kernel and module code Jiang Liu
2013-10-17 11:38 ` Will Deacon
2013-10-17 15:24 ` Jon Medhurst (Tixy)
2013-10-17 15:59 ` Jiang Liu
2013-10-18 8:56 ` Will Deacon
2013-10-18 13:44 ` Jon Medhurst (Tixy)
2013-10-18 15:08 ` Jiang Liu
2013-10-17 15:38 ` Jiang Liu
2013-10-17 6:19 ` [PATCH v4 3/7] arm64: move encode_insn_immediate() from module.c to insn.c Jiang Liu
2013-10-17 12:11 ` Will Deacon [this message]
2013-10-17 6:19 ` [PATCH v4 4/7] arm64: introduce aarch64_insn_gen_{nop|branch_imm}() helper functions Jiang Liu
2013-10-17 6:19 ` [PATCH v4 5/7] arm64, jump label: detect %c support for ARM64 Jiang Liu
2013-10-17 6:19 ` [PATCH v4 6/7] arm64, jump label: optimize jump label implementation Jiang Liu
2013-10-17 6:19 ` [PATCH v4 7/7] jump_label: use defined macros instead of hard-coding for better readability Jiang Liu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20131017121135.GK18765@mudshark.cambridge.arm.com \
--to=will.deacon@arm.com \
--cc=Catalin.Marinas@arm.com \
--cc=jiang.liu@huawei.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=liuj97@gmail.com \
--cc=rostedt@goodmis.org \
--cc=sandeepa.prabhu@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®