mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Steven Rostedt <rostedt@goodmis.org>
To: Juri Lelli <juri.lelli@gmail.com>
Cc: peterz@infradead.org, tglx@linutronix.de, mingo@redhat.com,
	oleg@redhat.com, fweisbec@gmail.com, darren@dvhart.com,
	johan.eker@ericsson.com, p.faure@akatech.ch,
	linux-kernel@vger.kernel.org, claudio@evidence.eu.com,
	michael@amarulasolutions.com, fchecconi@gmail.com,
	tommaso.cucinotta@sssup.it, nicola.manica@disi.unitn.it,
	luca.abeni@unitn.it, dhaval.giani@gmail.com, hgu1972@gmail.com,
	paulmck@linux.vnet.ibm.com, raistlin@linux.it,
	insop.song@gmail.com, liming.wang@windriver.com,
	jkacur@redhat.com, harald.gustafsson@ericsson.com,
	vincent.guittot@linaro.org, bruce.ashfield@windriver.com
Subject: Re: [PATCH 04/14] sched: SCHED_DEADLINE SMP-related data structures & logic.
Date: Thu, 21 Nov 2013 09:41:50 -0500	[thread overview]
Message-ID: <20131121094150.26318fe9@gandalf.local.home> (raw)
In-Reply-To: <528E1508.7060305@gmail.com>

On Thu, 21 Nov 2013 15:13:28 +0100
Juri Lelli <juri.lelli@gmail.com> wrote:
;
> >> +
> >> +#ifdef CONFIG_SMP
> >> +	/* zero means no -deadline tasks */
> > 
> > I'm curious to why you add the '-' to -deadline.
> > 
> 
> I guess "deadline tasks" is too much generic; "SCHED_DEADLINE tasks" too long;
> "DL" or "-dl" can be associated to "download". Nothing special in the end, just
> tought it was a reasonable abbreviation.

Yeah, keep the -deadline, as that makes it more searchable.

> >> +static int latest_cpu_find(struct cpumask *span,
> >> +			   struct task_struct *task,
> >> +			   struct cpumask *later_mask)
> >> +{
> >> +	const struct sched_dl_entity *dl_se = &task->dl;
> >> +	int cpu, found = -1, best = 0;
> >> +	u64 max_dl = 0;
> >> +
> >> +	for_each_cpu(cpu, span) {
> >> +		struct rq *rq = cpu_rq(cpu);
> >> +		struct dl_rq *dl_rq = &rq->dl;
> >> +
> >> +		if (cpumask_test_cpu(cpu, &task->cpus_allowed) &&
> >> +		    (!dl_rq->dl_nr_running || dl_time_before(dl_se->deadline,
> >> +		     dl_rq->earliest_dl.curr))) {
> >> +			if (later_mask)
> >> +				cpumask_set_cpu(cpu, later_mask);
> >> +			if (!best && !dl_rq->dl_nr_running) {
> >> +				best = 1;
> >> +				found = cpu;
> >> +			} else if (!best &&
> >> +				   dl_time_before(max_dl,
> >> +						  dl_rq->earliest_dl.curr)) {
> > 
> > Ug, the above is hard to read. What about:
> > 
> > 	if (!best) {
> > 		if (!dl_rq->dl_nr_running) {
> > 			best = 1;
> > 			found = cpu;
> > 		} elsif (dl_time_before(...)) {
> > 			...
> > 		}
> > 	}
> > 
> 
> This is completely removed in 13/14. I don't like it either, but since we end
> up removing this mess, do you think we still have to fix this here?

OK, if it gets removed later (I haven't hit patch 13 yet), then it
should be fine.

> 
> > Also, I would think dl should be nice to rt as well. There may be a
> > idle CPU or a non rt task, and this could pick a CPU running an RT
> > task. Worse yet, that RT task may be pinned to that CPU.
> > 
> 
> Well, in 13/14 we introduce a free_cpus mask. A CPU is considered free if it
> doesn't have any -deadline task running. We can modify that excluding also CPUs
> running RT tasks, but I have to think a bit if we can do this also from -rt code.
> 
> > We should be able to incorporate cpuprio_find() to be dl aware too.
> > That is, work for both -rt and -dl.
> >
> 
> Like checking if a -dl task is running on the cpu chosen for pushing an -rt
> task, and continue searching in that case.

Yep, and also, it could perhaps be used for knowing where to push a
-dl task too.

-- Steve

  reply	other threads:[~2013-11-21 14:42 UTC|newest]

Thread overview: 87+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-11-07 13:43 [PATCH 00/14] sched: SCHED_DEADLINE v9 Juri Lelli
2013-11-07 13:43 ` [PATCH 01/14] sched: add sched_class->task_dead Juri Lelli
2013-11-12  4:17   ` Paul Turner
2013-11-12 17:19   ` Steven Rostedt
2013-11-12 17:53     ` Juri Lelli
2013-11-27 14:10   ` [tip:sched/core] sched: Add sched_class->task_dead() method tip-bot for Dario Faggioli
2013-11-07 13:43 ` [PATCH 02/14] sched: add extended scheduling interface Juri Lelli
2013-11-12 17:23   ` Steven Rostedt
2013-11-13  8:43     ` Juri Lelli
2013-11-12 17:32   ` Steven Rostedt
2013-11-13  9:07     ` Juri Lelli
2013-11-27 13:23   ` [PATCH 02/14] sched: add extended scheduling interface. (new ABI) Ingo Molnar
2013-11-27 13:30     ` Peter Zijlstra
2013-11-27 14:01       ` Ingo Molnar
2013-11-27 14:13         ` Peter Zijlstra
2013-11-27 14:17           ` Ingo Molnar
2013-11-28 11:14             ` Juri Lelli
2013-11-28 11:28               ` Peter Zijlstra
2013-11-30 14:06                 ` Ingo Molnar
2013-12-03 16:13                   ` Juri Lelli
2013-12-03 16:41                     ` Steven Rostedt
2013-12-03 17:04                       ` Juri Lelli
2014-01-13 15:53   ` [tip:sched/core] sched: Add new scheduler syscalls to support an extended scheduling parameters ABI tip-bot for Dario Faggioli
2014-01-15 16:22     ` [RFC][PATCH] sched: Move SCHED_RESET_ON_FORK into attr::sched_flags Peter Zijlstra
2014-01-16 13:40       ` [tip:sched/core] sched: Move SCHED_RESET_ON_FORK into attr:: sched_flags tip-bot for Peter Zijlstra
2014-01-17 17:29     ` [tip:sched/core] sched: Add new scheduler syscalls to support an extended scheduling parameters ABI Stephen Warren
2014-01-17 18:04       ` Stephen Warren
2013-11-07 13:43 ` [PATCH 03/14] sched: SCHED_DEADLINE structures & implementation Juri Lelli
2013-11-13  2:31   ` Steven Rostedt
2013-11-13  9:54     ` Juri Lelli
2013-11-20 20:23   ` Steven Rostedt
2013-11-21 14:15     ` Juri Lelli
2014-01-13 15:53   ` [tip:sched/core] sched/deadline: Add " tip-bot for Dario Faggioli
2013-11-07 13:43 ` [PATCH 04/14] sched: SCHED_DEADLINE SMP-related data structures & logic Juri Lelli
2013-11-20 18:51   ` Steven Rostedt
2013-11-21 14:13     ` Juri Lelli
2013-11-21 14:41       ` Steven Rostedt [this message]
2013-11-21 16:08       ` Paul E. McKenney
2013-11-21 16:16         ` Juri Lelli
2013-11-21 16:26           ` Paul E. McKenney
2013-11-21 16:47             ` Steven Rostedt
2013-11-21 19:38               ` Paul E. McKenney
2014-01-13 15:53   ` [tip:sched/core] sched/deadline: Add " tip-bot for Juri Lelli
2013-11-07 13:43 ` [PATCH 05/14] sched: SCHED_DEADLINE avg_update accounting Juri Lelli
2014-01-13 15:53   ` [tip:sched/core] sched/deadline: Add " tip-bot for Dario Faggioli
2013-11-07 13:43 ` [PATCH 06/14] sched: add period support for -deadline tasks Juri Lelli
2014-01-13 15:53   ` [tip:sched/core] sched/deadline: Add period support for SCHED_DEADLINE tasks tip-bot for Harald Gustafsson
2013-11-07 13:43 ` [PATCH 07/14] sched: add schedstats for -deadline tasks Juri Lelli
2013-11-07 13:43 ` [PATCH 08/14] sched: add latency tracing " Juri Lelli
2013-11-20 21:33   ` Steven Rostedt
2013-11-27 13:43     ` Juri Lelli
2013-11-27 14:16       ` Steven Rostedt
2013-11-27 14:19         ` Juri Lelli
2013-11-27 14:26         ` Peter Zijlstra
2013-11-27 14:34           ` Ingo Molnar
2013-11-27 14:58             ` Peter Zijlstra
2013-11-27 15:35               ` Ingo Molnar
2013-11-27 15:40                 ` Peter Zijlstra
2013-11-27 15:46                   ` Ingo Molnar
2013-11-27 15:54                     ` Peter Zijlstra
2013-11-27 15:56                     ` Steven Rostedt
2013-11-27 16:01                       ` Peter Zijlstra
2013-11-27 16:02                       ` Steven Rostedt
2013-11-27 16:13                       ` Ingo Molnar
2013-11-27 16:33                         ` Steven Rostedt
2013-11-27 16:24                   ` Oleg Nesterov
2013-11-27 15:42               ` Ingo Molnar
2013-11-27 15:00           ` Steven Rostedt
2014-01-13 15:54   ` [tip:sched/core] sched/deadline: Add latency tracing for SCHED_DEADLINE tasks tip-bot for Dario Faggioli
2013-11-07 13:43 ` [PATCH 09/14] rtmutex: turn the plist into an rb-tree Juri Lelli
2013-11-21  3:07   ` Steven Rostedt
2013-11-21 17:52   ` [PATCH] rtmutex: Fix compare of waiter prio and task prio Steven Rostedt
2013-11-22 10:37     ` Juri Lelli
2014-01-13 15:54   ` [tip:sched/core] rtmutex: Turn the plist into an rb-tree tip-bot for Peter Zijlstra
2013-11-07 13:43 ` [PATCH 10/14] sched: drafted deadline inheritance logic Juri Lelli
2014-01-13 15:54   ` [tip:sched/core] sched/deadline: Add SCHED_DEADLINE " tip-bot for Dario Faggioli
2013-11-07 13:43 ` [PATCH 11/14] sched: add bandwidth management for sched_dl Juri Lelli
2014-01-13 15:54   ` [tip:sched/core] sched/deadline: Add bandwidth management for SCHED_DEADLINE tasks tip-bot for Dario Faggioli
2013-11-07 13:43 ` [PATCH 12/14] sched: make dl_bw a sub-quota of rt_bw Juri Lelli
2013-11-07 13:43 ` [PATCH 13/14] sched: speed up -dl pushes with a push-heap Juri Lelli
2014-01-13 15:54   ` [tip:sched/core] sched/deadline: speed up SCHED_DEADLINE " tip-bot for Juri Lelli
  -- strict thread matches above, loose matches on Subject: below --
2013-10-14 10:43 [PATCH 00/14] sched: SCHED_DEADLINE v8 Juri Lelli
2013-10-14 10:43 ` [PATCH 04/14] sched: SCHED_DEADLINE SMP-related data structures & logic Juri Lelli
2013-10-14 12:03   ` Peter Zijlstra
2013-10-15  9:36     ` Juri Lelli
2013-10-15 10:35       ` Peter Zijlstra
2013-10-15 11:36         ` Juri Lelli
2013-02-11 18:50 [PATCH 00/14] sched: SCHED_DEADLINE v7 Juri Lelli
2013-02-11 18:50 ` [PATCH 04/14] sched: SCHED_DEADLINE SMP-related data structures & logic Juri Lelli

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20131121094150.26318fe9@gandalf.local.home \
    --to=rostedt@goodmis.org \
    --cc=bruce.ashfield@windriver.com \
    --cc=claudio@evidence.eu.com \
    --cc=darren@dvhart.com \
    --cc=dhaval.giani@gmail.com \
    --cc=fchecconi@gmail.com \
    --cc=fweisbec@gmail.com \
    --cc=harald.gustafsson@ericsson.com \
    --cc=hgu1972@gmail.com \
    --cc=insop.song@gmail.com \
    --cc=jkacur@redhat.com \
    --cc=johan.eker@ericsson.com \
    --cc=juri.lelli@gmail.com \
    --cc=liming.wang@windriver.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luca.abeni@unitn.it \
    --cc=michael@amarulasolutions.com \
    --cc=mingo@redhat.com \
    --cc=nicola.manica@disi.unitn.it \
    --cc=oleg@redhat.com \
    --cc=p.faure@akatech.ch \
    --cc=paulmck@linux.vnet.ibm.com \
    --cc=peterz@infradead.org \
    --cc=raistlin@linux.it \
    --cc=tglx@linutronix.de \
    --cc=tommaso.cucinotta@sssup.it \
    --cc=vincent.guittot@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®