mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Lee Jones <lee.jones@linaro.org>
To: micky_ching@realsil.com.cn
Cc: sameo@linux.intel.com, devel@linuxdriverproject.org,
	linux-kernel@vger.kernel.org, gregkh@linuxfoundation.org,
	wei_wang@realsil.com.cn, rogerable@realtek.com
Subject: Re: [PATCH v2 1/3] mfd: rtsx: reduce code duplication in rtl8411
Date: Tue, 3 Dec 2013 10:55:41 +0000	[thread overview]
Message-ID: <20131203105541.GM11828@lee--X1> (raw)
In-Reply-To: <4dbd7d35c3e2201a77357155f6610abda69a3139.1386051860.git.micky_ching@realsil.com.cn>

> From: Micky Ching <micky_ching@realsil.com.cn>
>  
> in order to remove duplicated code in rtl8411, we make 8411 as the base
> init params, and other like-8411 chips will just change the different
> value with 8411, this can save some source code.
> 
> Signed-off-by: Lee Jones <lee.jones@linaro.org>

I haven't signed this version off.

I'm still confused what the difference between the versions are. I
submitted a patch just like this one, which you responded to with only
a single fix. Then you've submitted a slightly different version? What
makes this version different/better?

> Signed-off-by: Micky Ching <micky_ching@realsil.com.cn>
> ---
>  drivers/mfd/rtl8411.c  |   63 +++++++++---------------------------------------
>  drivers/mfd/rtsx_pcr.h |    8 ++++++
>  2 files changed, 19 insertions(+), 52 deletions(-)
> 
> diff --git a/drivers/mfd/rtl8411.c b/drivers/mfd/rtl8411.c
> index 5280135..c9eab9d 100644
> --- a/drivers/mfd/rtl8411.c
> +++ b/drivers/mfd/rtl8411.c
> @@ -279,7 +279,7 @@ static int rtl8411_conv_clk_and_div_n(int input, int dir)
>  	return output;
>  }
>  
> -static const struct pcr_ops rtl8411_pcr_ops = {
> +static struct pcr_ops rtl8411_pcr_ops = {
>  	.fetch_vendor_settings = rtl8411_fetch_vendor_settings,
>  	.extra_init_hw = rtl8411_extra_init_hw,
>  	.optimize_phy = NULL,
> @@ -295,22 +295,6 @@ static const struct pcr_ops rtl8411_pcr_ops = {
>  	.force_power_down = rtl8411_force_power_down,
>  };
>  
> -static const struct pcr_ops rtl8411b_pcr_ops = {
> -	.fetch_vendor_settings = rtl8411b_fetch_vendor_settings,
> -	.extra_init_hw = rtl8411b_extra_init_hw,
> -	.optimize_phy = NULL,
> -	.turn_on_led = rtl8411_turn_on_led,
> -	.turn_off_led = rtl8411_turn_off_led,
> -	.enable_auto_blink = rtl8411_enable_auto_blink,
> -	.disable_auto_blink = rtl8411_disable_auto_blink,
> -	.card_power_on = rtl8411_card_power_on,
> -	.card_power_off = rtl8411_card_power_off,
> -	.switch_output_voltage = rtl8411_switch_output_voltage,
> -	.cd_deglitch = rtl8411_cd_deglitch,
> -	.conv_clk_and_div_n = rtl8411_conv_clk_and_div_n,
> -	.force_power_down = rtl8411_force_power_down,
> -};
> -
>  /* SD Pull Control Enable:
>   *     SD_DAT[3:0] ==> pull up
>   *     SD_CD       ==> pull up
> @@ -456,45 +440,20 @@ void rtl8411_init_params(struct rtsx_pcr *pcr)
>  	pcr->rx_initial_phase = SET_CLOCK_PHASE(4, 3, 10);
>  
>  	pcr->ic_version = rtl8411_get_ic_version(pcr);
> -	pcr->sd_pull_ctl_enable_tbl = rtl8411_sd_pull_ctl_enable_tbl;
> -	pcr->sd_pull_ctl_disable_tbl = rtl8411_sd_pull_ctl_disable_tbl;
> -	pcr->ms_pull_ctl_enable_tbl = rtl8411_ms_pull_ctl_enable_tbl;
> -	pcr->ms_pull_ctl_disable_tbl = rtl8411_ms_pull_ctl_disable_tbl;
> +
> +	set_pull_ctrl_tables(rtl8411);
>  }
>  
>  void rtl8411b_init_params(struct rtsx_pcr *pcr)
>  {
> -	pcr->extra_caps = EXTRA_CAPS_SD_SDR50 | EXTRA_CAPS_SD_SDR104;
> -	pcr->num_slots = 2;
> -	pcr->ops = &rtl8411b_pcr_ops;
> -
> -	pcr->flags = 0;
> -	pcr->card_drive_sel = RTL8411_CARD_DRIVE_DEFAULT;
> -	pcr->sd30_drive_sel_1v8 = DRIVER_TYPE_B;
> -	pcr->sd30_drive_sel_3v3 = DRIVER_TYPE_D;
> -	pcr->aspm_en = ASPM_L1_EN;
> -	pcr->tx_initial_phase = SET_CLOCK_PHASE(23, 7, 14);
> -	pcr->rx_initial_phase = SET_CLOCK_PHASE(4, 3, 10);
> +	rtl8411_init_params(pcr);
>  
> -	pcr->ic_version = rtl8411_get_ic_version(pcr);
> +	rtl8411_pcr_ops.fetch_vendor_settings =
> +		rtl8411b_fetch_vendor_settings;
> +	rtl8411_pcr_ops.extra_init_hw = rtl8411b_extra_init_hw;
>  
> -	if (rtl8411b_is_qfn48(pcr)) {
> -		pcr->sd_pull_ctl_enable_tbl =
> -			rtl8411b_qfn48_sd_pull_ctl_enable_tbl;
> -		pcr->sd_pull_ctl_disable_tbl =
> -			rtl8411b_qfn48_sd_pull_ctl_disable_tbl;
> -		pcr->ms_pull_ctl_enable_tbl =
> -			rtl8411b_qfn48_ms_pull_ctl_enable_tbl;
> -		pcr->ms_pull_ctl_disable_tbl =
> -			rtl8411b_qfn48_ms_pull_ctl_disable_tbl;
> -	} else {
> -		pcr->sd_pull_ctl_enable_tbl =
> -			rtl8411b_qfn64_sd_pull_ctl_enable_tbl;
> -		pcr->sd_pull_ctl_disable_tbl =
> -			rtl8411b_qfn64_sd_pull_ctl_disable_tbl;
> -		pcr->ms_pull_ctl_enable_tbl =
> -			rtl8411b_qfn64_ms_pull_ctl_enable_tbl;
> -		pcr->ms_pull_ctl_disable_tbl =
> -			rtl8411b_qfn64_ms_pull_ctl_disable_tbl;
> -	}
> +	if (rtl8411b_is_qfn48(pcr))
> +		set_pull_ctrl_tables(rtl8411b_qfn48);
> +	else
> +		set_pull_ctrl_tables(rtl8411b_qfn64);
>  }
> diff --git a/drivers/mfd/rtsx_pcr.h b/drivers/mfd/rtsx_pcr.h
> index 947e79b..26b52ec 100644
> --- a/drivers/mfd/rtsx_pcr.h
> +++ b/drivers/mfd/rtsx_pcr.h
> @@ -63,4 +63,12 @@ static inline u8 map_sd_drive(int idx)
>  #define rtl8411_reg_to_sd30_drive_sel_3v3(reg)	(((reg) >> 5) & 0x07)
>  #define rtl8411b_reg_to_sd30_drive_sel_3v3(reg)	((reg) & 0x03)
>  
> +#define set_pull_ctrl_tables(__device)				\
> +do {								\
> +	pcr->sd_pull_ctl_enable_tbl  = __device##_sd_pull_ctl_enable_tbl;  \
> +	pcr->sd_pull_ctl_disable_tbl = __device##_sd_pull_ctl_disable_tbl; \
> +	pcr->ms_pull_ctl_enable_tbl  = __device##_ms_pull_ctl_enable_tbl;  \
> +	pcr->ms_pull_ctl_disable_tbl = __device##_ms_pull_ctl_disable_tbl; \
> +} while (0)
> +
>  #endif

-- 
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog

  reply	other threads:[~2013-12-03 10:55 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-12-03  9:26 [PATCH v2 0/3] mfd: rtsx: decrease driver size and add new device micky_ching
2013-12-03  9:26 ` [PATCH v2 1/3] mfd: rtsx: reduce code duplication in rtl8411 micky_ching
2013-12-03 10:55   ` Lee Jones [this message]
2013-12-03  9:26 ` [PATCH v2 2/3] mfd: rtsx: add card reader rtl8402 micky_ching
2013-12-03 10:45   ` Lee Jones
2013-12-03 11:02     ` micky
2013-12-03  9:26 ` [PATCH v2 3/3] mfd: rtsx: prevent 'used uninitialised' warnings micky_ching
2013-12-03 10:40   ` Lee Jones
2013-12-03 10:40     ` Lee Jones
2013-12-03 11:03       ` micky
2013-12-03 11:28         ` Lee Jones
2013-12-03 10:54     ` micky
2013-12-03 11:01       ` Lee Jones
2013-12-03 11:07         ` micky
2013-12-03 11:04       ` Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20131203105541.GM11828@lee--X1 \
    --to=lee.jones@linaro.org \
    --cc=devel@linuxdriverproject.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=micky_ching@realsil.com.cn \
    --cc=rogerable@realtek.com \
    --cc=sameo@linux.intel.com \
    --cc=wei_wang@realsil.com.cn \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome