mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: David Miller <davem@davemloft.net>
To: dan.j.williams@intel.com
Cc: ncardwell@google.com, dmaengine@vger.kernel.org,
	yoshfuji@linux-ipv6.org, netdev@vger.kernel.org,
	jmorris@namei.org, kuznet@ms2.inr.ac.ru, kaber@trash.net,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 3/4] net: make tcp_cleanup_rbuf private
Date: Thu, 09 Jan 2014 15:42:32 -0500 (EST)	[thread overview]
Message-ID: <20140109.154232.65818281679170677.davem@davemloft.net> (raw)
In-Reply-To: <CAPcyv4hPnCud=MWpsCMNZmK_BwVV8WZHOs7=GQMhymgkv-gNkw@mail.gmail.com>

From: Dan Williams <dan.j.williams@intel.com>
Date: Thu, 9 Jan 2014 12:33:29 -0800

> On Thu, Jan 9, 2014 at 12:26 PM, Neal Cardwell <ncardwell@google.com> wrote:
>> On Thu, Jan 9, 2014 at 3:16 PM, Dan Williams <dan.j.williams@intel.com> wrote:
>>> net_dma was the only external user so this can become local to tcp.c
>>> again.
>> ...
>>> -void tcp_cleanup_rbuf(struct sock *sk, int copied)
>>> +static void cleanup_rbuf(struct sock *sk, int copied)
>>
>> I would vote to keep the tcp_ prefix. In the TCP code base that is the
>> more common idiom, even for internal/static TCP functions, and
>> personally I find it easier to read and work with in stack traces,
>> etc. My 2 cents.
>>
> 
> Ok.  It was cleanup_rbuf() in a former life, but one vote for leaving
> the name as is is enough for me.

You can make that two votes :)

  reply	other threads:[~2014-01-09 20:42 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-01-09 20:12 [PATCH v2 0/4] net_dma removal, and dma debug extension Dan Williams
2014-01-09 20:16 ` [PATCH v2 1/4] net_dma: simple removal Dan Williams
2014-01-09 20:16 ` [PATCH v2 2/4] net_dma: revert 'copied_early' Dan Williams
2014-01-09 20:16 ` [PATCH v2 3/4] net: make tcp_cleanup_rbuf private Dan Williams
2014-01-09 20:26   ` Neal Cardwell
2014-01-09 20:33     ` Dan Williams
2014-01-09 20:42       ` David Miller [this message]
2014-01-10 10:38         ` David Laight
2014-01-09 20:17 ` [PATCH v2 4/4] dma debug: introduce debug_dma_assert_idle() Dan Williams
2014-01-10  0:38   ` Andrew Morton
2014-01-11  2:35     ` Dan Williams

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140109.154232.65818281679170677.davem@davemloft.net \
    --to=davem@davemloft.net \
    --cc=dan.j.williams@intel.com \
    --cc=dmaengine@vger.kernel.org \
    --cc=jmorris@namei.org \
    --cc=kaber@trash.net \
    --cc=kuznet@ms2.inr.ac.ru \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ncardwell@google.com \
    --cc=netdev@vger.kernel.org \
    --cc=yoshfuji@linux-ipv6.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®