From: Mark Brown <broonie@kernel.org>
To: Jean-Francois Moine <moinejf@free.fr>
Cc: alsa-devel@alsa-project.org, Dave Airlie <airlied@gmail.com>,
dri-devel@lists.freedesktop.org,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, Rob Clark <robdclark@gmail.com>,
Russell King - ARM Linux <linux@arm.linux.org.uk>
Subject: Re: [PATCH v3 2/5] ASoC: tda998x: add a codec driver for the TDA998x
Date: Tue, 4 Feb 2014 17:54:10 +0000 [thread overview]
Message-ID: <20140204175410.GL22609@sirena.org.uk> (raw)
In-Reply-To: <20140204181605.5b837a70@armhf>
[-- Attachment #1: Type: text/plain, Size: 3070 bytes --]
On Tue, Feb 04, 2014 at 06:16:05PM +0100, Jean-Francois Moine wrote:
> Mark Brown <broonie@kernel.org> wrote:
> > > + /* load the optional CODEC */
> > > + of_platform_populate(np, NULL, NULL, &client->dev);
> > Why is this using of_platform_populate()? That's a very odd way of
> > doing things.
> The i2c does not populate the subnodes in the DT. I did not find why,
> but, what is sure is that if of_platform_populate() is not called, the
> tda CODEC module is not loaded.
You shouldn't be representing this as a separate node in the DT unless
there really is a distinct and reusable IP, otherwise you're putting
Linux implementation details in there. Describe the hardware, not the
implemementation.
> You may find an other example in drivers/mfd/twl-core.c.
The TWL drivers aren't always a shining example of how to do things -
they were one of the earliest MFDs so there's warts in there.
> > > +config SND_SOC_TDA998X
> > > + tristate
> > > + depends on OF
> > > + default y if DRM_I2C_NXP_TDA998X=y
> > > + default m if DRM_I2C_NXP_TDA998X=m
> > Make this visible if it can be selected from DT so it can be used with
> > generic cards.
> I don't understand. The tda CODEC can only be used with the TDA998x I2C
> driver. It might have been included in the tda998x source as well.
You shouldn't have the default settings there at all, that's not the
normal idiom for MFDs. I'd also not expect to have to build the CODEC
driver just because I built the DRM component.
> Now, the CODEC is declared inside the tda998x as a node child. But, in
> a bad DT, the tda CODEC could be declared anywhere, even inside a other
> DRM I2C slave encoder, in which case, bad things would happen...
So, part of the problem here is that this is being explicitly declared
in the DT leading to more sources for error.
> > What does this actually do? No information is being passed in to the
> > core function here, not even any information on if it's starting or
> > stopping. Looking at the rest of the code I can't help thinking it
> > might be clearer to inline this possibly with a lookup helper, the code
> > is very small and the lack of parameters makes it hard to follow.
> I thought it was simple enough. The function tda_start_stop() is called
> from 2 places:
It's not at all obvious - _audio_update() isn't a terribly descriptive
name, just looking at that function by itself I had no idea what it was
supposed to be doing.
> - on audio start in tda_startup with the audio type (DAI id)
> priv->dai_id = dai->id;
> - on audio stop with a null audio type
> priv->dai_id = 0; /* streaming stop */
> On stream start, the DAI id is never null, as explained in the patch 1:
> The audio format values in the encoder configuration interface are
> changed to non null values so that the value 0 is used in the audio
> function to indicate that audio streaming is stopped.
> and on streaming stop the port is not meaningful.
> I will add a null item in the enum (AFMT_NO_AUDIO).
So we can't use both streams simultaneously then? That's a bit sad.
[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 836 bytes --]
next prev parent reply other threads:[~2014-02-04 17:54 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-02-01 17:10 [PATCH v3 0/5] add a TDA998x CODEC Jean-Francois Moine
2014-01-26 18:02 ` [PATCH v3 1/5] drm/i2c: tda998x: add a function for dynamic audio input switch Jean-Francois Moine
2014-01-26 18:45 ` [PATCH v3 2/5] ASoC: tda998x: add a codec driver for the TDA998x Jean-Francois Moine
2014-02-04 13:30 ` Mark Brown
2014-02-04 13:36 ` [alsa-devel] " Lars-Peter Clausen
2014-02-04 17:46 ` Mark Brown
2014-02-04 17:16 ` Jean-Francois Moine
2014-02-04 17:54 ` Mark Brown [this message]
2014-02-04 18:59 ` Jean-Francois Moine
2014-02-04 19:40 ` Mark Brown
2014-01-27 8:48 ` [PATCH v3 4/5] ASoC: tda998x: adjust the audio hw parameters from EDID Jean-Francois Moine
2014-02-04 18:06 ` Mark Brown
2014-02-05 9:11 ` Jean-Francois Moine
2014-02-05 9:19 ` [alsa-devel] " Lars-Peter Clausen
2014-02-05 11:18 ` Mark Brown
2014-02-05 13:31 ` Lars-Peter Clausen
2014-02-05 14:08 ` Mark Brown
2014-02-05 18:07 ` Jean-Francois Moine
2014-02-05 18:21 ` Lars-Peter Clausen
2014-01-30 11:08 ` [PATCH v3 5/5] ASoC: tda998x: adjust the audio CTS_N pre-divider from audio format Jean-Francois Moine
2014-02-04 18:09 ` Mark Brown
2014-02-01 16:48 ` [PATCH v3 3/5] ASoC: tda998x: add DT documentation of the tda998x CODEC Jean-Francois Moine
2014-02-01 18:30 ` Sergei Shtylyov
2014-02-04 18:12 ` Mark Brown
2014-02-04 19:02 ` Jean-Francois Moine
2014-02-04 19:54 ` Mark Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140204175410.GL22609@sirena.org.uk \
--to=broonie@kernel.org \
--cc=airlied@gmail.com \
--cc=alsa-devel@alsa-project.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@arm.linux.org.uk \
--cc=moinejf@free.fr \
--cc=robdclark@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®