From: "J. Bruce Fields" <bfields@fieldses.org>
To: Miklos Szeredi <miklos@szeredi.hu>
Cc: viro@ZenIV.linux.org.uk, torvalds@linux-foundation.org,
linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org,
hch@infradead.org, akpm@linux-foundation.org,
dhowells@redhat.com, zab@redhat.com, jack@suse.cz,
luto@amacapital.net, mszeredi@suse.cz
Subject: Re: [PATCH 08/13] vfs: add cross-rename
Date: Fri, 7 Feb 2014 17:40:44 -0500 [thread overview]
Message-ID: <20140207224044.GC8801@fieldses.org> (raw)
In-Reply-To: <1391791751-2533-9-git-send-email-miklos@szeredi.hu>
On Fri, Feb 07, 2014 at 05:49:06PM +0100, Miklos Szeredi wrote:
> From: Miklos Szeredi <mszeredi@suse.cz>
>
> If flags contain RENAME_EXCHANGE then exchange source and destination files.
> There's no restriction on the type of the files; e.g. a directory can be
> exchanged with a symlink.
>
> Signed-off-by: Miklos Szeredi <mszeredi@suse.cz>
> Reviewed-by: Jan Kara <jack@suse.cz>
I don't see any problem with the delegation stuff. Some random
bikeshedding:
> @@ -2575,6 +2579,10 @@ static void __d_move(struct dentry * dentry, struct dentry * target)
>
> /* Unhash the target: dput() will then get rid of it */
I never understood the point of this comment. It's not even right, is
it? And if anything this makes it less so. Delete?
> __d_drop(target);
> + if (exchange) {
> + __d_rehash(target,
> + d_hash(dentry->d_parent, dentry->d_name.hash));
> + }
>
> list_del(&dentry->d_u.d_child);
> list_del(&target->d_u.d_child);
...
> @@ -4042,7 +4057,7 @@ int vfs_rename(struct inode *old_dir, struct dentry *old_dentry,
>
> old_name = fsnotify_oldname_init(old_dentry->d_name.name);
> dget(new_dentry);
> - if (!is_dir)
> + if (!is_dir || (flags & RENAME_EXCHANGE))
> lock_two_nondirectories(source, target);
> else if (target)
> mutex_lock(&target->i_mutex);
I had to stop to think about that for a minute: OK, so in the normal
rename case we still need to lock the to-be-deleted target, and
lock_two_nondirectories won't do that for us because it ignores
directories. Got it.
This feels a bit ugly but I don't have a better idea.
> @@ -4051,25 +4066,25 @@ int vfs_rename(struct inode *old_dir, struct dentry *old_dentry,
Most of this function is under (flags & RENAME_EXCHANGE) conditionals at
this point. Have you looked at how much is duplicated if you split this
into something like vfs_rename and vfs_exchange?
--b.
next prev parent reply other threads:[~2014-02-07 22:40 UTC|newest]
Thread overview: 47+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-02-07 16:48 [PATCH 00/13] cross rename v4 Miklos Szeredi
2014-02-07 16:48 ` [PATCH 01/13] vfs: add d_is_dir() Miklos Szeredi
2014-02-07 17:36 ` J. Bruce Fields
2014-02-07 19:30 ` David Howells
2014-02-07 16:49 ` [PATCH 02/13] vfs: rename: move d_move() up Miklos Szeredi
2014-02-07 16:49 ` [PATCH 03/13] vfs: rename: use common code for dir and non-dir Miklos Szeredi
2014-02-07 16:49 ` [PATCH 04/13] vfs: add renameat2 syscall Miklos Szeredi
2014-02-07 16:49 ` [PATCH 05/13] vfs: add RENAME_NOREPLACE flag Miklos Szeredi
2014-02-07 16:49 ` [PATCH 06/13] security: add flags to rename hooks Miklos Szeredi
2014-02-07 16:49 ` [PATCH 07/13] vfs: lock_two_nondirectories: allow directory args Miklos Szeredi
2014-02-07 21:16 ` J. Bruce Fields
2014-02-11 15:32 ` Miklos Szeredi
2014-02-07 16:49 ` [PATCH 08/13] vfs: add cross-rename Miklos Szeredi
2014-02-07 22:40 ` J. Bruce Fields [this message]
2014-02-11 15:55 ` Miklos Szeredi
2014-02-07 16:49 ` [PATCH 09/13] ext4: rename: create ext4_renament structure for local vars Miklos Szeredi
2014-02-07 16:49 ` [PATCH 10/13] ext4: rename: move EMLINK check up Miklos Szeredi
2014-02-07 16:49 ` [PATCH 11/13] ext4: rename: split out helper functions Miklos Szeredi
2014-02-07 16:49 ` [PATCH 12/13] ext4: add cross rename support Miklos Szeredi
2014-02-11 21:23 ` Jan Kara
2014-02-07 16:49 ` [PATCH 13/13] vfs: merge rename2 into rename Miklos Szeredi
2014-02-07 22:46 ` [PATCH 00/13] cross rename v4 J. Bruce Fields
2014-02-11 15:57 ` Miklos Szeredi
2014-02-13 19:32 ` J. Bruce Fields
2014-02-10 10:51 ` Dave Chinner
2014-02-11 16:01 ` Miklos Szeredi
2014-02-12 17:18 ` Miklos Szeredi
2014-02-17 8:19 ` Dave Chinner
2014-02-17 18:04 ` Theodore Ts'o
2014-03-19 13:57 ` xfstest for renameat2 system call (was: [PATCH 00/13] cross rename v4) Miklos Szeredi
2014-04-08 1:23 ` Dave Chinner
2014-02-13 15:54 ` [PATCH 00/13] cross rename v4 David Howells
2014-02-13 16:25 ` Miklos Szeredi
2014-02-13 16:42 ` David Howells
2014-02-13 17:28 ` Miklos Szeredi
2014-02-13 18:21 ` Andy Lutomirski
2014-02-13 18:29 ` Linus Torvalds
2014-02-13 18:56 ` Miklos Szeredi
2014-02-13 19:20 ` Linus Torvalds
2014-02-13 19:02 ` David Howells
2014-02-13 19:32 ` Linus Torvalds
2014-02-13 20:17 ` Eric W. Biederman
2014-02-13 20:28 ` Miklos Szeredi
2014-02-24 17:12 ` Miklos Szeredi
2014-02-24 17:49 ` Linus Torvalds
2014-02-25 4:07 ` J. R. Okajima
2014-02-26 15:15 ` Jan Kara
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140207224044.GC8801@fieldses.org \
--to=bfields@fieldses.org \
--cc=akpm@linux-foundation.org \
--cc=dhowells@redhat.com \
--cc=hch@infradead.org \
--cc=jack@suse.cz \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=luto@amacapital.net \
--cc=miklos@szeredi.hu \
--cc=mszeredi@suse.cz \
--cc=torvalds@linux-foundation.org \
--cc=viro@ZenIV.linux.org.uk \
--cc=zab@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome