From: Lee Jones <lee.jones@linaro.org>
To: Laszlo Papp <lpapp@kde.org>
Cc: jdelvare@suse.de, linux@roeck-us.net, lm-sensors@lm-sensors.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] hwmon: (max6650) Rename the device ids to contain the hwmon suffix
Date: Mon, 10 Feb 2014 16:08:42 +0000 [thread overview]
Message-ID: <20140210160842.GB26997@lee--X1> (raw)
In-Reply-To: <1392045953-26596-1-git-send-email-lpapp@kde.org>
> In the preparation of creating an mfd driver and then refactor this one into a
> platform driver in order to add some pinctrl functionality to the chip, it is
> necessary to start the series with this change so that the mfd driver can refer
> to the proper name in the subsequent change without making changes in more than
> one driver later.
>
> This was a request from Lee Jones, the MFD subsystem maintainer.
>
> Signed-off-by: Laszlo Papp <lpapp@kde.org>
> ---
> drivers/hwmon/max6650.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/hwmon/max6650.c b/drivers/hwmon/max6650.c
> index 0cafc39..3c36edc 100644
> --- a/drivers/hwmon/max6650.c
> +++ b/drivers/hwmon/max6650.c
> @@ -116,8 +116,8 @@ static struct max6650_data *max6650_update_device(struct device *dev);
> */
>
> static const struct i2c_device_id max6650_id[] = {
> - { "max6650", 1 },
> - { "max6651", 4 },
> + { "max6650-hwmon", 1 },
> + { "max6651-hwmon", 4 },
Might be worth taking the opportunity to swap out these magic numbers
now.
> { }
> };
> MODULE_DEVICE_TABLE(i2c, max6650_id);
--
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog
next prev parent reply other threads:[~2014-02-10 16:08 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-02-10 15:25 Laszlo Papp
2014-02-10 16:08 ` Lee Jones [this message]
2014-02-10 16:38 ` [lm-sensors] " Jean Delvare
2014-02-10 16:53 ` linux
2014-02-10 18:59 ` Laszlo Papp
2014-02-10 23:10 ` Guenter Roeck
2014-02-11 3:23 ` Laszlo Papp
2014-02-11 3:35 ` Laszlo Papp
2014-02-10 16:58 ` Lee Jones
2014-02-10 17:43 ` Jean Delvare
2014-02-10 18:01 ` Lee Jones
2014-02-10 18:15 ` [lm-sensors] " Jean Delvare
2014-02-10 18:24 ` Lee Jones
2014-02-10 18:27 ` Laszlo Papp
2014-02-10 18:55 ` [lm-sensors] " Jean Delvare
2014-02-10 17:06 ` Laszlo Papp
2014-02-10 17:09 ` Laszlo Papp
2014-02-11 3:13 ` Laszlo Papp
2014-02-11 7:50 ` Jean Delvare
2014-02-11 8:19 ` Laszlo Papp
2014-02-11 8:28 ` Laszlo Papp
2014-02-11 8:49 ` Jean Delvare
2014-02-11 9:08 ` Laszlo Papp
2014-02-11 9:57 ` Lee Jones
2014-02-11 15:15 ` Laszlo Papp
2014-02-11 8:50 ` Lee Jones
2014-02-11 8:58 ` Laszlo Papp
2014-02-11 9:14 ` Laszlo Papp
2014-02-11 9:47 ` Lee Jones
2014-02-11 9:50 ` Laszlo Papp
2014-02-11 10:22 ` Laszlo Papp
2014-02-11 11:09 ` Laszlo Papp
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140210160842.GB26997@lee--X1 \
--to=lee.jones@linaro.org \
--cc=jdelvare@suse.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=lm-sensors@lm-sensors.org \
--cc=lpapp@kde.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®