From: Jiri Olsa <jolsa@redhat.com>
To: Jean Pihet <jean.pihet@linaro.org>
Cc: linux-kernel@vger.kernel.org, linaro-kernel@lists.linaro.org,
linux-arm-kernel@lists.infradead.org,
Arnaldo <acme@ghostprotocols.net>, Ingo Molnar <mingo@kernel.org>,
Will Deacon <will.deacon@arm.com>,
patches@linaro.org
Subject: Re: [PATCH] perf: ARM64: wire up perf_regs and unwind support
Date: Wed, 12 Feb 2014 14:09:38 +0100 [thread overview]
Message-ID: <20140212130938.GA7624@krava.brq.redhat.com> (raw)
In-Reply-To: <1391451427-31221-1-git-send-email-jean.pihet@linaro.org>
On Mon, Feb 03, 2014 at 07:17:07PM +0100, Jean Pihet wrote:
> This patch hooks in the perf_regs and libunwind code for ARM64.
> The tools/perf/arch/arm64 is created; it contains the arch specific
> code for DWARF unwinding.
>
> Signed-off-by: Jean Pihet <jean.pihet@linaro.org>
> Acked-by: Will Deacon <will.deacon@arm.com>
SNIP
> + */
> +const char *get_arch_regstr(unsigned int n)
> +{
> + const struct pt_regs_dwarfnum *roff;
> + for (roff = regdwarfnum_table; roff->name != NULL; roff++)
> + if (roff->dwarfnum == n)
> + return roff->name;
> + return NULL;
> +}
> diff --git a/tools/perf/arch/arm64/util/unwind.c b/tools/perf/arch/arm64/util/unwind.c
> new file mode 100644
> index 0000000..8d37a4c
> --- /dev/null
> +++ b/tools/perf/arch/arm64/util/unwind.c
> @@ -0,0 +1,82 @@
> +
> +#include <errno.h>
> +#include <libunwind.h>
> +#include "perf_regs.h"
> +#include "../../util/unwind.h"
> +
> +int unwind__arch_reg_id(int regnum)
I think this ^^^ wouldn't compile over acme/perf/core, bacause of
the recent code changes for the libdw unwind:
1d86598 perf callchain: Rename unwind__arch_reg_id into libunwind__arch_reg_id
jirka
next prev parent reply other threads:[~2014-02-12 13:10 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-02-03 18:17 Jean Pihet
2014-02-12 8:46 ` Jean Pihet
2014-02-12 10:10 ` Will Deacon
2014-02-12 11:27 ` Ingo Molnar
2014-02-12 11:30 ` Will Deacon
2014-02-12 13:02 ` Arnaldo Carvalho de Melo
2014-02-12 13:09 ` Jiri Olsa [this message]
2014-02-13 17:01 ` Jean Pihet
2014-02-13 17:06 Jean Pihet
2014-03-12 12:42 ` Jean Pihet
2014-03-12 17:45 ` Catalin Marinas
2014-03-13 10:12 ` Will Deacon
2014-03-13 10:22 ` Catalin Marinas
2014-03-13 12:01 ` Jean Pihet
2014-04-28 9:15 ` Jean Pihet
2014-04-28 9:24 ` Jiri Olsa
2014-04-28 12:32 ` Jean Pihet
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140212130938.GA7624@krava.brq.redhat.com \
--to=jolsa@redhat.com \
--cc=acme@ghostprotocols.net \
--cc=jean.pihet@linaro.org \
--cc=linaro-kernel@lists.linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=patches@linaro.org \
--cc=will.deacon@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®