From: Andrew Morton <akpm@linux-foundation.org>
To: Oleg Nesterov <oleg@redhat.com>
Cc: Peter Zijlstra <peterz@infradead.org>,
Al Viro <viro@ZenIV.linux.org.uk>,
David Woodhouse <dwmw2@infradead.org>,
Frederic Weisbecker <fweisbec@gmail.com>,
Geert Uytterhoeven <geert@linux-m68k.org>,
Ingo Molnar <mingo@kernel.org>,
Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
Richard Weinberger <richard@nod.at>,
Steven Rostedt <rostedt@goodmis.org>, Tejun Heo <tj@kernel.org>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH RESEND 04/11] signals: rename rm_from_queue_full() to flush_sigqueue_mask()
Date: Mon, 14 Apr 2014 15:02:21 -0700 [thread overview]
Message-ID: <20140414150221.b62ccb9fb9056527c565872f@linux-foundation.org> (raw)
In-Reply-To: <20140414151959.GA21995@redhat.com>
On Mon, 14 Apr 2014 17:19:59 +0200 Oleg Nesterov <oleg@redhat.com> wrote:
> "rm_from_queue_full" looks ugly and misleading, especially now that
> rm_from_queue() has gone away. Rename it to flush_sigqueue_mask(),
> this matches flush_sigqueue() we already have.
>
> Also remove the obsolete comment which explains the difference with
> rm_from_queue() we already killed.
>
Confused. You sent 0..11 on March 24 and today you resent just 4, 5,
10 and 11. If they're supposed to be replacement versions then please
explain this!
Anyway, emails are cheap and nobody reads lkml so please just resend
everything ;)
next prev parent reply other threads:[~2014-04-14 22:02 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20140414151929.GA21470@redhat.com>
2014-04-14 15:19 ` Oleg Nesterov
2014-04-14 22:02 ` Andrew Morton [this message]
2014-04-15 7:40 ` Peter Zijlstra
2014-04-15 7:45 ` Andrew Morton
2014-04-15 18:28 ` Oleg Nesterov
2014-04-14 15:20 ` [PATCH RESEND 05/11] signals: cleanup the usage of t/current in do_sigaction() Oleg Nesterov
2014-04-14 15:20 ` [PATCH RESEND 06/11] signals: mv {dis,}allow_signal() from sched.h/exit.c to signal.[ch] Oleg Nesterov
2014-04-14 15:20 ` [PATCH RESEND 07/11] signals: jffs2: fix the wrong usage of disallow_signal() Oleg Nesterov
2014-04-14 22:09 ` Andrew Morton
2014-04-14 15:20 ` [PATCH RESEND 08/11] signals: kill the obsolete sigdelset() and recalc_sigpending() in allow_signal() Oleg Nesterov
2014-04-14 15:20 ` [PATCH RESEND 09/11] signals: disallow_signal() should flush the potentially pending signal Oleg Nesterov
2014-04-14 15:20 ` [PATCH RESEND 10/11] signals: introduce kernel_sigaction() Oleg Nesterov
2014-04-14 15:20 ` [PATCH RESEND 11/11] signals: change wait_for_helper() to use kernel_sigaction() Oleg Nesterov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140414150221.b62ccb9fb9056527c565872f@linux-foundation.org \
--to=akpm@linux-foundation.org \
--cc=dwmw2@infradead.org \
--cc=fweisbec@gmail.com \
--cc=geert@linux-m68k.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=mingo@kernel.org \
--cc=oleg@redhat.com \
--cc=peterz@infradead.org \
--cc=richard@nod.at \
--cc=rostedt@goodmis.org \
--cc=tj@kernel.org \
--cc=viro@ZenIV.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®