mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Peter Zijlstra <peterz@infradead.org>
To: Fabian Frederick <fabf@skynet.be>
Cc: linux-kernel <linux-kernel@vger.kernel.org>,
	akpm <akpm@linux-foundation.org>
Subject: Re: [PATCH 2/2] kernel/stop_machine.c: remove false assignment to static
Date: Wed, 7 May 2014 23:04:11 +0200	[thread overview]
Message-ID: <20140507210411.GB2844@laptop.programming.kicks-ass.net> (raw)
In-Reply-To: <20140507224656.e06286af4392251135862718@skynet.be>

On Wed, May 07, 2014 at 10:46:56PM +0200, Fabian Frederick wrote:
> This patch also fixes function prototype over 80 characters

And does it wrong.. Also does it really matter to GCC that we init the
bool? Surely it can see its 0 and put it in .bss anyway?

> Cc: Peter Zijlstra <peterz@infradead.org>
> Cc: Andrew Morton <akpm@linux-foundation.org>
> Signed-off-by: Fabian Frederick <fabf@skynet.be>
> ---
>  kernel/stop_machine.c | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/kernel/stop_machine.c b/kernel/stop_machine.c
> index 695f0c6..8d29ee2 100644
> --- a/kernel/stop_machine.c
> +++ b/kernel/stop_machine.c
> @@ -42,7 +42,7 @@ struct cpu_stopper {
>  
>  static DEFINE_PER_CPU(struct cpu_stopper, cpu_stopper);
>  static DEFINE_PER_CPU(struct task_struct *, cpu_stopper_task);
> -static bool stop_machine_initialized = false;
> +static bool stop_machine_initialized;
>  
>  /*
>   * Avoids a race between stop_two_cpus and global stop_cpus, where
> @@ -241,7 +241,8 @@ static void irq_cpu_stop_queue_work(void *arg)
>   *
>   * returns when both are completed.
>   */
> -int stop_two_cpus(unsigned int cpu1, unsigned int cpu2, cpu_stop_fn_t fn, void *arg)
> +int stop_two_cpus(unsigned int cpu1, unsigned int cpu2, cpu_stop_fn_t fn,
> +		  void *arg)

Its only 84, so I didn't care to wrap it, its more readable this way,
but if you want it split split it like:

int
stop_two_cpus(unsigned int cpu1, unsigned int cpu2, cpu_stop_fn_t fn, void *arg)

Or if you really have to split arguments to it in groups that make
sense; like:

int stop_two_cpus(unsigned int cpu1, unsigned int cpu2,
		  cpu_stop_fn_t fn, void *arg)

But really, these are two unrelated changes, and should therefore not be
in a single patch.

  reply	other threads:[~2014-05-07 21:04 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-05-07 20:46 Fabian Frederick
2014-05-07 21:04 ` Peter Zijlstra [this message]
2014-05-08  5:07   ` Fabian Frederick

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140507210411.GB2844@laptop.programming.kicks-ass.net \
    --to=peterz@infradead.org \
    --cc=akpm@linux-foundation.org \
    --cc=fabf@skynet.be \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®