From: Felipe Balbi <balbi@ti.com>
To: "Antoine Ténart" <antoine.tenart@free-electrons.com>
Cc: <balbi@ti.com>, <gregkh@linuxfoundation.org>,
<Peter.Chen@freescale.com>, <kishon@ti.com>,
<stern@rowland.harvard.edu>, <sergei.shtylyov@cogentembedded.com>,
<yoshihiro.shimoda.uh@renesas.com>,
<alexandre.belloni@free-electrons.com>,
<thomas.petazzoni@free-electrons.com>, <zmxu@marvell.com>,
<jszhang@marvell.com>, <linux-usb@vger.kernel.org>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 0/8] usb: add support for the generic PHY framework
Date: Wed, 16 Jul 2014 12:45:13 -0500 [thread overview]
Message-ID: <20140716174513.GF3016@saruman.home> (raw)
In-Reply-To: <1405435156-27297-1-git-send-email-antoine.tenart@free-electrons.com>
[-- Attachment #1: Type: text/plain, Size: 2641 bytes --]
Hi,
On Tue, Jul 15, 2014 at 04:39:08PM +0200, Antoine Ténart wrote:
> Hi all,
>
> This is an attempt to add more common USB code aware of the generic PHY
> framework, while keeping the compatibility for the USB PHY one. It does
> not add the full support, some USB PHY specific functions not being
> available currently in the generic PHY subsystem (e.g. usb_phy_set_power()).
> But it allows to use the generic PHY framework in other cases, and might
> help others to convert their USB PHY drivers.
>
> A little background: I submitted a series to support USB on Berlin SoCs[1].
> One patch added a new PHY driver in drivers/usb/phy and Felipe asked it to
> be in the generic PHY framework instead[2]. This PHY being used by a ChipIdea
> driver, changes were needed in ChipIdea, OTG and HCD.
>
> This is done in 3 steps:
> 1. moving the OTG state from the USB PHY structure to the OTG one
> 2. renaming the field 'phy' to 'usb_phy'
> 3. adding a field for the generic framework PHY and dissociating its
> use from the USB PHY one
>
> Step 1 is in the first patch. Steps 2 and 3 are done for OTG, and ChipIdea
> subsystems in patches 2-3 and 7-8.
>
> HCD generic PHY support was made by Sergei and Yoshihiro[1]. I added some
> modifications to make this support consistent with this series in patches
> 4-6.
>
> I tested it by using the ChipIdea driver I introduced, both with an USB PHY
> and a PHY driver successfully. I also compiled a multi_v7 kernel (ARM), with
> every driver I could enable in the USB section.
>
> I'd like more people to test and your inputs and suggestions on these changes.
>
> Feel free to add Ccs if others might be interested in this. If needed patches
> can be squashed or divided, I tried there to group modifications by USB
> framework parts (OTG, HCD, ChipIdea).
>
> Patches can also be found at:
> git://git.free-electrons.com:users/antoine-tenart/linux.git usb-phy
>
> The series applies on top of Sergei and Yoshihiro generic PHY support in
> HCD[1].
>
> Thanks a lot!
>
> Antoine
>
> Changes since v1:
> - rebased the series on top of [1] (generic PHY support for HCD)
> - split s/phy/usb_phy/ renaming and generic PHY support in separate
> patches
>
> [1] https://www.mail-archive.com/linux-usb@vger.kernel.org/msg43471.html
Since this has a dependency on the other series which hasn't showed up
with enough Acks, I can't take this one either. Let's get this ready
early into v3.18-rc cycle so we don't miss this and the other series
again.
cheers
--
balbi
[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 819 bytes --]
next prev parent reply other threads:[~2014-07-16 17:46 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-07-15 14:39 Antoine Ténart
2014-07-15 14:39 ` [PATCH v2 1/8] usb: move the OTG state from the USB PHY to the OTG structure Antoine Ténart
2014-07-15 14:39 ` [PATCH v2 2/8] usb: rename phy to usb_phy in OTG Antoine Ténart
2014-07-15 14:39 ` [PATCH v2 3/8] usb: add support to the generic PHY framework " Antoine Ténart
2014-07-15 14:39 ` [PATCH v2 4/8] usb: rename phy to usb_phy in HCD Antoine Ténart
2014-07-15 15:55 ` Sergei Shtylyov
2014-07-16 15:09 ` Felipe Balbi
2014-07-16 17:02 ` Sergei Shtylyov
2014-07-15 14:39 ` [PATCH v2 5/8] usb: rename gen_phy to phy " Antoine Ténart
2014-07-15 14:39 ` [PATCH v2 6/8] usb: allow to supply the PHY in the drivers when using HCD Antoine Ténart
2014-07-23 10:59 ` Peter Chen
2014-07-15 14:39 ` [PATCH v2 7/8] usb: rename transceiver and phy to usb_phy in ChipIdea Antoine Ténart
2014-07-24 11:12 ` Peter Chen
2014-07-15 14:39 ` [PATCH v2 8/8] usb: chipidea: add support to the generic PHY framework " Antoine Ténart
2014-07-24 11:39 ` Peter Chen
2014-07-24 12:25 ` Antoine Ténart
2014-07-25 0:34 ` Peter Chen
2014-07-25 8:13 ` Antoine Ténart
2014-07-25 8:33 ` Peter Chen
2014-07-25 8:38 ` Antoine Ténart
2014-07-15 15:58 ` [PATCH v2 0/8] usb: add support for the generic PHY framework Alan Stern
2014-07-16 17:45 ` Felipe Balbi [this message]
2014-07-17 8:03 ` Antoine Ténart
2014-07-17 17:23 ` Felipe Balbi
2014-07-23 11:36 ` Peter Chen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140716174513.GF3016@saruman.home \
--to=balbi@ti.com \
--cc=Peter.Chen@freescale.com \
--cc=alexandre.belloni@free-electrons.com \
--cc=antoine.tenart@free-electrons.com \
--cc=gregkh@linuxfoundation.org \
--cc=jszhang@marvell.com \
--cc=kishon@ti.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=sergei.shtylyov@cogentembedded.com \
--cc=stern@rowland.harvard.edu \
--cc=thomas.petazzoni@free-electrons.com \
--cc=yoshihiro.shimoda.uh@renesas.com \
--cc=zmxu@marvell.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®