From: Tejun Heo <tj@kernel.org>
To: Linus Torvalds <torvalds@linux-foundation.org>
Cc: linux-kernel@vger.kernel.org, Lai Jiangshan <laijs@cn.fujitsu.com>
Subject: [GIT PULL] workqueue changes for v3.17-rc1
Date: Mon, 4 Aug 2014 09:56:51 -0400 [thread overview]
Message-ID: <20140804135651.GA26230@htj.dyndns.org> (raw)
Hello, Linus.
Lai has been doing a lot of cleanups of workqueue and kthread_work.
No significant behavior change. Just a lot of cleanups all over the
place. Some are a bit invasive but overall nothing too dangerous.
Thanks.
The following changes since commit ebe06187bf2aec10d537ce4595e416035367d703:
epoll: fix use-after-free in eventpoll_release_file (2014-06-16 17:21:59 -1000)
are available in the git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/tj/wq.git for-3.17
for you to fetch changes up to 95847e1bd34c0de86039408b24a05f07e788061d:
kthread_work: remove the unused wait_queue_head (2014-07-28 14:16:30 -0400)
----------------------------------------------------------------
Lai Jiangshan (20):
workqueue: use "pool->cpu < 0" to stand for an unbound pool
workqueue: remove the empty check in too_many_workers()
workqueue: use schedule_timeout_interruptible() instead of open code
workqueue: remove useless WARN_ON_ONCE()
workqueue: clear leftover flags when detached
workqueue: sanity check pool->cpu in wq_worker_sleeping()
workqueue: clear POOL_DISASSOCIATED in rebind_workers()
workqueue: stronger test in process_one_work()
workqueue: reuse the already calculated pwq in try_to_grab_pending()
workqueue: alloc struct worker on its local node
workqueue: wake regular worker if need_more_worker() when rescuer leave the pool
workqueue: remove an unneeded UNBOUND test before waking up the next worker
workqueue: remove @wakeup from worker_set_flags()
workqueue: unfold start_worker() into create_worker()
workqueue: move rescuer pool detachment to the end
workqueue: remove the stale comment in pwq_unbound_release_workfn()
workqueue: remove the misnamed out_unlock label in get_unbound_pool()
workqueue: use nr_node_ids instead of wq_numa_tbl_len
kthread_work: wake up worker only when the worker is idle
kthread_work: remove the unused wait_queue_head
include/linux/kthread.h | 13 +---
kernel/kthread.c | 2 +-
kernel/workqueue.c | 200 +++++++++++++++---------------------------------
3 files changed, 64 insertions(+), 151 deletions(-)
--
tejun
reply other threads:[~2014-08-04 13:56 UTC|newest]
Thread overview: [no followups] expand[flat|nested] mbox.gz Atom feed
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140804135651.GA26230@htj.dyndns.org \
--to=tj@kernel.org \
--cc=laijs@cn.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®