From: Peter Zijlstra <peterz@infradead.org>
To: David Rientjes <rientjes@google.com>
Cc: Bart Van Assche <bvanassche@acm.org>,
Ingo Molnar <mingo@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
"David S. Miller" <davem@davemloft.net>,
linux-kernel <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v3] spin_lock_nested(): Always evaluate second argument
Date: Sat, 9 Aug 2014 08:17:12 +0200 [thread overview]
Message-ID: <20140809061712.GL9918@twins.programming.kicks-ass.net> (raw)
In-Reply-To: <alpine.DEB.2.02.1408081451470.15603@chino.kir.corp.google.com>
[-- Attachment #1: Type: text/plain, Size: 1165 bytes --]
On Fri, Aug 08, 2014 at 02:52:50PM -0700, David Rientjes wrote:
> On Fri, 8 Aug 2014, Bart Van Assche wrote:
>
> > diff --git a/include/linux/spinlock.h b/include/linux/spinlock.h
> > index 3f2867f..262ba4e 100644
> > --- a/include/linux/spinlock.h
> > +++ b/include/linux/spinlock.h
> > @@ -197,7 +197,13 @@ static inline void do_raw_spin_unlock(raw_spinlock_t *lock) __releases(lock)
> > _raw_spin_lock_nest_lock(lock, &(nest_lock)->dep_map); \
> > } while (0)
> > #else
> > -# define raw_spin_lock_nested(lock, subclass) _raw_spin_lock(lock)
> > +/*
> > + * Always evaluate the 'subclass' argument to avoid that the compiler
> > + * warns about set-but-not-used variables when building with
> > + * CONFIG_DEBUG_LOCK_ALLOC=n and with W=1.
> > + */
>
> I was hoping there was going to be a more important reason for this change
> than to avoid compiler warnings, such as an example where someone is doing
> spin_lock_nested(lock, subclass) and the expression for "subclass"
> requires evaluation in all configs.
That would stink, having that argument have side effects. I'd call that
a plain old bug that needs fixing.
[-- Attachment #2: Type: application/pgp-signature, Size: 836 bytes --]
next prev parent reply other threads:[~2014-08-09 6:17 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-07-22 7:17 [PATCH RESEND] spin_lock_*(): " Bart Van Assche
2014-07-22 20:37 ` Andrew Morton
2014-07-22 23:16 ` David Rientjes
2014-08-06 17:07 ` Bart Van Assche
2014-08-06 17:10 ` [PATCH v2] spin_lock_nested(): " Bart Van Assche
2014-08-06 21:56 ` David Rientjes
2014-08-08 10:32 ` Bart Van Assche
2014-08-08 10:35 ` [PATCH v3] " Bart Van Assche
2014-08-08 21:52 ` David Rientjes
2014-08-09 6:17 ` Peter Zijlstra [this message]
2014-08-13 10:56 ` [tip:locking/core] locking/spinlocks: Always evaluate the second argument of spin_lock_nested() tip-bot for Bart Van Assche
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140809061712.GL9918@twins.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=akpm@linux-foundation.org \
--cc=bvanassche@acm.org \
--cc=davem@davemloft.net \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=rientjes@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome