From: Jiri Olsa <jolsa@redhat.com>
To: Arnaldo Carvalho de Melo <acme@kernel.org>
Cc: linux-kernel@vger.kernel.org,
Adrian Hunter <adrian.hunter@intel.com>,
Borislav Petkov <bp@suse.de>,
Corey Ashford <cjashfor@linux.vnet.ibm.com>,
David Ahern <dsahern@gmail.com>, Don Zickus <dzickus@redhat.com>,
Frederic Weisbecker <fweisbec@gmail.com>,
Ingo Molnar <mingo@kernel.org>,
Jean Pihet <jean.pihet@linaro.org>,
Mike Galbraith <efault@gmx.de>,
Namhyung Kim <namhyung@kernel.org>,
Paul Mackerras <paulus@samba.org>,
Peter Zijlstra <peterz@infradead.org>,
Stephane Eranian <eranian@google.com>
Subject: Re: [RFC 00/10] perf pollfd series
Date: Mon, 25 Aug 2014 13:04:31 +0200 [thread overview]
Message-ID: <20140825110431.GC11611@krava.brq.redhat.com> (raw)
In-Reply-To: <1408741190-5123-1-git-send-email-acme@kernel.org>
On Fri, Aug 22, 2014 at 05:59:40PM -0300, Arnaldo Carvalho de Melo wrote:
> Hi,
>
> This is an alternative series to the one Jiri Olsa posted to use the
> fixes he made to the kernel side to allow tooling to notice that a thread had
> exited by looking at the pollfd.revents looking for POLLHUP notifications.
>
> Once all event file descriptors are removed from the evlist pollfd array,
> tools can make a decision about exiting or telling the user about what happened,
> asking to guidance on what to do next.
>
> The main difference in this approach is that a new class, which Jiri
> called 'poller' and I called 'fdarray', grew up from what was in evlist->pollfd
> and associated operations, while Jiri first introduced a new class and then
> made tooling use it.
>
> The details of the implementation should be clear on the changelog
> comments, please let me know if you see any problems, and if I can have your
> acked-by/tested-by/whatever-else tags to get this moving forward.
>
> Ah, there is still one missing thing which is to make the hists browser
> in live mode be notified that all monitored events are POLLHUP'ed, will get
> to that in followup patches.
>
> The kernel bits were sent together with my latest pull req to Ingo,
> this series is on top of that branch and is available at:
>
> git://git.kernel.org/pub/scm/linux/kernel/git/acme/linux.git perf/pollfd
>
> - Arnaldo
>
> Arnaldo Carvalho de Melo (10):
> perf evlist: Introduce perf_evlist__filter_pollfd method
> perf tests: Add test for perf_evlist__filter_pollfd()
> perf evlist: Monitor POLLERR and POLLHUP events too
> perf record: Filter out POLLHUP'ed file descriptors
> perf trace: Filter out POLLHUP'ed file descriptors
> perf evlist: Allow growing pollfd on add method
> perf tests: Add pollfd growing test
> perf kvm stat live: Use perf_evlist__add_pollfd() instead of local equivalent
> perf evlist: Introduce poll method for common code idiom
> tools lib api: Adopt fdarray class from perf's evlist
fdarray name seems too generic for this object, fdpoll looks
more suitable.. also given that the file name is poll.[ch] ;-)
anyway, except for what I've already commented:
Acked-by: Jiri Olsa <jolsa@kernel.org>
jirka
next prev parent reply other threads:[~2014-08-25 11:05 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-08-22 20:59 Arnaldo Carvalho de Melo
2014-08-22 20:59 ` [PATCH 01/10] perf evlist: Introduce perf_evlist__filter_pollfd method Arnaldo Carvalho de Melo
2014-08-25 6:57 ` Adrian Hunter
2014-08-22 20:59 ` [PATCH 02/10] perf tests: Add test for perf_evlist__filter_pollfd() Arnaldo Carvalho de Melo
2014-08-22 20:59 ` [PATCH 03/10] perf evlist: Monitor POLLERR and POLLHUP events too Arnaldo Carvalho de Melo
2014-08-22 20:59 ` [PATCH 04/10] perf record: Filter out POLLHUP'ed file descriptors Arnaldo Carvalho de Melo
2014-08-22 20:59 ` [PATCH 05/10] perf trace: " Arnaldo Carvalho de Melo
2014-08-22 20:59 ` [PATCH 06/10] perf evlist: Allow growing pollfd on add method Arnaldo Carvalho de Melo
2014-08-25 9:41 ` Jiri Olsa
2014-08-25 9:47 ` Jiri Olsa
2014-08-25 15:59 ` Arnaldo Carvalho de Melo
2014-08-22 20:59 ` [PATCH 07/10] perf tests: Add pollfd growing test Arnaldo Carvalho de Melo
2014-08-22 20:59 ` [PATCH 08/10] perf kvm stat live: Use perf_evlist__add_pollfd() instead of local equivalent Arnaldo Carvalho de Melo
2014-08-26 14:04 ` David Ahern
2014-08-22 20:59 ` [PATCH 09/10] perf evlist: Introduce poll method for common code idiom Arnaldo Carvalho de Melo
2014-08-22 20:59 ` [PATCH 10/10] tools lib api: Adopt fdarray class from perf's evlist Arnaldo Carvalho de Melo
2014-08-26 7:46 ` Namhyung Kim
2014-08-26 13:08 ` Arnaldo Carvalho de Melo
2014-08-25 11:04 ` Jiri Olsa [this message]
2014-08-25 15:56 ` [RFC 00/10] perf pollfd series Arnaldo Carvalho de Melo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140825110431.GC11611@krava.brq.redhat.com \
--to=jolsa@redhat.com \
--cc=acme@kernel.org \
--cc=adrian.hunter@intel.com \
--cc=bp@suse.de \
--cc=cjashfor@linux.vnet.ibm.com \
--cc=dsahern@gmail.com \
--cc=dzickus@redhat.com \
--cc=efault@gmx.de \
--cc=eranian@google.com \
--cc=fweisbec@gmail.com \
--cc=jean.pihet@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=namhyung@kernel.org \
--cc=paulus@samba.org \
--cc=peterz@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome