mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Petr Mládek" <pmladek@suse.cz>
To: Alan Stern <stern@rowland.harvard.edu>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Tejun Heo <tj@kernel.org>,
	Joe Lawrence <joe.lawrence@stratus.com>,
	Jiri Kosina <jkosina@suse.cz>,
	linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/4] usb: hub: remove obsolete while cycle in hub_event()
Date: Wed, 17 Sep 2014 17:24:55 +0200	[thread overview]
Message-ID: <20140917152453.GF2168@dhcp128.suse.cz> (raw)
In-Reply-To: <Pine.LNX.4.44L0.1409121020500.1180-100000@iolanthe.rowland.org>

On Fri 12-09-14 10:23:26, Alan Stern wrote:
> On Fri, 12 Sep 2014, Petr Mladek wrote:
> 
> > The USB hub events are proceed by workqueue instead of kthread now.
> > The result is that hub_event() function processes only one event.
> > The while cycle was not removed earlier to show the real changes when
> > switching to the workqueue.
> > 
> > This patch also consolidates the goto targets and rename them from "loop*"
> > to "out*".
> > 
> > When touching the code, it fixes also formatting of dev_err() and dev_dbg()
> > calls to make checkpatch.pl happy :-)
> 
> Although the reason given in the description above is not really
> accurate, removing the loop in hub_events is a reasonable thing to do.  
> That loop doesn't serve any purpose as far as I can see.

IMHO, the while cycle was needed when hub_events() was used in
khubd thread. More events could had been added to the list before
the thread was scheduled.

Therefore I think that the above description makes sense.

And this is why I did not change the order of the patches in v2 of the patch
set. I sent all patches again because this one and the 3rd one needed
refresh.

Best Regards,
Petr

  reply	other threads:[~2014-09-17 15:25 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-09-12 12:21 [PATCH 0/4] usb: hub: convert khubd into workqueue Petr Mladek
2014-09-12 12:21 ` [PATCH 1/4] " Petr Mladek
2014-09-12 14:16   ` Alan Stern
2014-09-12 15:08     ` Petr Mladek
2014-09-12 15:44       ` Alan Stern
2014-09-16  9:10         ` Petr Mládek
2014-09-16 15:17           ` Petr Mládek
2014-09-16 15:32           ` Alan Stern
2014-09-12 18:08   ` Tejun Heo
2014-09-12 12:21 ` [PATCH 2/4] usb: hub: remove obsolete while cycle in hub_event() Petr Mladek
2014-09-12 14:23   ` Alan Stern
2014-09-17 15:24     ` Petr Mládek [this message]
2014-09-17 16:01       ` Alan Stern
2014-09-12 12:21 ` [PATCH 3/4] usb: hub: rename *kick_khubd to *kick_hub_wq Petr Mladek
2014-09-12 12:21 ` [PATCH 4/4] usb: hub: rename khubd to hub_wq in documentation and comments Petr Mladek

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140917152453.GF2168@dhcp128.suse.cz \
    --to=pmladek@suse.cz \
    --cc=gregkh@linuxfoundation.org \
    --cc=jkosina@suse.cz \
    --cc=joe.lawrence@stratus.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=stern@rowland.harvard.edu \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®