From: Tejun Heo <tj@kernel.org>
To: "Petr Mládek" <pmladek@suse.cz>
Cc: Alan Stern <stern@rowland.harvard.edu>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Joe Lawrence <joe.lawrence@stratus.com>,
Jiri Kosina <jkosina@suse.cz>,
linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 4/4] usb: hub: rename khubd to hub_wq in documentation and comments
Date: Thu, 18 Sep 2014 12:31:47 -0400 [thread overview]
Message-ID: <20140918163147.GA13573@mtj.dyndns.org> (raw)
In-Reply-To: <20140918161501.GG2168@dhcp128.suse.cz>
On Thu, Sep 18, 2014 at 06:15:02PM +0200, Petr Mládek wrote:
> The easiest solution would be to allocate the work queue with
> the flag WQ_UNBOUND and max_active = 1. It will force serialization
> of all work items.
Please use alloc_ordered_workqueue() for that purpose. WQ_UNBOUND +
max_active == 1 no longer guarantees single thread of execution.
Thanks.
--
tejun
next prev parent reply other threads:[~2014-09-18 16:32 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-09-17 15:19 [PATCH v2 0/4] usb: hub: convert khubd into workqueue Petr Mladek
2014-09-17 15:19 ` [PATCH v2 1/4] " Petr Mladek
2014-09-17 17:31 ` Alan Stern
2014-09-17 15:19 ` [PATCH v2 2/4] usb: hub: remove obsolete while cycle in hub_event() Petr Mladek
2014-09-17 17:33 ` Alan Stern
2014-09-17 15:19 ` [PATCH v2 3/4] usb: hub: rename usb_kick_khubd() to usb_kick_hub_wq() Petr Mladek
2014-09-17 15:19 ` [PATCH v2 4/4] usb: hub: rename khubd to hub_wq in documentation and comments Petr Mladek
2014-09-17 17:36 ` Alan Stern
2014-09-17 21:22 ` Tejun Heo
2014-09-18 14:24 ` Alan Stern
2014-09-18 16:15 ` Petr Mládek
2014-09-18 16:31 ` Tejun Heo [this message]
2014-09-18 17:21 ` Alan Stern
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140918163147.GA13573@mtj.dyndns.org \
--to=tj@kernel.org \
--cc=gregkh@linuxfoundation.org \
--cc=jkosina@suse.cz \
--cc=joe.lawrence@stratus.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=pmladek@suse.cz \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®