From: Francois Romieu <romieu@fr.zoreil.com>
To: Chun-Hao Lin <hau@realtek.com>
Cc: netdev@vger.kernel.org, nic_swsd@realtek.com,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH net-next 07/10] r8169:change function name of function "rtl_w1w0_eri"
Date: Wed, 1 Oct 2014 00:37:07 +0200 [thread overview]
Message-ID: <20140930223707.GB27610@electric-eye.fr.zoreil.com> (raw)
In-Reply-To: <1412089230-10208-7-git-send-email-hau@realtek.com>
Chun-Hao Lin <hau@realtek.com> :
> Change the name of this function to "rtl_w0_w1_eri".
> It is more suitable for this function's behavior.
Afaiks it used to follow the same rule as the one I outlined in the
comment to #6/10 for rtl_w0_w1_phy.
Could you elaborate (or say so if it should be clear for me after
some sleep) ?
[...]
> diff --git a/drivers/net/ethernet/realtek/r8169.c b/drivers/net/ethernet/realtek/r8169.c
> index e68fe5e..e79def5 100644
> --- a/drivers/net/ethernet/realtek/r8169.c
> +++ b/drivers/net/ethernet/realtek/r8169.c
[...]
> @@ -1629,14 +1629,14 @@ static void __rtl8169_set_wol(struct rtl8169_private *tp, u32 wolopts)
> case RTL_GIGA_MAC_VER_48:
> tmp = ARRAY_SIZE(cfg) - 1;
> if (wolopts & WAKE_MAGIC)
> - rtl_w1w0_eri(tp,
> + rtl_w0w1_eri(tp,
> 0x0dc,
> ERIAR_MASK_0100,
> MagicPacket_v2,
> 0x0000,
> ERIAR_EXGMAC);
> else
> - rtl_w1w0_eri(tp,
> + rtl_w0w1_eri(tp,
> 0x0dc,
> ERIAR_MASK_0100,
> 0x0000,
Please turn these into:
rtl_..._eri(tp, 0x0dc, ERIAR_MASK_0100, MagicPacket_v2,
0x0000, ERIAR_EXGMAC);
--
Ueimor
next prev parent reply other threads:[~2014-09-30 22:37 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-09-30 15:00 [PATCH net-next 01/10] r8169:change uppercase number to lowercase nubmer Chun-Hao Lin
2014-09-30 15:00 ` [PATCH net-next 02/10] r8169:add disable/enable RTL8168G pll function Chun-Hao Lin
2014-09-30 20:43 ` David Miller
2014-09-30 15:00 ` [PATCH net-next 03/10] r8169:add disable/enable RTL8168GU mcu power managment interrupt Chun-Hao Lin
2014-09-30 15:00 ` [PATCH net-next 04/10] r8168:add support more chips to get mac address from backup mac address register Chun-Hao Lin
2014-09-30 15:00 ` [PATCH net-next 05/10] r8169:add more chips to support magic packet v2 Chun-Hao Lin
2014-09-30 15:00 ` [PATCH net-next 06/10] r8169:change function name and behavior of function "rtl_w1w0_phy" Chun-Hao Lin
2014-09-30 22:33 ` Francois Romieu
2014-09-30 15:00 ` [PATCH net-next 07/10] r8169:change function name of function "rtl_w1w0_eri" Chun-Hao Lin
2014-09-30 22:37 ` Francois Romieu [this message]
2014-09-30 15:00 ` [PATCH net-next 08/10] r8169:change function name of function "r8168dp_check_dash" to "r8168_check_dash" Chun-Hao Lin
2014-09-30 20:45 ` David Miller
2014-09-30 15:00 ` [PATCH net-next 09/10] r8169:modify the behavior of function "rtl8168_oob_notify" Chun-Hao Lin
2014-09-30 15:00 ` [PATCH net-next 10/10] r8169:call "rtl8168_driver_start" "rtl8168_driver_stop" only when dash is enabled Chun-Hao Lin
2014-09-30 20:46 ` David Miller
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140930223707.GB27610@electric-eye.fr.zoreil.com \
--to=romieu@fr.zoreil.com \
--cc=hau@realtek.com \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=nic_swsd@realtek.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®