mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Mark Brown <broonie@kernel.org>
To: Romain Perier <romain.perier@gmail.com>
Cc: devicetree@vger.kernel.org, lgirdwood@gmail.com,
	linux-kernel@vger.kernel.org, heiko@sntech.de
Subject: Re: [RFC][PATCH 1/4] regulator: Add helper function to get "poweroff-source" property
Date: Wed, 1 Oct 2014 19:07:59 +0100	[thread overview]
Message-ID: <20141001180759.GH4273@sirena.org.uk> (raw)
In-Reply-To: <1412098186-5042-1-git-send-email-romain.perier@gmail.com>

[-- Attachment #1: Type: text/plain, Size: 912 bytes --]

On Tue, Sep 30, 2014 at 05:29:43PM +0000, Romain Perier wrote:

> +/**
> + * of_get_regulator_poweroff_source - Get poweroff-source for given device_node
> + * @np: Pointer to the given device_node
> + *
> + * return true if present false otherwise
> + */
> +bool of_get_regulator_poweroff_source(const struct device_node *np)
> +{
> +	return of_property_read_bool(np, "poweroff-source");
> +}
> +EXPORT_SYMBOL_GPL(of_get_regulator_poweroff_source);

This isn't really a regulator specific thing - it's common for the
actual implementation to be to simply cut power but it could be
something that doesn't look like a regulator doing it like a system
monitor.  I'd rename this to something like is_system_poweroff_source().

You probably also want to CC the DT maintainers on this and add some
documentation of this as a standard property, not entirely sure where
exactly but I'm sure the DT people could advise.

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 473 bytes --]

  parent reply	other threads:[~2014-10-01 18:08 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-09-30 17:29 Romain Perier
2014-09-30 17:29 ` [RFC][PATCH 2/4] regulator: act8865: Add support to turn off all outputs Romain Perier
2014-09-30 17:29 ` [RFC][PATCH 3/4] ARM: dts: rockchip: Enable power off in pmic for Radxa Rock Romain Perier
2014-09-30 17:29 ` [RFC][PATCH 4/4] dt-bindings: Document the property poweroff-source for act8865 regulator Romain Perier
2014-10-01 18:07 ` Mark Brown [this message]
2014-10-02 17:43   ` [RFC][PATCH 1/4] regulator: Add helper function to get "poweroff-source" property Romain Perier

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20141001180759.GH4273@sirena.org.uk \
    --to=broonie@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=heiko@sntech.de \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=romain.perier@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®