From: Petr Mladek <pmladek@suse.cz>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: linux-kernel@vger.kernel.org, Ingo Molnar <mingo@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
Jiri Kosina <jkosina@suse.cz>, "H. Peter Anvin" <hpa@zytor.com>,
Thomas Gleixner <tglx@linutronix.de>,
"Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Subject: Re: [RFC][PATCH 12/12 v3] x86/nmi: Perform a safe NMI stack trace on all CPUs
Date: Mon, 10 Nov 2014 19:58:48 +0100 [thread overview]
Message-ID: <20141110185847.GC2552@dhcp128.suse.cz> (raw)
In-Reply-To: <20141107135609.7ccdd3ce@gandalf.local.home>
On Fri 2014-11-07 13:56:09, Steven Rostedt wrote:
> On Thu, 6 Nov 2014 19:41:55 +0100
> Petr Mladek <pmladek@suse.cz> wrote:
>
> > > /* "in progress" flag of arch_trigger_all_cpu_backtrace */
> > > static unsigned long backtrace_flag;
> > >
> > > +static void print_seq_line(struct nmi_seq_buf *s, int last, int pos)
> >
> > I would rename the arguments:
> >
> > "last -> first"
> > "pos -> last"
> >
> > or maybe better would be to pass first positon and len.
>
> I switched it to "start" and "end" to not be confused by the last_i
> that is being passed in.
I like it.
> >
> > > +{
> > > + const char *buf = s->buffer + last;
> > > +
> > > + printk("%.*s", (pos - last) + 1, buf);
> > > +}
> >
>
>
>
> > >
> > > + /*
> > > + * Now that all the NMIs have triggered, we can dump out their
> > > + * back traces safely to the console.
> > > + */
> > > + for_each_cpu(cpu, printtrace_mask) {
> > > + int last_i = 0;
> > > +
> > > + s = &per_cpu(nmi_print_seq, cpu);
> > > + len = s->seq.len;
> >
> > If there is an seq_buf overflow, the len might be size + 1, so we need to do:
> >
> > len = min(s->seq.len, s->size);
> >
> > Well, we should create a function for this in seq_buf.h.
> > Alternatively, we might reconsider the overflow state,
> > use len == size and extra "overflow" flag in the seq_buf struct.
> >
> >
> > > + if (!len)
> > > + continue;
> > > +
> > > + /* Print line by line. */
> > > + for (i = 0; i < len; i++) {
> > > + if (s->buffer[i] == '\n') {
> > > + print_seq_line(s, last_i, i);
> > > + last_i = i + 1;
> > > + }
> > > + }
> > >
> > > + if (last_i < i - 1) {
> >
> > IMHO, this should be:
> >
> > if (last_i < i)
> >
> > because last_i = i + 1. Otherwise, we would ignore state when there is
> > one character after a new line. For example, imagine the following:
> >
> > buffer = "a\nb";
> > len = 3;
> >
> > it will end with:
> >
> > last_i = 2;
> > i = 3;
> >
> > and we still need to print the "b".
>
> Well, we really don't *need* to ;-)
>
> But for correctness sake, I agree, it should be last_i < i.
I agree that one more character does not make much difference but
it might save someones day :-)
> >
> > > + print_seq_line(s, last_i, i);
> >
> > If I get it correctly, (i == len) here and "printk_seq_line"
> > print_seq_line() prints the characters including "pos" value.
> > So, we should call:
> >
> > print_seq_line(s, last_i, i - 1)
>
> Right that was wrong. Actually, I think the best answer would be:
>
> print_seq_line(s, last_i, len - 1);
Yup
> This removes the variable 'i'. Probably should add a comment here too
> that reminds the reviewer that print_seq_line() prints up to and
> including the last index.
Yes, the comment is worth having.
> Note, my current code also has:
>
> len = seq_buf_used(&s->seq);
>
> where we don't need to worry about the semantics of seq_buf internals.
Perfect
Thanks a lot for working on it. Please, resend this patch once you are
happy with it.
Best Regards,
Petr
prev parent reply other threads:[~2014-11-10 18:58 UTC|newest]
Thread overview: 77+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-04 15:52 [RFC][PATCH 00/12 v3] seq-buf/x86/printk: Print all stacks from NMI safely Steven Rostedt
2014-11-04 15:52 ` [RFC][PATCH 01/12 v3] x86/kvm/tracing: Use helper function trace_seq_buffer_ptr() Steven Rostedt
2014-11-04 16:27 ` Paolo Bonzini
2014-11-04 17:17 ` Rustad, Mark D
2014-11-04 19:09 ` Steven Rostedt
2014-11-04 19:35 ` Steven Rostedt
2014-11-04 20:09 ` Rustad, Mark D
2014-11-05 10:28 ` Petr Mladek
2014-11-04 15:52 ` [RFC][PATCH 02/12 v3] RAS/tracing: Use trace_seq_buffer_ptr() helper instead of open coded Steven Rostedt
2014-11-04 19:59 ` Borislav Petkov
2014-11-05 10:29 ` Petr Mladek
2014-11-04 15:52 ` [RFC][PATCH 03/12 v3] tracing: Create seq_buf layer in trace_seq Steven Rostedt
2014-11-05 14:22 ` Petr Mladek
2014-11-05 18:41 ` Steven Rostedt
2014-11-05 20:00 ` Steven Rostedt
2014-11-05 21:17 ` Steven Rostedt
2014-11-05 21:21 ` Steven Rostedt
2014-11-06 16:33 ` Petr Mladek
2014-11-07 18:30 ` Steven Rostedt
2014-11-07 18:59 ` Joe Perches
2014-11-07 19:10 ` Steven Rostedt
2014-11-10 13:53 ` Petr Mladek
2014-11-10 17:37 ` Steven Rostedt
2014-11-10 19:02 ` Petr Mladek
2014-11-06 16:13 ` Petr Mladek
2014-11-05 14:26 ` Petr Mladek
2014-11-05 18:42 ` Steven Rostedt
2014-11-04 15:52 ` [RFC][PATCH 04/12 v3] tracing: Convert seq_buf_path() to be like seq_path() Steven Rostedt
2014-11-05 14:45 ` Petr Mladek
2014-11-05 20:10 ` Steven Rostedt
2014-11-06 14:18 ` Petr Mladek
2014-11-06 21:09 ` Steven Rostedt
2014-11-06 15:01 ` Petr Mladek
2014-11-07 18:34 ` Steven Rostedt
2014-11-10 14:03 ` Petr Mladek
2014-11-10 17:38 ` Steven Rostedt
2014-11-04 15:52 ` [RFC][PATCH 05/12 v3] tracing: Convert seq_buf fields to be like seq_file fields Steven Rostedt
2014-11-05 15:57 ` Petr Mladek
2014-11-05 20:14 ` Steven Rostedt
2014-11-06 14:24 ` Petr Mladek
2014-11-04 15:52 ` [RFC][PATCH 06/12 v3] tracing: Add a seq_buf_clear() helper and clear len and readpos in init Steven Rostedt
2014-11-05 16:00 ` Petr Mladek
2014-11-04 15:52 ` [RFC][PATCH 07/12 v3] tracing: Have seq_buf use full buffer Steven Rostedt
2014-11-05 16:31 ` Petr Mladek
2014-11-05 20:21 ` Steven Rostedt
2014-11-05 21:06 ` Steven Rostedt
2014-11-06 15:31 ` Petr Mladek
2014-11-06 19:24 ` Steven Rostedt
2014-11-07 9:11 ` Petr Mladek
2014-11-07 18:37 ` Steven Rostedt
2014-11-10 18:11 ` Petr Mladek
2014-11-06 15:13 ` Petr Mladek
2014-11-04 15:52 ` [RFC][PATCH 08/12 v3] tracing: Add seq_buf_get_buf() and seq_buf_commit() helper functions Steven Rostedt
2014-11-05 16:51 ` Petr Mladek
2014-11-05 20:26 ` Steven Rostedt
2014-11-07 18:39 ` Steven Rostedt
2014-11-10 18:33 ` Petr Mladek
2014-11-10 19:23 ` Steven Rostedt
2014-11-04 15:52 ` [RFC][PATCH 09/12 v3] seq_buf: Move the seq_buf code to lib/ Steven Rostedt
2014-11-05 16:57 ` Petr Mladek
2014-11-05 20:32 ` Steven Rostedt
2014-11-04 15:52 ` [RFC][PATCH 10/12 v3] seq-buf: Make seq_buf_bprintf() conditional on CONFIG_BINARY_PRINTF Steven Rostedt
2014-11-05 17:06 ` Petr Mladek
2014-11-05 20:33 ` Steven Rostedt
2014-11-05 20:42 ` Steven Rostedt
2014-11-06 14:39 ` Petr Mladek
2014-11-07 20:36 ` Junio C Hamano
2014-11-07 21:49 ` Steven Rostedt
2014-11-10 18:43 ` Petr Mladek
2014-11-04 15:52 ` [RFC][PATCH 11/12 v3] printk: Add per_cpu printk func to allow printk to be diverted Steven Rostedt
2014-11-06 16:56 ` Petr Mladek
2014-11-04 15:52 ` [RFC][PATCH 12/12 v3] x86/nmi: Perform a safe NMI stack trace on all CPUs Steven Rostedt
2014-11-04 23:05 ` Jiri Kosina
2014-11-04 23:41 ` Steven Rostedt
2014-11-06 18:41 ` Petr Mladek
2014-11-07 18:56 ` Steven Rostedt
2014-11-10 18:58 ` Petr Mladek [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20141110185847.GC2552@dhcp128.suse.cz \
--to=pmladek@suse.cz \
--cc=akpm@linux-foundation.org \
--cc=hpa@zytor.com \
--cc=jkosina@suse.cz \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=paulmck@linux.vnet.ibm.com \
--cc=rostedt@goodmis.org \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®