mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Steven Rostedt <rostedt@goodmis.org>
To: byungchul.park@lge.com
Cc: mingo@redhat.com, linux-kernel@vger.kernel.org,
	seungho1.park@lge.com, jolsa@redhat.com
Subject: Re: [PATCH v2 2/3] tracing, function_graph: add additional marks to signal very large function execution time
Date: Thu, 13 Nov 2014 22:32:06 -0500	[thread overview]
Message-ID: <20141113223206.04912862@gandalf.local.home> (raw)
In-Reply-To: <1415171926-9782-3-git-send-email-byungchul.park@lge.com>

On Wed,  5 Nov 2014 16:18:45 +0900
byungchul.park@lge.com wrote:
  
> +/* trace overhead mark */
> +struct trace_mark {
> +	unsigned long long val; /* unit: nsec */
> +	char sym;
> +};

Please format the above to:

struct trace_mark {
	unsigned long long		val;
	char				sym;
};

> +
> +#define DEFINE_MARK_STRUCT static const struct trace_mark mark[]

Why is this a macro?

> +#define DEFINE_MARK(v, s) {.val = v, .sym = s}
> +#define MARK(d) 							\
> +({									\
> +	int i = ARRAY_SIZE(mark);					\
> +	while ((unsigned long long)(d) <= mark[--i].val && i > 0);	\
> +	mark[i].sym;							\
> +})

Why is this a macro and not a static inline?

static inline char find_trace_mark(unsigned long long duration)
{
	int i = ARRAY_SIZE(mark);

	while (duration <= mark[--i].val && i > 0)
		;

	return make[i]. sym;
}

That's much more readable.

>  
>  /**
>   * struct tracer - a specific tracer and its callbacks to interact with debugfs
> diff --git a/kernel/trace/trace_functions_graph.c b/kernel/trace/trace_functions_graph.c
> index cb33f46..8a62907 100644
> --- a/kernel/trace/trace_functions_graph.c
> +++ b/kernel/trace/trace_functions_graph.c
> @@ -797,6 +797,14 @@ trace_print_graph_duration(unsigned long long duration, struct trace_seq *s)
>  	return TRACE_TYPE_HANDLED;
>  }
>  
> +DEFINE_MARK_STRUCT = {
> +	DEFINE_MARK(0ULL		, ' '), /* 0 usecs */
> +	DEFINE_MARK(10000ULL		, '+'), /* 10 usecs */
> +	DEFINE_MARK(100000ULL		, '!'), /* 100 usecs */
> +	DEFINE_MARK(1000000ULL		, '#'), /* 1000 usecs */
> +	DEFINE_MARK(1000000000ULL	, '$'), /* 1 sec */
> +};

Don't need to use a name as big as DEFINE_MARK. Just have:

#undef MARK
#define MARK(v, s) { .val = v, .sym = s }

struct trace_mark mark[] = {
	MARK(0ULL			, ' '), /* 0 usecs */
[...]
};

With the define directly above the call, we don't need need to be that
descriptive.

> +
>  static enum print_line_t
>  print_graph_duration(unsigned long long duration, struct trace_seq *s,
>  		     u32 flags)
> @@ -822,12 +830,7 @@ print_graph_duration(unsigned long long duration, struct trace_seq *s,
>  
>  	/* Signal a overhead of time execution to the output */
>  	if (flags & TRACE_GRAPH_PRINT_OVERHEAD) {
> -		/* Duration exceeded 100 usecs */
> -		if (duration > 100000ULL)
> -			ret = trace_seq_puts(s, "! ");
> -		/* Duration exceeded 10 usecs */
> -		else if (duration > 10000ULL)
> -			ret = trace_seq_puts(s, "+ ");
> +		ret = trace_seq_printf(s, "%c ", MARK(duration));

Then this could just be:

		ret = trace_seq_printf(s, "%c ",
				       find_trace_mark(duration));

-- Steve

>  	}
>  
>  	/*


  reply	other threads:[~2014-11-14  3:32 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-11-05  7:18 [PATCH v2 0/3] tracing: signaling large duration and delay byungchul.park
2014-11-05  7:18 ` [PATCH v2 1/3] tracing, function_graph: fix micro seconds notation in comment byungchul.park
2014-11-14  3:32   ` Steven Rostedt
2014-11-05  7:18 ` [PATCH v2 2/3] tracing, function_graph: add additional marks to signal very large function execution time byungchul.park
2014-11-14  3:32   ` Steven Rostedt [this message]
2014-11-14  6:18     ` Byungchul Park
2014-11-05  7:18 ` [PATCH v2 3/3] tracing: add additional marks to signal very large delay byungchul.park
2014-11-14  3:38   ` Steven Rostedt
2014-11-14  6:22     ` Byungchul Park

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20141113223206.04912862@gandalf.local.home \
    --to=rostedt@goodmis.org \
    --cc=byungchul.park@lge.com \
    --cc=jolsa@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=seungho1.park@lge.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®