From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755571AbbAFNwE (ORCPT ); Tue, 6 Jan 2015 08:52:04 -0500 Received: from gw-1.arm.linux.org.uk ([78.32.30.217]:47029 "EHLO pandora.arm.linux.org.uk" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1754602AbbAFNwB (ORCPT ); Tue, 6 Jan 2015 08:52:01 -0500 Date: Tue, 6 Jan 2015 13:51:29 +0000 From: Russell King - ARM Linux To: Heiko =?iso-8859-1?Q?St=FCbner?= , Andy Yan Cc: Daniel Kurtz , David Airlie , Philipp Zabel , fabio.estevam@freescale.com, Greg Kroah-Hartman , Grant Likely , Rob Herring , Shawn Guo , Josh Boyer , Sean Paul , Inki Dae , Dave Airlie , Arnd Bergmann , Lucas Stach , Zubair Lutfullah Kakakhel , Yakir Yang , "linux-kernel@vger.kernel.org" , dri-devel , devel@driverdev.osuosl.org, "open list:OPEN FIRMWARE AND..." , "open list:ARM/Rockchip SoC..." , Xu Jianqun , Pawel Moll , "mark.yao@rock-chips.com" , Mark Rutland , Ian Campbell , Kumar Gala , vladimir_zapolskiy@mentor.com Subject: Re: [PATCH v18 12/12] drm: bridge/dw_hdmi: add rockchip rk3288 support Message-ID: <20150106135129.GG12302@n2100.arm.linux.org.uk> References: <1417760564-16858-1-git-send-email-andy.yan@rock-chips.com> <1417761259-17429-1-git-send-email-andy.yan@rock-chips.com> <6479148.dVz0vTNYfK@phil> MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: <6479148.dVz0vTNYfK@phil> User-Agent: Mutt/1.5.23 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Dec 11, 2014 at 12:24:15PM +0100, Heiko Stübner wrote: > Past practices suggest that having the dw in the name is a sane solution too, > like in dw_mmc-foo (mmc/host), dwmac-foo (net/ethernet/stmicro/stmmac). > > And personally I'd keep to this already established naming scheme ... i.e. not > hiding the dw heritage. > > And also it looks like other involved parties like Philipp and Russell seemed > to be ok with the naming through the revisions till now. I don't have much of a preference when it comes to this. I was disappointed that the original imx-hdmi driver did not use "dw" in its filename, as the documentation clearly stated in several places that it was a designware part, and as we all know, they're a company which sells IP, so their designs are going to crop up in different places. So I welcome this patch set - and I've also tested it on a SolidRun Hummingboard i2ex along with all my CEC and audio patches, where it seems to be fine. So for the set: Tested-by: Russell King Apart from the two minor items I've pointed out in separate replies: Acked-by: Russell King Thanks. -- FTTC broadband for 0.8mile line: currently at 9.5Mbps down 400kbps up according to speedtest.net.