From: Richard Guy Briggs <rgb@redhat.com>
To: Calvin Owens <calvinowens@fb.com>
Cc: Eric Paris <eparis@redhat.com>,
ebiederm@xmission.com, paul@paul-moore.com,
linux-kernel@vger.kernel.org, kernel-team@fb.com,
stable@vger.kernel.org, linux-audit@redhat.com
Subject: Re: [PATCH][RESEND 2] Revert "AUDIT: Allow login in non-init namespaces"
Date: Tue, 13 Jan 2015 10:36:09 -0500 [thread overview]
Message-ID: <20150113153443.GH512@madcap2.tricolour.ca> (raw)
In-Reply-To: <20150109014448.GF27996@mail.thefacebook.com>
On 15/01/08, Calvin Owens wrote:
> This reverts 543bc6a1a987 "AUDIT: Allow login in non-init namespaces".
>
> This commit incorrectly assumes that libpam treats -ECONNREFUSED as
> an indicator that audit is disabled, and -EPERM or any other error
> as a fatal error that prevents the login from continuing.
Which netlink audit message type is actually failing?
Is it AUDIT_TTY_{G,S}ET or is it an AUDIT_USER_* message? The former
requires CAP_AUDIT_CONTROL and both PID and user init namespace (for
now) and the latter requires CAP_AUDIT_WRITE and only user init
namespace.
> The opposite is in fact true: -EPERM allows the login to continue,
> and -ECONNREFUSED causes it to refuse the login. This behavior has
> been unchanged in upstream linux-pam since at least 2008.
So this sounds to me like standard PAM usage is inverted from PAM usage
in containers.
> Reverting this change allows libpam to again work as expected in
> non-init user namespaces.
However, that will break other things...
Do you have test cases to show this?
Currently:
If audit is not available, return ECONNREFUSED. (netlink_unicast_kernel)
If not in init user namespace, return ECONNREFUSED. (audit_netlink_ok)
If control message and not init PID ns, return EPERM (audit_netlink_ok)
If control message and not CAP_AUDIT_CONTROL, return EPERM (audit_netlink_ok)
If user log message and not CAP_AUDIT_WRITE, return EPERM (audit_netlink_ok)
If unrecognized message, return EINVAL (audit_netlink_ok)
Listening in non-init net namespaces caused EPERM to be returned by
audit instead of ECONNREFUSED by netlink due to lack of perms when the
sending process didn't have CAP_AUDIT_WRITE. Fixed in docker bz1119849
http://blog.oddbit.com/2014/07/21/tracking-down-a-kernel-bug-wit/
> Signed-off-by: Calvin Owens <calvinowens@fb.com>
> Cc: stable@vger.kernel.org
> ---
> Relevant code in linux-pam:
> https://git.fedorahosted.org/cgit/linux-pam.git/tree/libpam/pam_audit.c#n56
This code only checks for an error return of -EPERM when the userid is
non-root. Is login running as root, or has it already forked and is
running as an unprivileged user at that point? Audit doesn't care about
the UID even though many equate root (superuser) with full capabilities.
Audit only looks at capabilities and namespaces. Is this relevant to PAM?
> kernel/audit.c | 12 +-----------
> 1 file changed, 1 insertion(+), 11 deletions(-)
>
> diff --git a/kernel/audit.c b/kernel/audit.c
> index 80983df..656e8ce 100644
> --- a/kernel/audit.c
> +++ b/kernel/audit.c
> @@ -640,18 +640,8 @@ static int audit_netlink_ok(struct sk_buff *skb, u16 msg_type)
> int err = 0;
>
> /* Only support initial user namespace for now. */
> - /*
> - * We return ECONNREFUSED because it tricks userspace into thinking
> - * that audit was not configured into the kernel. Lots of users
> - * configure their PAM stack (because that's what the distro does)
> - * to reject login if unable to send messages to audit. If we return
> - * ECONNREFUSED the PAM stack thinks the kernel does not have audit
> - * configured in and will let login proceed. If we return EPERM
> - * userspace will reject all logins. This should be removed when we
> - * support non init namespaces!!
> - */
> if (current_user_ns() != &init_user_ns)
> - return -ECONNREFUSED;
> + return -EPERM;
>
> switch (msg_type) {
> case AUDIT_LIST:
- RGB
--
Richard Guy Briggs <rbriggs@redhat.com>
Senior Software Engineer, Kernel Security, AMER ENG Base Operating Systems, Red Hat
Remote, Ottawa, Canada
Voice: +1.647.777.2635, Internal: (81) 32635, Alt: +1.613.693.0684x3545
next prev parent reply other threads:[~2015-01-13 15:36 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-05 0:46 [PATCH] " Calvin Owens
2014-11-18 20:32 ` [PATCH][RESEND] " Calvin Owens
2015-01-09 1:44 ` [PATCH][RESEND 2] " Calvin Owens
2015-01-09 20:33 ` Paul Moore
2015-01-09 21:24 ` Calvin Owens
2015-01-09 21:36 ` Paul Moore
2015-01-15 5:20 ` Calvin Owens
2015-01-13 15:36 ` Richard Guy Briggs [this message]
2015-01-13 16:21 ` Richard Guy Briggs
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150113153443.GH512@madcap2.tricolour.ca \
--to=rgb@redhat.com \
--cc=calvinowens@fb.com \
--cc=ebiederm@xmission.com \
--cc=eparis@redhat.com \
--cc=kernel-team@fb.com \
--cc=linux-audit@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=paul@paul-moore.com \
--cc=stable@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®