From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751351AbbCSGpX (ORCPT ); Thu, 19 Mar 2015 02:45:23 -0400 Received: from ozlabs.org ([103.22.144.67]:35084 "EHLO ozlabs.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750729AbbCSGpV (ORCPT ); Thu, 19 Mar 2015 02:45:21 -0400 In-Reply-To: <1426270496-26362-13-git-send-email-alexinbeijing@gmail.com> To: Alex Dowad , linux-kernel@vger.kernel.org From: Michael Ellerman Cc: Michael Neuling , Paul Gortmaker , Paul Mackerras , Anton Blanchard , Vineeth Vijayan , Christoph Lameter , "open list:LINUX FOR POWERPC..." Subject: Re: [23/32] powerpc: copy_thread(): rename 'arg' argument to 'kthread_arg' Message-Id: <20150319064519.6BEA814010F@ozlabs.org> Date: Thu, 19 Mar 2015 17:45:19 +1100 (AEDT) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 2015-13-03 at 18:14:46 UTC, Alex Dowad wrote: > The 'arg' argument to copy_thread() is only ever used when forking a new > kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency > with do_fork() and other arch-specific implementations of copy_thread()). I don't understand the bit about consistency with do_fork() ? Otherwise it looks fine. cheers