From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753549AbbC3Wuh (ORCPT ); Mon, 30 Mar 2015 18:50:37 -0400 Received: from mail.linuxfoundation.org ([140.211.169.12]:57691 "EHLO mail.linuxfoundation.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752383AbbC3Wuf (ORCPT ); Mon, 30 Mar 2015 18:50:35 -0400 Date: Mon, 30 Mar 2015 15:50:33 -0700 From: Andrew Morton To: Milosz Tanski Cc: Christoph Hellwig , LKML , "linux-fsdevel@vger.kernel.org" , "linux-aio@kvack.org" , Mel Gorman , Volker Lendecke , Tejun Heo , Jeff Moyer , "Theodore Ts'o" , Al Viro , Linux API , Michael Kerrisk , linux-arch@vger.kernel.org, Dave Chinner Subject: Re: [PATCH v7 0/5] vfs: Non-blockling buffered fs read (page cache only) Message-Id: <20150330155033.2cdc8d9a4a2c4ecf6a9ad154@linux-foundation.org> In-Reply-To: References: <20150326202824.65d03787.akpm@linux-foundation.org> <20150327100411.6823b9d7.akpm@linux-foundation.org> <20150330074020.GC22229@infradead.org> <20150330115414.f7900c7062fe6370cb2aea8d@linux-foundation.org> X-Mailer: Sylpheed 3.4.1 (GTK+ 2.24.23; x86_64-pc-linux-gnu) Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, 30 Mar 2015 18:40:16 -0400 Milosz Tanski wrote: > On Mon, Mar 30, 2015 at 2:54 PM, Andrew Morton > wrote: > > On Mon, 30 Mar 2015 00:40:20 -0700 Christoph Hellwig wrote: > > > >> On Fri, Mar 27, 2015 at 10:04:11AM -0700, Andrew Morton wrote: > >> > mm... I don't think we should be adding placeholders to the kernel API > >> > to support code which hasn't been written, tested, reviewed, merged, > >> > etc. It's possible none of this will ever happen and we end up with a > >> > syscall nobody needs or uses. Plus it's always possible that during > >> > this development we decide the pwrite2() interface needs alteration but > >> > it's too late. > >> > > >> > What would be the downside of deferring pwrite2() until it's all > >> > implemented? > >> > >> It _is_ implemented. I just decided to submit it separately as Miklos > >> already has to deal with enough bikeshedding for his feature that I > >> don't want to put the burden of dealing with the BS for the one I wrote > >> on him. > > > > afacit the only difference between this pwritev2() and the existing > > pwritev() is that pwritev2() interprets pos==-1 as "current position", > > which duplicates writev()? > > > > Unless I've missed something, there's no point in merging this > > pwritev2() and it would be better to separate this syscall out into a > > pwritev2() patchset which can be considered and merged separately. For > > the reasons described above. > > > > At the LSF/MM session, the agreement form the active participants > (James Bottomley, Ted Tso, Christoph, and I forget the last guy's > name) that we should ship both syscalls in the first patch. I was over in the mm session and probably wouldn't have objected either because because you can't sit down, think, carefully inspect code and evaluate arguments in such a context. I've explained my reasoning. If there's something wrong with that reasoning or if there are contradictory reasons which I'm not aware of then let's hear them!