From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756485AbbDOWGA (ORCPT ); Wed, 15 Apr 2015 18:06:00 -0400 Received: from zeniv.linux.org.uk ([195.92.253.2]:35893 "EHLO ZenIV.linux.org.uk" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753546AbbDOWFw (ORCPT ); Wed, 15 Apr 2015 18:05:52 -0400 Date: Wed, 15 Apr 2015 23:05:50 +0100 From: Al Viro To: Jens Axboe Cc: linux-kernel@vger.kernel.org, linux-fsdevel@vger.kernel.org Subject: Re: [PATCH v2] direct-io: only inc/dec inode->i_dio_count for file systems Message-ID: <20150415220550.GO889@ZenIV.linux.org.uk> References: <1429135298-17153-1-git-send-email-axboe@fb.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1429135298-17153-1-git-send-email-axboe@fb.com> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Apr 15, 2015 at 04:01:35PM -0600, Jens Axboe wrote: > Hi, > > A proper patch series posting of the patch to skip inode dio counts > where we don't need them. Performance results and general notes in > patch #1. We can take this a bit further if we want to push this > truncate locking into the caller, but I'd like to keep that as a > separate patch series instead. > > Changes since v2: > > - Changed flag to DIO_SKIP_DIO_COUNT. Patch 2+3 will use this for > skipping the extra inc/dec for btrfs and ext4, so better rename it > to something that better tells what is happening in the deep mess > that is dio. > > - Have inode_dio_inc/dec() helpers. Again, this better tells the caller > what is going on. Please, rebase on vfs.git#for-next; it conflicts (at least) with Omar's ->direct_IO() patches, if not with generic_write_checks() ones following those.