From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756183AbbEUNjj (ORCPT ); Thu, 21 May 2015 09:39:39 -0400 Received: from mail.kernel.org ([198.145.29.136]:37399 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756707AbbEUNgB (ORCPT ); Thu, 21 May 2015 09:36:01 -0400 Message-Id: <20150521133553.187649762@goodmis.org> User-Agent: quilt/0.61-1 Date: Thu, 21 May 2015 09:33:51 -0400 From: Steven Rostedt To: linux-kernel@vger.kernel.org Cc: Ingo Molnar , Andrew Morton Subject: [for-next][PATCH 18/19] tracing: Rename ftrace_define_fields_##call() to trace_event_define_fields_##call() References: <20150521133333.339981647@goodmis.org> MIME-Version: 1.0 Content-Type: text/plain; charset=ISO-8859-15 Content-Disposition: inline; filename=0018-tracing-Rename-ftrace_define_fields_-call-to-trace_e.patch Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: "Steven Rostedt (Red Hat)" The name "ftrace" really refers to the function hook infrastructure. It is not about the trace_events. The function ftrace_define_fields_##call() is used to define how to process the trace_event fields. It has nothing to do with function tracing. Rename it. Signed-off-by: Steven Rostedt --- include/trace/perf.h | 4 ++-- include/trace/trace_events.h | 2 +- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/include/trace/perf.h b/include/trace/perf.h index c9af07652f08..4ad27492a63d 100644 --- a/include/trace/perf.h +++ b/include/trace/perf.h @@ -65,7 +65,7 @@ * * static struct trace_event_class __used event_class_