From: Liviu Dudau <Liviu.Dudau@arm.com>
To: Jiang Liu <jiang.liu@linux.intel.com>
Cc: "hanjun.guo@linaro.org" <hanjun.guo@linaro.org>,
Bjorn Helgaas <bhelgaas@google.com>,
Arnd Bergmann <arnd@arndb.de>,
Catalin Marinas <Catalin.Marinas@arm.com>,
Will Deacon <Will.Deacon@arm.com>,
"Rafael J. Wysocki" <rjw@rjwysocki.net>,
Thomas Gleixner <tglx@linutronix.de>,
Yijing Wang <wangyijing@huawei.com>,
Lorenzo Pieralisi <Lorenzo.Pieralisi@arm.com>,
Tomasz Nowicki <tomasz.nowicki@linaro.org>,
"suravee.suthikulpanit@amd.com" <suravee.suthikulpanit@amd.com>,
"msalter@redhat.com" <msalter@redhat.com>,
"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
"linux-acpi@vger.kernel.org" <linux-acpi@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linaro-acpi@lists.linaro.org" <linaro-acpi@lists.linaro.org>
Subject: Re: [PATCH 01/11] ARM64 / PCI: introduce struct pci_controller for ACPI
Date: Wed, 27 May 2015 10:47:02 +0100 [thread overview]
Message-ID: <20150527094702.GE2175@e106497-lin.cambridge.arm.com> (raw)
In-Reply-To: <5564AB68.6080502@linux.intel.com>
On Tue, May 26, 2015 at 06:20:40PM +0100, Jiang Liu wrote:
> On 2015/5/27 0:58, Liviu Dudau wrote:
> > On Tue, May 26, 2015 at 01:49:14PM +0100, Hanjun Guo wrote:
> >> ARM64 ACPI based PCI host bridge init needs a arch dependent
> >> struct pci_controller to accommodate common PCI host bridge
> >> code which is introduced later, or it will lead to compile
> >> errors on ARM64.
> >
> > Hi Hanjun,
> >
> > Two questions: why don't you introduce this patch next to the
> > one that is going to make use of it (or even merge it there)?
> > Second, why is the whole struct pci_controller not surrounded
> > by #ifdef CONFIG_ACPI as you are implying that this is needed
> > only for ACPI?
> >
> > Btw, looking through the whole series I'm not (yet) convinced
> > that this is needed at all.
> Hi Liviu,
> This structure is required by the requested patch set
> at http://patchwork.ozlabs.org/patch/472249/, which consolidates
> the common code to support PCI host bridge into ACPI core.
> Thanks!
> Gerry
Hi Jiang,
Thanks for pointing me on the right answer, I've missed that series!
Probably not the best place to comment on that series here, but I
wonder why did you not made the pci_controller structure available
in a more generic header file that can be included so that arches
don't have to redefine the structure every time. After all, you are
trying to consolidate things.
Oh, and pci_controller name throws a lot of false negatives, maybe
a more specific one (acpi_pci_controller?) would make things clear?
Best regards,
Liviu
>
> >
> > Best regards,
> > Liviu
> >
> >>
> >> Signed-off-by: Hanjun Guo <hanjun.guo@linaro.org>
> >> Tested-by: Suravee Suthikulpanit <Suravee.Suthikulpanit@amd.com>
> >> CC: Arnd Bergmann <arnd@arndb.de>
> >> CC: Catalin Marinas <catalin.marinas@arm.com>
> >> CC: Liviu Dudau <Liviu.Dudau@arm.com>
> >> CC: Lorenzo Pieralisi <Lorenzo.Pieralisi@arm.com>
> >> CC: Will Deacon <will.deacon@arm.com>
> >> ---
> >> arch/arm64/include/asm/pci.h | 10 ++++++++++
> >> 1 file changed, 10 insertions(+)
> >>
> >> diff --git a/arch/arm64/include/asm/pci.h b/arch/arm64/include/asm/pci.h
> >> index b008a72..7088495 100644
> >> --- a/arch/arm64/include/asm/pci.h
> >> +++ b/arch/arm64/include/asm/pci.h
> >> @@ -10,6 +10,16 @@
> >> #include <asm-generic/pci-bridge.h>
> >> #include <asm-generic/pci-dma-compat.h>
> >>
> >> +struct acpi_device;
> >> +
> >> +struct pci_controller {
> >> +#ifdef CONFIG_ACPI
> >> + struct acpi_device *companion; /* ACPI companion device */
> >> +#endif
> >> + int segment; /* PCI domain */
> >> + int node; /* NUMA node */
> >> +};
> >> +
> >> #define PCIBIOS_MIN_IO 0x1000
> >> #define PCIBIOS_MIN_MEM 0
> >>
> >> --
> >> 1.9.1
> >>
> >
>
--
====================
| I would like to |
| fix the world, |
| but they're not |
| giving me the |
\ source code! /
---------------
¯\_(ツ)_/¯
next prev parent reply other threads:[~2015-05-27 9:47 UTC|newest]
Thread overview: 61+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-05-26 12:49 [PATCH 00/11] ARM64 PCI hostbridge init based on ACPI Hanjun Guo
2015-05-26 12:49 ` [PATCH 01/11] ARM64 / PCI: introduce struct pci_controller for ACPI Hanjun Guo
2015-05-26 16:58 ` Liviu Dudau
2015-05-26 17:20 ` Jiang Liu
2015-05-27 8:21 ` Hanjun Guo
2015-09-07 4:14 ` Ganapatrao Kulkarni
2015-09-07 8:45 ` Lorenzo Pieralisi
2015-09-08 13:35 ` Hanjun Guo
2015-05-27 9:47 ` Liviu Dudau [this message]
2015-05-27 11:29 ` Jiang Liu
2015-05-26 12:49 ` [PATCH 02/11] x86, pci: Clean up comment about buggy MMIO config space access for AMD Fam10h CPUs Hanjun Guo
2015-08-31 12:04 ` Tomasz Nowicki
2015-05-26 12:49 ` [PATCH 03/11] x86, pci: Abstract PCI config accessors and use AMD Fam10h workaround exclusively Hanjun Guo
2015-05-26 12:49 ` [PATCH 04/11] x86, pci: Reorder logic of pci_mmconfig_insert() function Hanjun Guo
2015-05-26 12:49 ` [PATCH 05/11] x86, pci, acpi: Move arch-agnostic MMCONFIG (aka ECAM) and ACPI code out of arch/x86/ directory Hanjun Guo
2015-05-26 17:08 ` Will Deacon
2015-05-27 8:06 ` Tomasz Nowicki
2015-06-02 13:32 ` Lorenzo Pieralisi
2015-06-04 9:28 ` Hanjun Guo
2015-06-04 10:22 ` Lorenzo Pieralisi
2015-06-04 12:28 ` Hanjun Guo
2015-06-08 2:57 ` Hanjun Guo
2015-06-08 15:14 ` Lorenzo Pieralisi
2015-08-31 11:01 ` Tomasz Nowicki
2015-09-07 9:59 ` Tomasz Nowicki
2015-09-08 15:07 ` Lorenzo Pieralisi
2015-09-09 13:47 ` Tomasz Nowicki
2015-09-11 11:20 ` Lorenzo Pieralisi
2015-09-11 12:35 ` Tomasz Nowicki
2015-09-14 9:37 ` Lorenzo Pieralisi
2015-09-14 11:34 ` Tomasz Nowicki
2015-09-14 14:55 ` Tomasz Nowicki
2015-09-25 16:02 ` Tomasz Nowicki
2015-09-25 16:19 ` Lorenzo Pieralisi
2015-10-15 13:22 ` Lorenzo Pieralisi
2015-10-15 14:34 ` Tomasz Nowicki
2015-10-15 16:26 ` Marc Zyngier
2015-10-15 18:51 ` Tomasz Nowicki
2015-05-26 12:49 ` [PATCH 06/11] pci, acpi, mcfg: Provide generic implementation of MCFG code initialization Hanjun Guo
2015-05-26 12:49 ` [PATCH 07/11] x86, pci: mmconfig_{32,64}.c code refactoring - remove code duplication Hanjun Guo
2015-05-26 12:49 ` [PATCH 08/11] x86, pci, ecam: mmconfig_64.c becomes default implementation for ECAM driver Hanjun Guo
2015-05-26 12:49 ` [PATCH 09/11] pci, acpi, mcfg: Share ACPI PCI config space accessors Hanjun Guo
2015-05-26 12:49 ` [PATCH 10/11] XEN / PCI: Remove the dependence on arch x86 when PCI_MMCONFIG=y Hanjun Guo
2015-05-26 13:54 ` Boris Ostrovsky
2015-05-26 14:00 ` Boris Ostrovsky
2015-05-26 14:54 ` Tomasz Nowicki
2015-05-26 15:44 ` Boris Ostrovsky
2015-05-27 3:55 ` Hanjun Guo
2015-05-26 12:49 ` [PATCH 11/11] ARM64 / PCI / ACPI: support for ACPI based PCI hostbridge init Hanjun Guo
2015-05-26 15:12 ` Tomasz Nowicki
2015-05-27 7:31 ` Hanjun Guo
2015-05-26 17:13 ` Will Deacon
2015-05-26 17:24 ` Jiang Liu
2015-05-27 0:30 ` [PATCH 00/11] ARM64 PCI hostbridge init based on ACPI Rafael J. Wysocki
2015-05-27 3:57 ` Hanjun Guo
2015-06-08 12:05 ` Jagan Teki
2015-06-10 2:47 ` Hanjun Guo
2015-10-15 19:15 ` Jon Masters
2015-10-15 23:42 ` Hanjun Guo
2015-10-15 23:49 ` Jon Masters
2015-12-07 20:29 ` Bjorn Helgaas
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150527094702.GE2175@e106497-lin.cambridge.arm.com \
--to=liviu.dudau@arm.com \
--cc=Catalin.Marinas@arm.com \
--cc=Lorenzo.Pieralisi@arm.com \
--cc=Will.Deacon@arm.com \
--cc=arnd@arndb.de \
--cc=bhelgaas@google.com \
--cc=hanjun.guo@linaro.org \
--cc=jiang.liu@linux.intel.com \
--cc=linaro-acpi@lists.linaro.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=msalter@redhat.com \
--cc=rjw@rjwysocki.net \
--cc=suravee.suthikulpanit@amd.com \
--cc=tglx@linutronix.de \
--cc=tomasz.nowicki@linaro.org \
--cc=wangyijing@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®