mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Tejun Heo <tj@kernel.org>
To: Aleksa Sarai <cyphar@cyphar.com>
Cc: lizefan@huawei.com, mingo@redhat.com, peterz@infradead.org,
	richard@nod.at, fweisbec@gmail.com, linux-kernel@vger.kernel.org,
	cgroups@vger.kernel.org
Subject: Re: [PATCH v13 5/5] cgroup: implement the PIDs subsystem
Date: Tue, 9 Jun 2015 13:56:32 +0900	[thread overview]
Message-ID: <20150609045632.GR21465@mtj.duckdns.org> (raw)
In-Reply-To: <1433548938-32560-5-git-send-email-cyphar@cyphar.com>

Hello, Aleksa.

On Sat, Jun 06, 2015 at 10:02:18AM +1000, Aleksa Sarai wrote:
...
> +/*
> + * Lockless hierarchical accounting (with enforceable limits) derived from
> + * mm/page_counter.c. Original copyright notice from page_counter code:
> + *
> + * -------------------------------------------------
> + * Lockless hierarchical page accounting & limiting
> + * Copyright (C) 2014 Red Hat, Inc., Johannes Weiner
> + * -------------------------------------------------
> + */

I don't think we need the above copyright notice.

...
> +struct cgroup_subsys pids_cgrp_subsys = {
> +	.css_alloc	= pids_css_alloc,
> +	.css_free	= pids_css_free,
> +	.attach		= pids_attach,
> +	.can_attach 	= pids_can_attach,
> +	.cancel_attach 	= pids_cancel_attach,
> +	.can_fork	= pids_can_fork,
> +	.cancel_fork	= pids_cancel_fork,
> +	.fork		= pids_fork,
> +	.exit		= pids_exit,
> +	.legacy_cftypes	= files,

Please also init dfl_cftypes the same way too.  Also, can you please
rename files to pids_files?

> +	.early_init	= 0,

And the above can be dropped.

Other than the above minor points, everything looks good to me but I
think we're a bit too close to the merge window to put this in now.
Once you update patch 4 and 5 according to the review, I'll apply them
after the next rc1 drops.

Thanks.

-- 
tejun

      reply	other threads:[~2015-06-09  4:56 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-06-05 23:42 [PATCH v13 0/5] cgroup: add " Aleksa Sarai
2015-06-06  0:02 ` [PATCH v13 1/5] cgroup: use bitmask to filter for_each_subsys Aleksa Sarai
2015-06-06  0:02 ` [PATCH v13 2/5] cgroup: replace explicit ss_mask checking with for_each_subsys_which Aleksa Sarai
2015-06-08  9:21   ` Tejun Heo
2015-06-06  0:02 ` [PATCH v13 3/5] cgroup, block: implement task_get_css() Aleksa Sarai
2015-06-08  9:22   ` Tejun Heo
2015-06-06  0:02 ` [PATCH v13 4/5] cgroup: allow a cgroup subsystem to reject a fork Aleksa Sarai
2015-06-09  4:41   ` Tejun Heo
2015-06-09  7:20     ` Aleksa Sarai
2015-06-09  7:23       ` Tejun Heo
2015-06-06  0:02 ` [PATCH v13 5/5] cgroup: implement the PIDs subsystem Aleksa Sarai
2015-06-09  4:56   ` Tejun Heo [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150609045632.GR21465@mtj.duckdns.org \
    --to=tj@kernel.org \
    --cc=cgroups@vger.kernel.org \
    --cc=cyphar@cyphar.com \
    --cc=fweisbec@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lizefan@huawei.com \
    --cc=mingo@redhat.com \
    --cc=peterz@infradead.org \
    --cc=richard@nod.at \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®