From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753273AbbFQEPp (ORCPT ); Wed, 17 Jun 2015 00:15:45 -0400 Received: from mx0b-00082601.pphosted.com ([67.231.153.30]:38968 "EHLO mx0b-00082601.pphosted.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750841AbbFQEPi (ORCPT ); Wed, 17 Jun 2015 00:15:38 -0400 Date: Tue, 16 Jun 2015 21:15:24 -0700 From: Martin KaFai Lau To: Larry Finger CC: Tejun Heo , Catalin Marinas , Christoph Lameter , , , Kernel Team Subject: Re: [RFC NEXT] mm: Fix suspicious RCU usage at kernel/sched/core.c:7318 Message-ID: <20150617041524.GD3958923@devbig242.prn2.facebook.com> References: <1434403518-5308-1-git-send-email-Larry.Finger@lwfinger.net> <20150616210720.GC3958923@devbig242.prn2.facebook.com> <5580DED0.3060002@lwfinger.net> MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Disposition: inline In-Reply-To: <5580DED0.3060002@lwfinger.net> User-Agent: Mutt/1.5.20 (2009-12-10) X-Originating-IP: [192.168.52.123] X-Proofpoint-Spam-Reason: safe X-FB-Internal: Safe X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:5.14.151,1.0.33,0.0.0000 definitions=2015-06-17_02:2015-06-16,2015-06-17,1970-01-01 signatures=0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, Jun 16, 2015 at 09:43:28PM -0500, Larry Finger wrote: > On 06/16/2015 04:07 PM, Martin KaFai Lau wrote: > >On Mon, Jun 15, 2015 at 04:25:18PM -0500, Larry Finger wrote: > >>Additional backtrace lines are truncated. In addition, the above splat is > >>followed by several "BUG: sleeping function called from invalid context > >>at mm/slub.c:1268" outputs. As suggested by Martin KaFai Lau, these are the > >>clue to the fix. Routine kmemleak_alloc_percpu() always uses GFP_KERNEL > >>for its allocations, whereas it should use the value input to pcpu_alloc(). > >Just a minor nit, 'kmemleak_alloc_percpu() should follow the gfp from > >per_alloc()' may be a more accurate title to describe the patch. > > Do you mean that the subject should be changed? Yes A typo in my last response: s/per_alloc/pcpu_alloc/ --Martin