From: Ingo Molnar <mingo@kernel.org>
To: "H. Peter Anvin" <hpa@zytor.com>
Cc: brgerst@gmail.com, linux-kernel@vger.kernel.org,
peterz@infradead.org, bp@alien8.de, tglx@linutronix.de,
akpm@linux-foundation.org, torvalds@linux-foundation.org,
dvlasenk@redhat.com, luto@amacapital.net,
linux-tip-commits@vger.kernel.org
Subject: [RFC] Rename various 'IA32' uses in arch/x86/ code
Date: Thu, 18 Jun 2015 18:49:12 +0200 [thread overview]
Message-ID: <20150618164912.GA8557@gmail.com> (raw)
In-Reply-To: <55808579.4050004@zytor.com>
* H. Peter Anvin <hpa@zytor.com> wrote:
> On 06/08/2015 03:24 PM, tip-bot for Ingo Molnar wrote:
> > Commit-ID: bace7117d3fb59a6ed7ea1aa6c8994df6a28a72a
> > Gitweb: http://git.kernel.org/tip/bace7117d3fb59a6ed7ea1aa6c8994df6a28a72a
> > Author: Ingo Molnar <mingo@kernel.org>
> > AuthorDate: Mon, 8 Jun 2015 21:20:26 +0200
> > Committer: Ingo Molnar <mingo@kernel.org>
> > CommitDate: Mon, 8 Jun 2015 23:43:38 +0200
> >
> > x86/asm/entry: (Re-)rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max
> >
> > Brian Gerst noticed that I did a weird rename in the following commit:
> >
> > b2502b418e63 ("x86/asm/entry: Untangle 'system_call' into two entry points: entry_SYSCALL_64 and entry_INT80_32")
> >
> > which renamed __NR_ia32_syscall_max to __NR_entry_INT80_compat_max.
> >
> > Now the original name was a misnomer, but the new one is a misnomer as well,
> > as all the 32-bit compat syscall entry points (sysenter, syscall) share the
> > system call table, not just the INT80 based one.
> >
> > Rename it to __NR_syscall_compat_max.
> >
>
> The original one wasn't really a misnomer, as it referred to the ia32
> system calls specifically, but this works too.
It was a misnomer, because what are the 'ia32 system calls'? We have no Intel
specific system calls!
The term 'IA32' (Intel Architecture 32-bit) is a misnomer in many existing
arch/x86/ symbol, function and file names, and most of them should be renamed.
Some common examples, with a suggested rename target:
stack_frame_ia32 -> stack_frame_compat
IA32_RT_SIGFRAME_sigcontext -> COMPAT_RT_SIGFRAME_sigcontext
sigcontext_ia32 -> sigcontext_compat
user_i387_ia32_struct -> user_i387_compat_struct
TIF_IA32 -> TIF_COMPAT
and here a few 'ia32' misnomers that should be addressed not via simple renames,
but via transformations to existing compat facilities:
CONFIG_IA32_EMULATION -> partly eliminate, partly covert to CONFIG_COMPAT use
is_ia32_task() -> convert to is_compat_task() use
This holds for file names as well, for example:
arch/x86/ia32/ -> arch/x86/compat/
arch/x86/ia32/ia32_aout.c -> arch/x86/compat/aout.c
arch/x86/ia32/ia32_signal.c -> arch/x86/compat/signal.c
arch/x86/ia32/sys_ia32.c -> arch/x86/compat/sys.c
There are a number of symbols where the 'IA32' name is probably fine: for example
the various Intel-specific MSR names - or even cross-CPU MSR names that AMD uses
but which got first introduced on Intel CPUs.
For generic names that deal with 32-bit compat, 'ia32' is a misnomer.
If there's consensus for the above (re-)naming schemes I can start doing them.
Thanks,
Ingo
next prev parent reply other threads:[~2015-06-18 16:49 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <tip-bace7117d3fb59a6ed7ea1aa6c8994df6a28a72a@git.kernel.org>
2015-06-16 20:22 ` [tip:x86/asm] x86/asm/entry: (Re-) rename __NR_entry_INT80_compat_max to __NR_syscall_compat_max H. Peter Anvin
2015-06-18 16:49 ` Ingo Molnar [this message]
2015-06-18 17:49 ` [RFC] Rename various 'IA32' uses in arch/x86/ code Brian Gerst
2015-06-18 19:37 ` H. Peter Anvin
2015-06-19 7:13 ` Ingo Molnar
2015-06-19 17:19 ` H. Peter Anvin
2015-06-21 13:44 ` Ingo Molnar
[not found] ` <CA+55aFzKOyZ4ZA6zFvCNqqqkYT8hLQOXAgJRj-k+LRqvQ1iiyQ@mail.gmail.com>
2015-06-18 19:41 ` H. Peter Anvin
2015-06-18 21:13 ` Ingo Molnar
2015-06-18 22:11 ` Brian Gerst
2015-06-19 7:08 ` Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150618164912.GA8557@gmail.com \
--to=mingo@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=bp@alien8.de \
--cc=brgerst@gmail.com \
--cc=dvlasenk@redhat.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=luto@amacapital.net \
--cc=peterz@infradead.org \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome