From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751376AbbF2Lr1 (ORCPT ); Mon, 29 Jun 2015 07:47:27 -0400 Received: from bombadil.infradead.org ([198.137.202.9]:60180 "EHLO bombadil.infradead.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752491AbbF2LrV (ORCPT ); Mon, 29 Jun 2015 07:47:21 -0400 Date: Mon, 29 Jun 2015 13:47:14 +0200 From: Peter Zijlstra To: Adrian Hunter Cc: Jiri Olsa , Arnaldo Carvalho de Melo , Kan Liang , lkml , David Ahern , Ingo Molnar , Namhyung Kim Subject: Re: [PATCH perf/core] perf tools: Add missing break for PERF_RECORD_ITRACE_START Message-ID: <20150629114714.GG19282@twins.programming.kicks-ass.net> References: <1435576340-19346-1-git-send-email-jolsa@kernel.org> <5591293E.80308@intel.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <5591293E.80308@intel.com> User-Agent: Mutt/1.5.21 (2012-12-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Jun 29, 2015 at 02:17:18PM +0300, Adrian Hunter wrote: > On 29/06/15 14:12, Jiri Olsa wrote: > > Missing switch break since introduction of new event: > > c4937a91ea56 perf tools: handle PERF_RECORD_LOST_SAMPLES > > > > Cc: Kan Liang > > Cc: Adrian Hunter > > Link: http://lkml.kernel.org/n/tip-e3gbrp2561x2s9tkqvf2wh9n@git.kernel.org > > Signed-off-by: Jiri Olsa > > --- > > tools/perf/util/machine.c | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/tools/perf/util/machine.c b/tools/perf/util/machine.c > > index 4744673aff1b..a08e38339cac 100644 > > --- a/tools/perf/util/machine.c > > +++ b/tools/perf/util/machine.c > > @@ -1448,7 +1448,7 @@ int machine__process_event(struct machine *machine, union perf_event *event, > > case PERF_RECORD_AUX: > > ret = machine__process_aux_event(machine, event); break; > > case PERF_RECORD_ITRACE_START: > > - ret = machine__process_itrace_start_event(machine, event); > > + ret = machine__process_itrace_start_event(machine, event); break; > > case PERF_RECORD_LOST_SAMPLES: > > ret = machine__process_lost_samples_event(machine, event, sample); break; > > break; > > But now you have break; break; > > Isn't putting 'break' on the end of the line making things harder to read? I would tend to agree, its a very odd style.