From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754660AbbGFL1B (ORCPT ); Mon, 6 Jul 2015 07:27:01 -0400 Received: from casper.infradead.org ([85.118.1.10]:44820 "EHLO casper.infradead.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753820AbbGFL07 (ORCPT ); Mon, 6 Jul 2015 07:26:59 -0400 Date: Mon, 6 Jul 2015 13:26:53 +0200 From: Peter Zijlstra To: byungchul.park@lge.com Cc: mingo@kernel.org, minchan.kim@lge.com, linux-kernel@vger.kernel.org Subject: Re: [PATCH 1/1] sched: make update_min_vruntime() more readable Message-ID: <20150706112653.GC3644@twins.programming.kicks-ass.net> References: <1436088829-25768-1-git-send-email-byungchul.park@lge.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1436088829-25768-1-git-send-email-byungchul.park@lge.com> User-Agent: Mutt/1.5.21 (2012-12-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Sun, Jul 05, 2015 at 06:33:48PM +0900, byungchul.park@lge.com wrote: > From: Byungchul Park > > update_min_vruntime() condition flow can be simpler This changelog needs help; a few more words on why this is correct and simpler would not go amiss, and you should mention you're deleting some spurious trailing whitespace. > Signed-off-by: Byungchul Park > --- > kernel/sched/fair.c | 17 +++++++---------- > 1 file changed, 7 insertions(+), 10 deletions(-) > > diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c > index 3d57cc0..59de964 100644 > --- a/kernel/sched/fair.c > +++ b/kernel/sched/fair.c > @@ -463,20 +463,17 @@ static void update_min_vruntime(struct cfs_rq *cfs_rq) > { > u64 vruntime = cfs_rq->min_vruntime; > > - if (cfs_rq->curr) > - vruntime = cfs_rq->curr->vruntime; > - > if (cfs_rq->rb_leftmost) { > struct sched_entity *se = rb_entry(cfs_rq->rb_leftmost, > struct sched_entity, > run_node); > > - if (!cfs_rq->curr) > - vruntime = se->vruntime; > - else > - vruntime = min_vruntime(vruntime, se->vruntime); > + vruntime = se->vruntime; > } > > + if (cfs_rq->curr) > + vruntime = min_vruntime(vruntime, cfs_rq->curr->vruntime); > + > /* ensure we never gain time by being placed backwards. */ > cfs_rq->min_vruntime = max_vruntime(cfs_rq->min_vruntime, vruntime); > #ifndef CONFIG_64BIT