From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751988AbbGOHau (ORCPT ); Wed, 15 Jul 2015 03:30:50 -0400 Received: from metis.ext.pengutronix.de ([92.198.50.35]:38011 "EHLO metis.ext.pengutronix.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751565AbbGOHat convert rfc822-to-8bit (ORCPT ); Wed, 15 Jul 2015 03:30:49 -0400 From: Juergen Borleis Organization: Pengutronix e.K. To: Stefan Wahren Subject: Re: [PATCH] serial: mxs-auart: keep the AUART unit in reset state when not in use Date: Wed, 15 Jul 2015 09:34:07 +0200 User-Agent: KMail/1.9.10 (enterprise35 0.20100827.1168748) Cc: linux-serial@vger.kernel.org, kernel@pengutronix.de, "Greg Kroah-Hartman" , Jiri Slaby , linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org References: <1436884864-6782-1-git-send-email-jbe@pengutronix.de> <1463261573.74606.1436895184420.JavaMail.open-xchange@oxbsltgw03.schlund.de> In-Reply-To: <1463261573.74606.1436895184420.JavaMail.open-xchange@oxbsltgw03.schlund.de> X-KMail-QuotePrefix: > MIME-Version: 1.0 Content-Type: Text/Plain; charset="utf-8" Content-Transfer-Encoding: 8BIT Content-Disposition: inline Message-Id: <201507150934.07249.jbe@pengutronix.de> X-SA-Exim-Connect-IP: 2001:67c:670:201:5054:ff:fe8d:eefb X-SA-Exim-Mail-From: jbe@pengutronix.de X-SA-Exim-Scanned: No (on metis.ext.pengutronix.de); SAEximRunCond expanded to false X-PTX-Original-Recipient: linux-kernel@vger.kernel.org Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Stefan, On Tuesday 14 July 2015 19:33:04 Stefan Wahren wrote: > [...] > > diff --git a/drivers/tty/serial/mxs-auart.c > > b/drivers/tty/serial/mxs-auart.c index 13cf773..f42b6ad 100644 > > --- a/drivers/tty/serial/mxs-auart.c > > +++ b/drivers/tty/serial/mxs-auart.c > > @@ -858,6 +858,30 @@ static void mxs_auart_reset(struct uart_port *u) > > writel(AUART_CTRL0_CLKGATE, u->membase + AUART_CTRL0_CLR); > > } > > > > +static void mxs_auart_do_reset(struct uart_port *u) > > i think the naming of this new function is too similiar to > mxs_auart_reset() and doesn't represent the exact behavior. How about > mxs_auart_keep_reset() or mxs_auart_gate()? Hmm, maybe mxs_auart_reset() should be renamed instead, because it terminates the reset to this unit and make it work (called when the driver's probe function is running). But okay, mxs_auart_keep_reset() names more what it really does. > [...] > > + udelay(10); > > The delay in mxs_auart_reset() has a value of 3 microseconds. Why not the > same here? Hmm, good question. And why 3 us? :) I'm going to change it to 3 us as well. > [...] > > + /* reset the unit if not aready done */ > > Just a typo: already? Ups. Yes. Will fix. Thanks! Juergen -- Pengutronix e.K.                              | Juergen Borleis             | Industrial Linux Solutions                    | http://www.pengutronix.de/  |